Contents

Navigation: Overview >

Contents

The following Help Topics are available:

Credits and How to cite NTSYSpc.

How to get started using NTSYSpc

Modes of operation

Interactive mode

Batch mode

Output Listing Window

Ntedit, a data editor

Configuration window and file

Preparation of input data files

File formats

Examples of files

Importing and exporting data to other programs

Graphics:

Plot options

General plot options

Plot menu

Computational modules in NTSYSpc:

Examples of typical applications and batch files

techsupp Technical support

Updates to NTSYSpc

References

Compiled 9/10/2018


Credits

Navigation: Credits >

Credits

Programming and other assistance with NTSYSpc:
Dean Adams | Made numerous suggestions for improvements.
Junhyong Kim | Some of the computational algorithms in CONSEN module.
Richard Jensen | Beta tested and made suggestions for improvements to many versions.
Les Marcus | Made numerous helpful suggestions
Dennis E. Slice | Development of the “graphics engine”.
Jeff Walker | Conversion of FORTRAN routines for common principal components analysis to Pascal.


How to cite NTSYSpc?

Navigation: Credits >

How to cite NTSYSpc?

The exact format will depend on the policies of the journal but the following format is common:

Rohlf, F. J. 2018. NTSYSpc: numerical taxonomy system. ver. 2.21c. Applied Biostatistics, Inc.: Port Jefferson: New York.

Please update the date and the version number as appropriate for the actual software that you are using.


How to use this program

Navigation: Introduction >

How to use this program

The style of usage of NTSYSpc is somewhat different from other statistical packages. One does not read in a data file and then apply various operations on it. In NTSYSpc one loads the desired computational module and then selects the data files needed by that module. The results of the computations are usually additional files that can be used as input to other modules. This makes NTSYSpc very flexible and thus useful for a wide variety of analyses but it does take some effort to learn how to use it efficiently. To perform an operation, select the main category from the left of the main NTSYSpc window, then select the desired program module button from the list at the left. There is also a listing notebook window but it will be empty until you actually perform some computation (by clicking on the “Compute” button).

There are test data sets so you can try a few simple operations right away (enter the name TEST.NTS into the first field of the Output Parameter Entry Window shown above (or click on the field to bring up a file open dialog box. Then click on the Compute button to run this program. The results are displayed in the Listing Notebook Window. Next, you should look at Modes of operation, to learn how to use NTSYSpc in both interactive and batch modes. Then read the section on preparation of input data files to see how to prepare input data files.

The installation process associates the “.NTS” extension with the NTedit program. This means that double-clicking on a file in Windows Explorer will load that file into NTedit. NTedit is also placed in the Windows “Send to” folder which means that you can edit a file by right-clicking on the file name and then selecting “NTedit” from the “Send to” submenu. The “.NTB” extension is associated with the NTSYSpc program itself so that you can run an NTSYSpc batch file by just double-clicking on it in the Windows Explorer. It is possible to use other file name extensions for the NTS files (unrecognized file types are assumed to be NTS files) but this should be avoided because one may accidentally use one of the other defined file extensions that would prevent NTSYSpc from properly reading the file. It also prevents the NTedit program from being loaded automatically when a file name is double-clicked.

Unlike many statistics programs, one cannot get a complete analysis by pressing a single button. NTSYSpc consists of a number of separate program modules and most analyses require one to use several modules in sequence. See the Typical applications section for examples. Each module reads one or more input files containing the matrices to be operated upon and then produces an output listing and one or more output files or a "plot." The output files are formatted so that they can be read as input by other modules in NTSYSpc. With editing, they can also be read by many other programs since they are simple ASCII files (not binary files) and have a simple format. The plots can not only be printed they can be copied to the Windows clipboard and pasted into other programs such as Word where they can be edited. The can also be saved to disk as an enhanced Windows metafile (*.EMF).

Be sure to check the README.TXT file for any last-minute notes. The registration card should also be filled-out and returned. It will allow us to better know the types of users of this software – this helps plan for new features to add to the software. Note: you should check Applied Biostatistic’s website to download any new service releases (these minor updates are free). Your comments, corrections, and suggestions about the program are welcomed - they will help set priorities for the addition of new features.

For convenience, computational modules are often referred to using their batch code names. These names are provided in parentheses in the help Table of Contents and in the heading for their corresponding help topic. A list can also be found under the “Batch” keyword in the help index. Most modules in NTSYSpc do not have explicit dimension limits for objects or variables. Some programs, like MDSCALE, must manipulate many matrices simultaneously and hence are much more limited in the sizes of matrices they can handle (512 variables is the maximum for MDSCALE).


NTSYSpc main window

Navigation: Introduction >

NTSYSpc main window

Help is available for the following major topics:

Overview of how to use NTSYSpc

Modes of operation

Main menu

Configuration window

Statistical modules available

Typical applications


Main menu

Navigation: Introduction >

Main menu

Across the top of the main window is a menu bar. The various choices are described below.

File A submenu from which you can select “Edit data file,” “View listing,” “Printer setup,” “Run batch file,” and “Exit.” The edit menu item displays a file open dialog in which you can specify the name of the NTSYSpc file you wish to edit. The program NTedit is then run. If the file is a type supported by NTSYSpc then it will be displayed in a spreadsheet like format. If there are any errors in reading the file then an alternative ASCII editor (such as the Windows notepad or some other user selectable editor) will be run. The view listing item opens the Listing window. The printer setup item opens the standard Windows printer setup dialog box. The run batch file item brings up the Batch mode dialog box so that a batch file can be run. The exit item closes the program (the program can also be closed by clicking on the Close speed button on the tool bar.
Options A submenu from which you can select “Configuration”, “Restore defaults”, ”. The configuration item will display a parameter entry form for various program configuration options. It will also allow you to define the contents of the User folder (convenient for quick access to the modules you use most frequently). The restore defaults item will reset the configuration parameters back to their original states. You can also select the old “classic” interface.
Help A submenu from which you can select “Contents,” “Topic search,” or “About.” The contents item displays the table of contents for the help file. Topic search brings up the Help topics dialog box in which you can search for various terms. The “About” item displays the NTSYSpc “about box” showing copyright information, version number, and the registration number.


Output listing window

Navigation: Introduction >

Output listing window

This window uses a notebook metaphor to display listing output from the computational modules. Each time a module is run a new section is created with an index tab numbered in sequence and labeled by the name of the module. A section can be examined by clicking on a tab and then moving the scrollbars. Note that the entire window can be resized. An example is shown below.

The File menu provides a number of important operations. The entire “notebook” can be reloaded from a previous run, saved to an ASCII file, cleared (i.e., deleted), or printed. Alternatively, the currently displayed section of the notebook can be saved to an ASCII file, deleted, or printed.

The Edit menu provides commands to select all the text in the current notebook section, to cut or copy selected text to the Windows clipboard, and to paste in text from the clipboard. These commands permit you to copy results into other software such as a wordprocessor. They also allow you to delete unwanted information before printing or saving to a disk file. Keeping such notebooks is a convenient way to verify which options were used to produce a certain result. The purpose of reloading a notebook is to allow the appending of new results so that a record of all the computations for a particular project can be kept together. The file format is simply an ASCII file with the form feed character separating sections.

The Options menu allows you to change the font used both for the on-screen display and for printing. The indent item controls the size of the left margin when printing.

The Help menu provides the standard contents, topic search, and about items.


Configuration window

Navigation: Introduction >

Configuration window

There are a number of aspects of how NTSYSpc operates that can be modified by a user. These are done from the Configuration Window (select “Configuration” under the Option menu on the main window). This will display a window like those used for the various computational modules. The entries here, however, are system parameters such as file formats, directory names, and other options. The information you enter will be saved in the ntsys.ini file in the Windows directory. The file also includes coded information about the position and size of some of the windows used by NTSYSpc. The same file is also used by the Ntedit program. If this file become corrupted it is best to delete it and let NTSYSpc recreate it the next time it is run.

Configuration parameters

Batch code | Description
FF | Format code for output files. The e code will give full precision.
LF | Format code for output listing. Default is 8.4f
LI | Indent for output listing. Default is 4 spaces.
PW | Page width for output listing. Default is 78
DD | Data directory—the directory to use as the current directory for data files.
OW | File overwrite code. ?=ask, O=overwrite, and A=append.
ED | Editor to be called from the File|Edit menu.
SP | Should plots be displayed? One may wish to suppress them when running batch programs.
ST | Should output listings be shown using separate tabbed sections? The default is Yes.
TC | The color to be used for module caption text in the menu bar at the left. The default is white but that may not be visible when certain color schemes are used in Windows.
DEC | Character to be used as the decimal separator. The default is the period “.” but a comma “,” can also be used. Changing this character will also change the character used as a separator in CSV files (default is a comma but a semicolon is used if the decimal character is a comma). This also applies to data files.

The “File format” code is used to write results to disk so they can be used as input to other modules. The default format of “e” ensures these values are saved with maximum precision. This value should not be changed except possibly when working with very large matrices and you are low on disk space. On the other hand, the “Listing format” code will often be changed so that numerical information displayed in the Listing window has an appropriate level of precision for a given data set. The default is “8.4f” which means that floating point numbers should be displayed with four decimal places within a field eight characters wide. You can also enter the code as “F8.4” as in FORTRAN but the NTSYSpc will always store the code with the “f” at the end.

The “File overwrite code” is used to determine what should happen when the program attempts to save a data file with the same name as an existing file. Ask means that a window will pop-up asking what should be done, overwrite means that the existing file should be deleted, and append means that the new file will be appended to the end of the existing file.

If you wish, another editor can be substituted for the NTedit program.

Note: the configuration parameters can also be changed through commands in a batch file. Use CONFIG as if it were a module and use the "batch codes" given above to change the values of the parameters. as the following:

config LF=9.6f

In order to change the decimal separator character to a comma in a batch file it must be enclosed in parentheses because the comma character is used to separate arguments in a batch file. For example to change from a period to a comma enter the following:

config dec=(,)

Changing back to a period can be done as follows because the period is not used as a separator:

config dec=.

One can also customize list of program icons that appear in the User folder. An example is shown below.

At the right are listed all of the modules in NTSYSpc. You can click on one and drag it to the User folder that is open on the left. You can also right click on any of the modules in the folder to remove them from this folder. You can also rename them if you wish.

You may find the use of the User folder convenient If you usually use just a few modules in NTSYSpc.


Modes of operation

Navigation: Introduction > Modes of operation >

Modes of operation

There are two basic modes of operation: interactive and batch. For the interactive mode simply click on the buttons corresponding to various modules, fill out the input forms, and then click on the compute button. NTSYSpc can also be used in a command (batch) mode of operation. The batch mode can be used by preparing a "batch file" consisting of a sequence of NTSYSpc commands. Batch files are especially convenient for the processing of large data sets or for processing a large number of data sets (perhaps from a simulation). After you become familiar with how NTSYSpc works (and the batch codes) you may find that using command mode much faster than navigating the buttons and forms.


Interactive mode

Navigation: Introduction > Modes of operation >

Interactive mode

Initially, the main NTSYSpc window displays the names of the modules available. To select a module, click on a folder at the left corresponding to the desired group of modules and then the button corresponding to the desired module. The selected module will display an input entry window. You must enter the required information in the Entry Window (you need to at least specify the name of an input file) and then click the “Compute” button to run the program. The default choices, if there are any, will have already been entered into the form. The method of providing the information depends upon the type of field.

Input or output matrix names: names are any valid Windows file names. File names should end with the file extension “.NTS” (if left blank then the “.NTS” will be appended automatically. File names can be preceded by a drive specification (e.g., a:test.nts) or a path specification (e.g., d:\data\test.nts). If the name contains either a colon or a backslash character, then the name is used as is. Otherwise the name will be appended to the name of the current data directory. Double click the entry line (or click on the browse button) to open a standard file open/save dialog box. If file names do not have one of the standard extensions (such as NTS, CSV, XLS, or NEX) then it will be assumed that the file uses the NTS format.

Pick lists: Many of the programs require one to select one of several choices for a field (such as a method of standardization or a clustering method). In such cases a list of the available choices will be displayed.

Check boxes: Click on the box to alternate between checked = "Yes" and unchecked = "No" answers.

String fields: These are used, e.g., to enter transformation codes, lists of members of a set, etc. The field will scroll left or right if you need to enter more information than can be displayed in the available area.

Integer fields: An edit window with up and down arrows is displayed. You can either enter the desired quantity or else click the arrows to change the values. In most cases there are constraints on the range of possible values that can be entered.

Real number fields: An edit window is displayed. Very large or very small values can be entered using a form of scientific notation (such as 1e-6 for 10 to the –6 power).

Once the fields have been filled‑in correctly, click the compute button to run the module. Output listing will be displayed which will contain a summary of the parameters you specified, information about the input files, and for some modules there will be results from the specified computations. In most of the programs the information shown in the output Window is only enough to assure the user that the correct computations have been performed. The real "results" are stored as matrices in the output files. In case of an error, the program displays a message in an Error Window. You can correct the entry and try again.


Batch mode

Navigation: Introduction > Modes of operation >

Batch mode

In batch mode the direct execution of a sequence of program modules will be attempted without displaying the input entry forms. This is much faster than using interactive mode when more than just a few steps are involved in an analysis.

Each command begins with an asterisk, *, in column 1, the name of the desired program starting in column 2, and followed by parameter=value pairs. Lines that begin with a quote characters (either single or double) or are blank are treated as comments. In addition, any information following a “;” (the end of line character) is also treated as comments and ignored. Each parameter is the batch abbreviation code for some program parameter. Value gives the value of the parameter. There must be an "=" sign (and no blanks) between the parameter and its value. Each such pair must be separated by at least one blank space. The parameter is usually a one to three letter code. The values can be file names, numerical constants, or option codes. The values are identical to what would be specified in an entry form in interactive mode. The defaults are also the same. To indicate a checked field (e.g., whether one should compute by rows) you can enter “row”, “yes”, or “true” as appropriate (they are equivalent). The “Help|Search topic” menu item provides access to the batch codes for each module. The file TEST.NTB on the distribution disk is an example of an NTSYSpc batch file. Note that while long file names are supported, blanks within file names are not currently supported.

Assume that the following statements are in a file, SAMPB.NTB and there is a data file data.nts.

*stand o=data.nts d=row r=sdata.nts; comments can go after the “;”

*simint o=sdata.nts r=dist.nts

*sahn o=dist.nts r=tree.nts

To execute these commands, click the batch speed button or select the Run batch file option from the menu to display the Batch mode window. Click the Load button and provide the file name when requested and the click the Run button. The batch job given above would standardize a data matrix in the file data.nts (with the results stored in sdata.nts), compute the default coefficient (taxonomic distances), store them in dist.nts, and then perform a UPGMA cluster analysis. Additional examples of batch files are given in the help topics on typical applications of NTSYSpc.

It is also possible to prepare a batch file with substitutable parameters. This allows batch files to be used with more than one data set. If the codes %1, %2, ..., %9 are found in a batch file they will be replaced by the values of the corresponding parameter strings in the batch window. An example is shown below.

*stand o=%1.nts d=row r=sdata.nts

*simint o=sdata.nts r=dist.nts

*sahn o=dist.nts cm=%2 r=tree.nts

If the first replaceable parameter is set to "mosq" and the second to "single", then the batch window is as shown below.

The file is then interpreted as if it were as follows:

*stand o=mosq.nts d=row r=sdata.nts

*simint o=sdata.nts r=dist.nts

*sahn o=dist.nts cm=single r=tree.nts

Up to 9 substitutable parameters can be specified. The values of the parameters are given in the “Parameters” window on the batch dialog box as shown above.

While the batch file is running, the Batch Window shows the current line and the name of the program being executed. If there is an error in processing the batch file, a message will be displayed in an Error Window and the program will switch to interactive mode. Note that graphics programs have to be treated differently. The processing of the batch file will pause after each plot is created so that you can examine it, reformat it using various plot options, print it, or save it to the Windows clipboard so that you can paste it into other software. While the batch file is paused, the “Run” button changes to a “Next” button. When you have finished looking at a plot click the “Next” button to continue processing the batch file.

Results are shown in the Listing window. An example is given below.


Preparation of input data files

Navigation: Data files >

Preparation of input data files

NTSYSpc NTS data files are ordinary ASCII files (txt, not binary files). A file for an initial data matrix may be prepared with NTedit or with any editor or word processor that has a pure ASCII character (non-document) mode. If you try to use a document file there may be invisible binary codes that NTSYSpc will not know how to interpret. Free-format is used for the entries in the data matrices. This means that at least one blank space, comma, or tab is required between numbers. NTSYSpc can also read matrices from Excel (XLS files, not yet XLSX files, see Importing files ). It can also read CSV, comma separated variables, files (this is a compact format than can be produced by Excel and other software.

Trees can be input using the nexus file format (NEX files).

Note: Most of the modules can read more than one matrix from the same input file. In fact the POOLVC, CVA, and CPCA modules require that you place the two or more input data matrices in the same file. When there are more than two trees to be compared, the CONSEN module also requires this. For most of the other modules the program simply repeats the same analysis on each of the matrices in the input file.

Description of file formats.


File formats

Navigation: Data files >

File formats

An NTSYSpc matrix can contain 4 kinds of records. Comment lines are optional. Row and column label lines are optional in the NTS file format.

Comments These lines are used to include notes with the data. The first character in each line must be some type of quote character (" or '). The information on these lines will be copied onto comment lines in any matrices based on this input matrix. In addition, each subsequent program will add an additional comment line so that the sequence of steps leading to a given matrix are saved as part of the matrix file.

Matrix parameter line This line contains 4 integer numbers (The second and third may have a suffix letter to indicate the presence and location of row and column labels) and possibly a floating point number. They must be separated by at least one blank space.

• The first number is a code for the type of matrix.

1 rectangular data matrix,

2 symmetric dissimilarity matrix,

3 symmetric similarity matrix,

4 diagonal matrix,

5 tree matrix for dissimilarity data,

6 tree matrix for similarity data,

7 graph matrix for dissimilarity data, and

8 graph matrix for similarity data.

• The second and third numbers are the numbers of rows and columns in the matrix. If labels are to be furnished for either the rows or columns (or both) then a letter must be entered right after the number (with no spaces in between). An “L” is used to indicate the presence of a list of labels in a separate record placed before the data. For example, “25L” means that there are 25 rows and labels are furnished in a separate record. A lower case "l" can also be used - but this is less desirable since it looks so similar to the number "1". The letter “B” is used to indicate that row labels are placed as the first item in each row and “E” indicates that the row labels are placed after the end of each row. Note that a tree matrix must have 2 columns. Graph matrices use a slightly different set of rules (the number of rows equals the number of OTUs and in place of the number of columns is given the number of edges in the graph).
• The fourth number is 0 if there are no missing data in the matrix. If there are missing data then the fourth number should be a "1" followed by at least one blank and then the numerical code used to denote the missing values - 999 is a popular choice. The code should not be a value that could result from standardization or other transformations of the data matrix (e.g., do not use zero if you are going to standardize the data).

Row and column labels Labels must be furnished if a "B", "E", or "L" is placed after the numbers of rows or and "L" after the number of columns in the previous line. Row labels can be placed in one of three locations: as the first element at the beginning of each row (B), as the last element at the end of each row (E), or as a separate list of row labels in front of the matrix (L). The column labels if present always consist of a list of labels with the first label beginning on a new line. Each label consists of a string of characters (up to 16 letters or digits but no blanks). The labels are separated by one or more blanks or by a comma. Examples are given below. Note: when the results are plotted the underscore character “_” is displayed as a blank.

Matrix data lines The elements of the matrix are entered with rows in the input matrix corresponding to one or more lines in the input file (i.e., matrices are always entered row wise). Symmetric matrices are entered as rows beginning with column 1 and ending with the diagonal elements (i.e., the lower half matrix with diagonals is entered rowwise). If all the elements for a row do not fit on a single line, then you may continue typing on as many new lines as needed. It is important that the first element of a new row starts on a new line—even if the previous line is mostly empty. The elements themselves are free format. Values must be separated by one or more blanks or by a comma.

The lines can be very long (the theoretical limit is 2 GB!) - but it will be easier to work with them with most editors if you use shorter lines (80 characters or fewer). Blank lines are ignored.

More than one matrix can be stored in a single file. The records for a second matrix (starting with the optional comment lines) simply follow after those for the first. Most program modules in NTSYSpc will perform the selected set of operations on each of the matrices in an input file. The results for the second and subsequent matrices are simply appended to the files produced by processing the first matrix. For some programs it is necessary to put more than one matrix in a single file in order to perform a certain computation. It is required by programs such as CPCA, CVA, and POOLVCV. It is also necessary in order to compute the majority rule consensus tree for more than two trees.

Note: if you prepare the original data matrix so that the rows correspond to the characters (variables) and the columns correspond to the objects being classified (OTUs, data points, etc.), then you will find that default row/column direction options in most of the modules will be correct.

Since there is always the chance that there will be an error in the preparation of a data matrix, it is strongly suggested that you use the NTedit program and that you first try the OUTPUT module to display your input data matrix. It can be printed out for convenience in proofing. Another alternative is to use Excel to edit your data files.

Note: More than one matrix can be placed in the same NTS file. Usually the matrices must be of the same type (but there can be a mixture of similarity vs. distance matrices or a mixture of trees based on either similarity or dissimilarity.

Examples of NTSYSpc matrix files.


File formats for gene frequency data

File formats for genetic data

Navigation: Data files >

File formats for genetic data

Matrices for gene frequency data must contain the frequencies of all the alleles or genotypes (i.e., the frequencies must add up to 1 for each locus. In the example shown below the 19 rows correspond to 19 alleles distributed over the 5 loci. The columns correspond to samples taken from four populations. The first 4 rows correspond to the alleles at the ABO locus. Thus the column sums must be equal to 1 for the first 4 rows. The next five rows correspond the next locus within which the columns must sum to 1, and so on for the remaining loci. For allele frequency data see this topic.

" Blood-group data from Cavalli-Sforza and Edwards (1967)

" 5 loci with a total of 19 alleles for 4 populations

1 19L 4L 0

A1 A2 B O CDE CDe cDE cDe Cde cdE cde MS Ms NS Ns Fya Fyb

Dia Dib

Eskimo Bantu English Korean

0.2914 0.1034 0.2090 0.2208

0 0.0866 0.0696 0

0.0316 0.1200 0.0612 0.2069

0.6770 0.6900 0.6602 0.5723

0 0 0.0024 0.0082

0.4985 0.1400 0.4205 0.6197

0.4906 0.0100 0.1411 0.3148

0.0109 0.6000 0.0257 0.0573

0 0.0200 0.0098 0

0 0 0.0119 0

0 0.2300 0.3886 0

0.1719 0.0900 0.2377 0.0245

0.6703 0.4800 0.3048 0.4615

0 0.0400 0.0703 0.0646

0.1578 0.3900 0.3872 0.4494

0.7500 0.0600 0.4213 0.9950

0.2500 0.9400 0.5787 0.0050

0 0 0 0.0313

1 1 1 0.9687

In the example given above, the period, “.”, is used to indicate the decimal point. See the config window to change this to a comma, “,”.

For some coefficients the SIMGEND module needs to know which alleles correspond to the same locus. This information is provided in a rectangular matrix (stored in a separate file) that contains a single row (or column) of codes indicating the locus that each allele belongs to. This information can also be used by the FREQ module An example is shown below for the above data.

" Loci info for

" Blood-group data from Cavalli-Sforza and Edwards (1967)

1 1 19L 0

A1 A2 B O CDE CDe cDE cDe Cde cdE cde MS Ms NS Ns Fya Fyb

Dia Dib

1 1 1 1 2 2 2 2 2 2 2 3 3 3 3 4 4 5 5

For some coefficients the SIMGEND module needs to know the sample size for each population being compared. A diagonal matrix or a rectangular matrix can be used to provide this information. A diagonal matrix such as the following is produced by the FREQ module.

“ diagonal sample size matrix for 4 populations

4 4 4 0

25 25 25 25

Some modules can also accept sample sizes as a rectangular matrix

“ rectangular sample size matrix for 4 populations

1 1 4 0

25 25 25 25

The band similarity coefficient in the SIMGEND module requires a data matrix giving codes for band numbers for the diploid genotype at each locus for each individual. An example is given below. While there are no missing values in this example, missing values codes can be used.

" test data for band similarity.

" rows correspond to individuals and columns correspond

" to two alleles at each of 5 loci.

1 4 10L 0

1a 1b 2a 2b 3a 3b 4a 4b 5a 5b

4 4 6 5 1 2 3 3 2 5

5 3 6 5 3 4 3 4 2 5

4 3 3 3 4 3 2 2 1 4

3 3 6 3 2 2 3 4 2 2

For genotype data for diploid individuals a similar format can be used. For two diploid loci there would be six possible genotypes and they would represent separate variables (AA, Aa, aa, BB, Bb, and bb). If the sample were populations then the entries in the data matrix would be genotype frequencies. If each individual was coded separately then the entries would be “1” if the genotype was present or “0” if it was not.

RAPD PCR data are usually coded as a matrix of 0 and 1 values with specimens as rows and bands as columns (although it could be the other way around if that were more convenient for input). In each cell a 1 entered if a band corresponding to that column is present and a 0 otherwise. Various coefficients could be used to compute the similarity or dissimilarity among samples but the Jaccard or Dice coefficients (see the SIMQUAL module) are more appropriate if one believes that the fact that two specimens lack the same band is not informative. An example of an analysis using NTSYSpc on microsatellite markers is given in Zeng et al. (2004) .

The entry for “Phylogeny Analysis using NTSYS-pc” in the Molecular Genetics Protocol website at the URL http://moleculargeneticsprotocol.blogspot.com/2007/05/ntsys-for-beginner.html gives some useful hints about preparing and analyzing DNA data using NTSYSpc.


Allele frequency data

Navigation: Data files >

Allele frequency data

Raw allele frequency data can be input using the freq module. It is usually easiest to prepare a data file with each column corresponding to an allele and each row corresponding to an individual. A simple example is given below.

" allele data for computing gene frequencies

" rows give data for diploid individuals

“ they come from samples of 3 populations

" two loci of 3 and 2 alleles

" Enter a 1 for each allele present (2 for homozygous)

1 15 5 0

1 0 1 2 0

2 0 0 1 1

1 0 1 2 0

0 1 1 2 0

2 0 0 1 1

1 0 1 2 0

0 2 0 2 0

1 0 1 2 0

1 1 0 2 0

2 0 0 2 0

1 0 1 0 2

0 0 2 0 2

1 0 1 0 2

1 1 0 1 1

2 0 0 0 2

Note that the values within the data matrix are codes indicating the “quantity” of each allele present in each row (individual). One does not enter genotype codes such a 12 or 22.

Note also that the blank lines within the file and the extra spaces to separate loci are optional and are ignored by the program. However, there must be at least one blank space between the values entered in each row.

A file must be provided to give the sample identification codes to indicate which sample each specimen (row of the input matrix) belongs.

" grouping ID file for computing gene frequencies

“ three groups of 5 specimens each

1 15 1 0

1

1

1

1

1

2

2

2

2

2

3

3

3

3

3

Next, you have to indicate which columns belong to each locus. In this example the first three alleles are from the first locus and the next two are from the second locus.

" loci IDs

“ two loci with 3 and 2 alleles.

1 1 5

1 1 1 2 2

Finally, the results of using the FREQ module are as follows:

C1 C2 C3 C4 C5

----------------------------------------------

R1 | 0.600 0.100 0.300 0.800 0.200

R2 | 0.500 0.300 0.200 1.000 0.000

R3 | 0.500 0.100 0.400 0.100 0.900


NTSYSpc tree format

Navigation: Data files >

NTSYSpc tree format

It is easiest to understand the conventions used to encode the results of a cluster analysis as a tree matrix by considering an example. The tree matrix that results from a UPGMA cluster analysis of distances computed from the sample test.nts file (after standardization) is as follows:

5 10L 2 0

A B C D E F G H I

1 0.665

5 0.928

10 0.937

2 1.061

3 0.693

7 1.409

4 1.615

6 1.347

8 1.085

9 0

The first column gives the numerical codes for the n OTUs (1 = A, 2 = B, etc.). The second column gives the heights (level values) for each of the n-1 clusters. The last numerical value (0) is always ignored. This same information can also be given in XLS or CSV file formats (but in that case the row labels go down the side and two dummy labels must be provided for the columns). These relationships can be displayed as a phenogram using text graphics as follows:

Note that the objects (OTUs) are listed in a tree matrix in the same order as they are in the first column of the tree matrix - as are the level values. In the phenogram you will note that each horizontal line of “-” signs runs from an object label leftward until it hits a “.” where it bends and runs downward until it connects to a horizontal line (shown with an “L”). The “.” is located along the abscissa according to the level value for the object. For example, the line from object B runs until it reaches a distance value of 1.061 -- the level at which cluster {A,E,J,B} joins {C,G}. The last level (the level at which the entire set of objects joins something outside of the present study) is undefined. Notes on how one works with clusters coded in this fashion are given in Rohlf (1977). That paper also gives algorithms for transforming the codes into other representations. Rohlf (1973) also provides some hints as does Rohlf (1975a) .

An example of the same phenogram displayed by the TREE program is shown below. This type of plot, with clusters centered on their stems, is clearly more suitable for publication than the “quick and dirty” text-mode display shown above.

The above format has been extended to allow OTUs to be at different heights. For this mode tree matrices have three columns. The first two are as above. The third column gives the height of each OTU above the root. An example is given below.

"Phylogenetic tree from tpsTree, ver. 1.15

6 11L 3L 0

Anoph1 Aede44 Psor32 Cule101 Culi21 Mans29 Orth28 Wyeo13 Uran17 Toxo12

Dein126

Index Level Height

1 0.00000000000000E+000 1.60000000000000E+001

9 8.00000000000000E+000 1.00000000000000E+001

7 1.30000000000000E+001 1.40000000000000E+001

5 1.60000000000000E+001 1.70000000000000E+001

10 1.00000000000000E+001 1.70000000000000E+001

2 1.40000000000000E+001 1.50000000000000E+001

3 1.80000000000000E+001 1.90000000000000E+001

6 1.20000000000000E+001 2.40000000000000E+001

4 1.40000000000000E+001 1.50000000000000E+001

11 1.30000000000000E+001 1.70000000000000E+001

8 0.00000000000000E+000 4.30000000000000E+001

The output of the tree module is shown below.


Nexus format

Navigation: Data files >

Nexus format

There are two ways to describe a tree using nested parentheses.

1. There is a variant of the NTS tree format for tree matrices based on dissimilarities (matrix type code = 5). While complete NEXUS files cannot be read, the tree descriptions can be processed as long as the OTUs names are given as integer numbers (corresponding to their position in a data matrix). This format is provided to enable trees produced by other programs to be entered into NTSYSpc more easily. One can also enter trees by hand using this notation -- but it becomes awkward for large trees since it is easy to miscount parentheses.

In this format nesting is indicated by parentheses, branch lengths (which are optional) are given in the format ":value" after each OTU name and right parenthesis, and the end of the tree is indicated by a semicolon. If branch lengths are not provided then NTSYSpc will generate arbitrary clustering levels consistent with the set relationships given in the tree. Note that one must either provide branch lengths for all branches or else for none of them. A mixture will produce unpredictable results.

Example of a NEXUS style tree not using branch lengths:

" NEXUS style NTS file with OTU labels provided.

5 5L 2 0

A B C D E

(((1,3),2),(4,5));

This implies a tree of the following topology:

1--.

3----.

2----L---.

4--. |

5--L-----L---

Example of an input file using branch lengths:

" Example of NTS nexus tree using branch lengths but no OTU labels.

5 5 2 0

(((1:2.1,3:2.5):1.6,2:3.3):0.7,(4:0.5,5:0.3):0.9);

This tree has the same topology as in the previous example. It should be noted, as in the above example, that the branch lengths may be inconsistent with the levels (heights) used to describe an ultrametric tree. In the above example the branch length for OTU 1 is 2.1 but the length for OTU 3 is 2.5. The program will use the average (2.4) of these values. An additional problem is that the raw average of heights of each interior node may not increase as one goes towards the root. In the above example the height at which the set {1,3,2} joins the root is 4.3 and the height at which {4,5} joins is 1.3. The average of these two values is 2.8 which is smaller than the level at which {2} joined {1,3}. The program constrains the average heights to be at least 0.0001 greater than the largest height within the sets being joined. This preserves the topology indicated by the parentheses but shows the trees graphically as looking as if there was a multifurcation.

2. There is also a nexus file format (also called the Newick Tree Format). These files must be given the extension “.nex”. This format is supported by many programs concerned with estimating phylogenetic trees. Within NTSYSpc, the NJOIN module can save tree files in this format. Trees in this format can be read by the COPH, CONSEN, and OUTPUT modules. Note that while this format is quite standard, the NTSYSpc format described above is much simpler to use – especially if large trees have to be entered by hand. The use of nested parentheses is often difficult when coding trees manually.

An example of the nexus format is given below. The translate section is required by NTSYSpc. It gives the labels for the OTUs. There can be one or more tree commands in a file. Each describes a tree using nested parentheses. The length of each branch on the tree must be provided following the “:” character (lengths are real numbers). The file is treated a single stream of characters with line breaks ignored.

#nexus

begin trees;

[11 mosq. extracted from Harbach & Kitching (1998)]

translate 1 Anoph1, 2 Toxo12, 3 Wyeo13, 4 Uran17, 5 Culi21, 6 Orth28,

7 Mans29, 8 Psor32, 9 Aede44, 10 Cule101, 11 Dein126;

tree (1:16,(4:2,((6:1,(5:1,2:1):3):3,

((9:1,(8:1,7:6):4):2,((10:1,11:3):1,3:30):1):2):2):8);

end;

Note that just the ‘tree” parameter is recognized (not the “utree” parameter). Note also that the “translate” field must be given and only integer numbers can be used to indicate the OTUs within the nested parentheses. The translate form of the nexus tree format is required since it gives the relationship between the tree and the order of the OTUs in the data matrix.

A plot using the tree module is given below.

The nexus file format is described in: Maddison et al. (1997). The method used for describing trees is called the “Newick Standard” and was adopted June 26, 1986 by an informal committee meeting during the Society for the Study of Evolution meetings in Durham, New Hampshire. James Archie, William H.E. Day, Wayne Maddison, Christopher Meacham, F. James Rohlf, David Swofford, and Joe Felsenstein were present. The reason for the name is that the second and final session of the committee met at Newick's restaurant in Dover, NH. Examples and a simple description of this format are available at http://evolution.genetics.washington.edu/phylip/newicktree.html.


Excel files

Navigation: Data files >

Excel files

NTedit and the NTSYSpc modules can read matrices stored in Excel XLS files (including the new XLSX file format used in MS Office 2007). There is one restriction at present – there can be only one matrix stored in each spreadsheet but there can be multiple spreadsheets in a file. The Excel program itself does not need to be present on your computer in order for NTSYSpc to read an XLS or XLSX file.

File format

NTSYSpc will search the spreadsheet for the matrix parameter line by starting with the first row. If only the first cell, A1, contains information then its search continues on to subsequent rows until a row is found with at least four non-blank cells. The information in the rows being skipped over is assumed to be comments. Once the matrix parameter line is found, the cell in column “A” is interpreted as the matrix type code. The two cells to the right (columns B and C) must be the number of rows and the number of columns. Note: these must be integer numbers. Do not try to append a code to indicate the presence of row or column labels as one does for an NTS file. The cell in column D contains the code indicating whether or not there are any missing values. Enter a zero or leave it blank if there are no missing values. Otherwise, enter the identifying numerical code in the cell in column E.

The next row contains column labels beginning with column B. If any cells are left blank they will be replaced with column numbers. Column A contains the row labels. If any cells are blank then will be replaced by row numbers. Note that row and column labels are in their natural position—not as records in front of the matrix as in as in the “L” option for NTS files. The row and column labels should not contain any blanks. The matrix itself begins in column B. See below for a simple example where the matrix starts in cell B5.

If empty cells are found within the matrix, they are assumed to also correspond to missing values. Information in the spreadsheet in rows beyond the matrix is ignored and can be used to store other information. Note in this last case you will have to enter a numerical code to be used within NTSYSpc to indicate missing values. It must be a value that cannot occur within the dataset or within any transformed matrices derived from it. The default is 999.

Note: Only one matrix can be read from each Excel spreadsheet file and the matrix should be the first set of entries in a spreadsheet. Information past the matrix will be ignored. However, the Excel file can have more than one spreadsheet. You can, however, save a spreadsheet with multiple matrices as a CSV file then you can have multiple matrices in one spreadsheet.


CSV files

Navigation: Data files >

CSV files

The CSV (comma separated variables) format is a simple format that is useful for transferring data between different programs. These files can be produced by a number of common programs (e.g., Excel). Note: If the comma character is set as the decimal point character, then the semicolon is used as the separator in CSV files. See the config window where this character can be changed. In the examples given below the default period and comma are assumed.

For input, NTSYSpc requires that information in these files be laid out identically to XLS files. In NTSYSpc these files are interpreted as follows:

If one or more initial lines contain only one value then they are interpreted as comments whether they are text or numerical values.

A matrix header line must contain 4 or 5 numeric values (matrix type, no. rows, no. cols., missing value flag, and the missing value code if the flag is not equal to 0).

The next line must contain the column labels starting in the second cell. If the entries are blank then they will be replaced by codes such as C1, C2, etc.

Each row of the matrix must correspond to a single input line. The first element in each row is interpreted as the row labels. The other values are taken as the entries in the matrix. If any row labels are blank then they are replaced by values such as R1, R2, etc.

An example of a rectangular matrix in CSV format is given below. The first line is a comment (if it were to contain a comma then the entire comment must be enclosed in quotes). Note: the line giving the column labels must begin with a comma in order to skip over the column containing the row labels. This is because the implied layout must match that of the Excel layout.

Example of a rectangular matrix

1,4,4,0

,cc1,cc2,cc3,cc4

rr1,11,12,13,14

rr2,21,22,23,24

rr3,31,32,33,34

rr4,41,42,43,44

An example of a symmetric matrix is given below. Even though it is not necessary in this case, the comment line is enclosed in quotes. Note: both row and column labels must be allowed for (if you wish NTSYSpc to create a label then no values need to be placed between the commas but the correct number of commas must still be provided.

'test of a sym matrix'

2,5,5,0,

,v1,v2,v3,v4,v5

v1,0

v2,1,0

v3,2,1,0

v4,3,2,1,0

v5,4,3,2,1,0

Example of a diagonal matrix. In this example the row labels are the integers 1 to 5 (the same as the values provided for the diagonals). While a column label must be present, it is ignored. The row labels are used internally as the column labels also.

'test of a diag matrix'

4,5,5,0,

,C1

1,1

2,2

3,3

4,4

5,5

Example of a tree matrix. While the column label fields must be present, their contents are ignored.

'test of a tree matrix'

5,9,2,0,

,p,Level

1,1,2

2,2,3

3,4,4

4,3,5

5,5,6

6,6,7

7,7,6

8,8,5

9,9,0

Example of a graph matrix. Note: the value for the number of rows is actually the number of nodes in the graph and the value for the number of columns is actually the number of edges in the graph. In this example there is one fewer edges than variables. There could be many more edges than there are variables.

'test of a graph matrix'

7,5,4,0,

,i,j,d,

1,1,3,1.47,

2,3,4,1.13,

3,4,5,0.01,

4,5,2,1.1,

5,

Both NTedit and NTSYSpc can read files in this format, but only the NTedit program can create files in this format.

This format is also useful for output. For example, to import a matrix into Word, one can first read a CSV file into Excel and then copy and paste it into Word as a table that can then be automatically formatted for publication (unless it is too large).


Examples of file formats

Navigation: Data files >

Examples of file formats

An example of a data matrix file with 3 comment lines and labels for the columns but not the rows is given below. This set of test data (test.nts) is furnished with NTSYSpc and is used for many of the examples given in this manual.

"A sample data matrix to test NTSYSpc

"There are 5 characters (rows) and 10 OTUs (columns)

"The columns are labeled. No missing values.

1 5 10L 0

A B C D E F G H I J

8 7 9 13 6 12 9 7 11 6

5 6 3 3 7 10 5 7 5 7

11 13 12 9 8 18 17 21 22 13

10 18 22 8 7 17 18 26 24 18

11 6 12 10 10 19 13 13 19 14

An example of a data matrix with column labels and with row labels placed at the beginning of each row:

1 4B 3L 0

c_1 c_2 c_3

r_1 1, 3, 4

r_2 3, 2, 1

r_3 3, 4, 2

r_4 2, 1, 2

Note: the underscore character will not be displayed when the results are plotted. This allows labels to look as if they consist of more than a single word. In the above example, the data values were also separated by commas. This is optional because the presence of at least one blank space is sufficient. The use of commas assumes that the decimal point is indicated by a period, “.”. If a comma, “,”, is used instead (see the config window) then a semicolon, “;”, can be used as a separator.

See file formats for gene frequency data for examples of files containing gene frequencies.

An example of a symmetrical correlation matrix file (note that elements past the diagonal of a symmetric matrix must not be entered). Labels can only be placed in a list in front of the data (i.e., only the “L” code is valid). The format used in Excel files for import into NTedit is different.

"A sample correlation matrix with labels

3 5L 5 0

A B C F E

1

0.4 1

0.3 0.4 1

0.6 0.3 0.4 1

0.7 0.3 0.4 0.5 1

In this case the “L” can be appended to either the number of rows, the number of columns, or to both. But only one set of labels should be furnished. If a symmetric matrix is the output of some other program it may be stored as a full square matrix. In that case you should code it as a rectangular matrix and use the SYMD or SYMS options of the TRANSF program to convert it to the lower half matrix form required by NTSYSpc.

Tree matrices (matrix types 5 and 6) are usually produced by programs rather than entered by a user. The usual exception is when one wishes to enter an expected tree to compare with the observed results (using the CONSEN program). There are three ways in which a tree can be entered in NTSYSpc, the format used by NTSYSpc to write tree matrices and the Nexus format used in some other software.

Graph connection matrices (matrix types 7 and 8) have a simple format. There are three columns with the first two containing integer numbers of the pairs of points being connected. The third column contains the distance (or similarity) between the pair of points. In the header line, the number of rows is set to the total number of points in the original data. It is not the number of rows in the graph matrix. The number of columns is set to the number of pairs of points in the graph matrix. It is not equal to the number of columns (3) in the graph matrix. Such matrices are output by the MST and NJOIN modules.

An example is given below of a matrix used to specify points to be connected in the Procrustes plot display. In this case the distance between points is ignored so zero values are given in the matrix. In this example the points are connected as a complete outline.

" connections for 5 points

7 5 5 0

1 2 0

2 3 0

3 4 0

4 5 0

5 1 0

Some of the graphics programs allow points to be identified using different plotting ID symbols. This is done using a file that indicates the points that should receive the same symbol. This is simply a rectangular matrix with either n rows and just 1 column or one row and n columns. In either case, the entries are a list of integers such as 1 1 2 3 2 2 3 etc. All points with the same code will be shown using the same plotting symbol. This type of file can be created by the COMBINE module. Note: the file can be in any of the available input formats – not just NTS.

Another type of file (used in POOLVCV and SPLIT modules) is one that lists the sizes of groups. It is a rectangular matrix with n rows and one column or one row and n columns that simply lists the number of observations in each of n groups.


Importing and exporting data to other programs

Navigation: Data files >

Importing and exporting data to other programs

Since the matrix files have a simple format, they should be usable by other programs with very few changes needed. Results from other programs should also be convertible into NTSYSpc formats. The largest problems are apt to be due to different conventions for furnishing labels and for reading symmetric matrices. It may be helpful to load the file into NTedit in text mode, which provides full freedom in how you change the format of the file. Since the program can read Excel and CSV files, they may provide a way to pass data from another program to NTSYSpc. Saving files in CSV format may also be a convenient way to pass results to other software. Note: the NTedit program can also save files in MathSoft’s *.m format used by the MATLAB program.


Data editor

Navigation: NTedit -- a data editor >

Data editor

The NTedit program is a data editor for use with NTSYSpc data files. It can also be used independently of the main NTSYSpc program to edit ascii files. It recognizes valid NTSYSpc NTS data files. It is also able to read XLS and CSV files if the data are laid out correctly. For each of the basic file formats (rectangular, symmetric, diagonal, tree, and graph) it displays an appropriate arrangement of the cells in the spreadsheet. NTedit can save files as NTS or CSV files (it cannot save files as XLS files). In addition, it can also save matrices in MathSoft’s MATLAB (*.m) file format. This program can also be used to edit any ASCII (text) file. While the NTS file format is simple, using NTedit ensures that the files are formatted correctly. An example is shown below.

NTedit can be started in three ways.

1. Click on the program icon to start the program and then use the File|Open menu to load an existing data file or File|New to begin a new file.

2. Load this program from the File|Edit data file menu of NTSYSpc.
3. You can also use a DOS command window and type ntedit and the name of a file and then press the R key to start the program.

Once NTedit is started you can enter or correct data in any of the cells of the spreadsheet. You can insert or delete rows and columns within the table by clicking on the appropriate menu choices or the speed buttons on the tool bar. You can also add or delete rows and columns from the end of the table by entering new values in the edit boxes displaying the current numbers of rows and columns. You can also enter or change the numerical code used to indicate missing values in the data. Make sure this field is blank (not zero) if there are no missing values. Note: the changes in these three fields will not take effect until the cursor leaves the field (thus indicating that you are finished typing). To change the labels for the rows or columns (given in the first, protected, row or column of the data table) click on the RowLabs or Col.Labs buttons to unprotect these entries. You can then type new information in these cells. The new names should not have any blanks within them. Click these buttons again to re-protect these labels from accidental change.

To create a new file use the following steps:

1. select “New” from the file menu,

2. select the proper matrix type from the list (you may receive a warning about the possible loss of data when you change matrix types),
3. enter the correct numbers of rows and columns in the edit boxes labeled “No. rows” and “No. cols.” (note that the new values do not take effect until your cursor leaves the edit boxes), and then
4. start entering your data.

If there are missing data the identifying numerical code needs to be entered in the edit box labeled “Missing.” Click on the “Comments ” button if you wish to add comments to the matrix. When you are done you can use the “Check matrix” item under the Edit menu to check that all data values are properly formatted numbers. It also will check to make sure there are no empty cells. This same check is made when to attempt to save the matrix to a disk file. You will be given a chance to replace all the empty cells with whatever code you specified for missing data (if that field is blank then zeroes will be used). Cells that correspond to missing data will be shown with a special highlight. The font used to display the values in the matrix can be changed from the Option menu.

NTedit can also be used to view and make changes in existing files. If you use the “Open file in grid” menu item then the existing files must already be in a proper format. If you try to load a file that is not formatted properly you will receive an error message and then the editor will try to load the file in text mode. NTedit and NTSYSpc can also read matrices from Excel . Nexus files can only be loaded in text mode.

As a convenience, files can also be dragged from the Windows explorer and dropped on the NTedit window. Note that there is an option in the Options menu that lets matrices from different files be appended to the currently open file.

See NTedit: Main window, Comments window, and .


NTedit main window

Navigation: NTedit -- a data editor >

NTedit main window

This window is used for creating or editing a NTSYSpc matrix files. Overview of NTedit.

To start a new data set, select File|New if the spreadsheet is not already cleared. Then enter appropriate values in the edit box fields for the number of rows and columns and for the missing value code. Note: the changes in these three fields will not take effect until the cursor leaves the field (thus indicating that you are finished typing).

To enter new labels (rather than the default R1, R2, ... etc.) depress the RowLabs or Col.Labs buttons to unprotect the first column or row of the table. You can then directly type new labels.

Use the tab key to move from cell to cell of the data table as you enter values into the table.

Click on the Comments button to open a window in which you can type any other information you would like associated with the data file. This information is reproduced on all listing files produced by NTSYSpc and is also copied to any matrices produced from this matrix.

For rectangular matrices, you can change the positions or rows and columns clicking on the first row or column and dragging the selected column or row to its new position. In all cases you can change the width of a column by going to the first row and dragging the dividing line between columns.

The program can also read matrices from Excel XLS files if the spreadsheet is laid out in the proper format with one matrix per spreadsheet.

The Options menu allows you to bring up the Fonts dialog window. You can select a typeface and a size for displaying the values in a matrix. For large matrices you may wish to use a smaller font size so that more of the matrix can be displayed at one time. You can also make the columns wider by dragging the mouse cursor over the border between the column labels (you will see the mouse cursor change to indicate when you can start dragging).


NTedit comments window

Navigation: NTedit -- a data editor >

NTedit comments window

This window displays the comments currently associated with this file. You can add new comment lines or change existing ones.


NTedit text edit window

Navigation: NTedit -- a data editor >

NTedit text edit window

By using the Open as text menu item you can open any ASCII text file and edit it. This is useful for the following tasks: to repair an NTS file that is formatted so badly that it cannot be loaded into the grid, to create or edit batch files, to create or edit nexus files, and to edit any other ASCII text file. NTedit is capable of working with very large files (it is not limited to 64K as is the Windows notepad program). An example is shown below.

In addition to the usual cut, copy, and paste commands, many other keyboard shortcuts are supported. They are listed below.

Save file Cs

Cut to clipboard CX

Copy to clipboard CC

Paste from clipboard CV

Undo Cz

Redo VCz

Toggle insert mode Z

Find Cf

Find next 3

Replace CR

Go to line 4

Set bookmark 0 – 9 VC0 – 9

Go to bookmark 0 – 9 C0 – 9

Go to first page Ch

Go to last page Ce

Go to bottom of window Cx

Go to top of window Cz

Select all CA

Extend selection to end of line Ve

Extend selection to start of line Vh

Extend selection up a page Vz

Extend selection down a page Vx


NTedit - find

Navigation: NTedit -- a data editor >

NTedit - find

Search for the specified text. If the search is successful then the search may be repeated by pressing the 3 key.

Options: case sensitive search and find just whole words.

Searches can be forward or backwards from the current cursor position or globally (i.e., from the beginning of the file).


NTedit - search and replace

Navigation: NTedit -- a data editor >

NTedit - search and replace

Search for the specified text and replace it. If a match is found, you can select “Yes” to replace this occurrence and to search for the next, “No” to skip this occurrence and search for the next, or “Cancel” to end the search. Select “Replace all” to automatically make all replacements.

Options: case sensitive search and find just whole words. Searches can also be made globally (i.e., from the beginning of the file).

Searches can be forward or backwards from the current cursor position (or from the beginning of the file if the global search option has been checked).


Plot menu

Navigation: Graphics >

Plot menu

The File menu contains the following items: “Save metafile” (allows you to save the plot to disk as an enhanced Windows metafile), “Printer setup” (which allows you to select a printer, paper size, and orientation), “Print preview” (which changes the plot to a preview of how it will look when printed), “Print” (to print the plot), and “Close” (to close the plot window). The Edit menu allows one to copy the current plot to the Windows clipboard as either a bitmap or as a metafile. The Help menu leads to the standard Contents, Topic search, and About items.

Note: saving a plot as an enhanced Windows metafile or else copying it to the Windows clipboard as a metafile and pasting it into another program gives one a lot of flexibility. Within programs such as Word or many drawing programs you can edit the plot at a very detailed level. You can change the attributes of the points and line and even move them around. You can also change the attributes of the text labels and the text itself. Because of this flexibility one must edit such files carefully.

Note: most of the graphic options can be saved to a graphic options file and later restored to give the same attributes to another plot. However, if you save the options from one module and then restore them to another then only those features that are in common will have any effect – the others will be ignored.


Graphics options

Navigation: Graphics >

Graphics options

The various plots produced by NTSYSpc can be enhanced in many ways for printing by taking advantage of the available options.

Begin by clicking on a plot with the right mouse button or by selecting the “Plot options” item on the Options menu of the plot window. The options available depend upon the type of plot. All plots allow the user to specify a title and a subtitle and the fonts used to display them. There is also always a tab labeled “Options” that contains a button labeled “General”. This is used to open the General Plot Options dialog box. An example of a graphic options window is given below.

Note: one can save plots as enhanced Windows metafiles or else copy them to the Windows clipboard and paste them into another program. Within programs such as Word or some drawing programs you can edit the plot at a very detailed level. You can change the attributes of the points and lines – and even move them around so you have to be careful! You can also change the attributes (size, font face, style) of the text labels and the text itself.

Note: when printing to high resolution PCL printers you will usually have to use these to increase the widths of the lines in order to make them visible in the output. Lines have to have a width of at least 3 pixels in order to be visible on high resolution PCL printers. You may find it more convenient to print to a Post Script printer or else to copy and paste into Word and then let it take care of printing.


Other graphics options

Navigation: Graphics >

Other graphics options

These depend upon the plot. For MXPLOT and MOD3D there are pick lists for selecting the variables to be plotted. There are also choices of whether the data points should be identified by sequential numbers or labeled using the labels in the input data. There are also options to control the various attributes of the points and lines making up a plot. There are special dialog boxes to allow you to select colors, plotting symbols, fonts, etc.


General plot options

Navigation: Graphics >

General plot options

The following options (listed by group) are available for all plots.

General: “Preserve axis aspect” means to preserve the aspect of the x and y axes with respect to the original units of measurements. This must be kept checked for the 3D and Tree plots. For 2D scatter plots it should be checked when plotting the results of analyses such as principal components analysis where the relative lengths of the axes is important. One will usually not want it checked when plotting raw data. “Center” controls whether the plot is centered in the window.

Frame: Optionally, a line can be drawn around the outside of the plot to frame it. Options are available to control its size and color.

Background color: The background color in the different regions of a plot can be set individually.

Margin size: Top, bottom, left, and right margin sizes can be set.

Legend: This group is not used at present but will be used to control how groups of points or lines are identified.

In addition, each plotting program has its own specific plot options dialog box.

Note: one can save plots as enhanced Windows metafiles or else copy them to the Windows clipboard and paste them into another program. Within programs such as Word or some drawing programs you can edit the plot at a very detailed level. You can change the attributes of the points and lines – and even move them around so you have to be careful! You can also change the attributes (size, font face, style) of the text labels and the text itself.

Note: It is often more convenient to paste a plot into Word and use it to print than to print directly from NTSYSpc because this allows you to edit the plot, add captions, crop, control its size, etc.


Graphics speed buttons

Navigation: Graphics >

Graphics speed buttons

Several of the computational modules can directly call one or more of the graphics modules by the use of speed buttons on a small toolbar at the bottom left of the Parameter entry window. An example is shown below.


Saving plots

Navigation: Graphics >

Saving plots

Plots can be saved in several ways. First, one can of course print the plot. It is usually more convenient to save the plot as a graphic that can be imported into other software. By clicking on the file menu you can save the plot as a Windows enhanced metafile. While not all software supports this format, it is a very convenient format. While these EMF files are usually quite small, they contain a high-resolution representation of the plot. It can be imported into Word and other standard Windows software (unfortunately it is not supported by all graphics programs). From the Edit menu you can copy the plot to the Windows clipboard and then paste it into other software such as Word. Both bitmap and enhanced metafile formats are supported. While the bitmap format is supported by almost all graphic software, it has the disadvantage that it is simply a pixel by pixel copy of the image at the resolution of the screen when the image was captured.

Enhanced metafiles, whether imported from a file or pasted from the clipboard, can be edited within Word. You can change the contents of the labels (or even add new ones) and change the attributes of the lines and text in the plot in order to get a publication quality plot.


MXPLOT 2D scatterplot

Navigation: Graphics > 2D scatterplots >

MXPLOT 2D scatterplot

Plots pairs of rows or columns of a matrix against one another. It is used, for example, after the EIGEN and PROJ programs. The program also computes the minima, maxima, means, and variances for the two variables. The correlation between the pair of variables is also computed and displayed in the listing output.

The “secondary rectangular input matrix” allows one to create a biplots. One can, for example, plot PCA projections as the primary input matrix and the PCA eigenvectors as the secondary input matrix). One can also use this feature to plot CVA scores for the means as the primary input matrix and the CVA scores for each specimen as the secondary input matrix (to do this one will first have to combine the matrices of specimen scores into a single matrix. If one wishes to distinguish the group memberships of each specimen then the symbol ID file should also be prepared (it is a matrix with one column and as many rows as there are specimens. The entries will be “1” for all members of the first group, a “2” for all members of the second group, etc.

Note: when plotting the results of a principal components analysis or other ordination analyses, the sign of the axes is arbitrary. For example, specimens with larger values for general size (projection on PC1) may be shown at the left rather than at the right. This can be corrected by using an option is available on the Variables page of the Plot Options dialog to reflect the x and y axes. Right-click on the plot or use the Options menu to display the plot options.

Note: when printing to high resolution PCL printers you will have to use the plot options dialog to increase the widths of the lines.

Program parameters and batch codes.


MXPLOT program parameters

Navigation: Graphics > 2D scatterplots >

MXPLOT program parameters

Batch code | Description
O | The name of the input rectangular matrix.
D | The direction of the matrix that corresponds to the variables to be plotted against one another. The default is ROW.
X | The number of the variable to be plotted along the abscissa, X-axis, (default is 1).
Y | The number of the variable to be plotted along the ordinate, Y-axis, (default is 2).
G | Name of the graph matrix. This defines the pairs of points to be connected in the plot.
S | The name of a file containing a matrix with integer codes indicating which points should have the same plotting symbol.
O2 | The name of a secondary rectangular input matrix to superimpose as a biplot
D2 | The direction of the secondary matrix that corresponds to the variables to be plotted against one another. The default is ROW.

Note: There are many options available from the plot options window. The vectors option draws vectors from each point to the origin. From the plot window you can copy the plot to the Windows clipboard or save it as an enhanced Windows metafile.


MOD3D 3D scatterplot

Navigation: Graphics > 3D scatterplots >

MOD3D 3D scatterplot

Plots a perspective view of 3-dimensional space showing the objects as “points” on top of “pins” floating above a “baseboard”. The viewing angles can be changed interactively from the plot options window. This program is usually used to view the results of principal components analysis, principal coordinates analysis, or multidimensional scaling analysis. It also can be used to view data matrices 3 variables at a time. In that case, the normalization option should be set to YES so that each variable is plotted full scale. By default, the three axes are plotted to the same scale so that PCA or other ordination plots will give the correct impression of the relationships among the points.

A plot of a second matrix can be superimposed as a 3D biplot (originally called a “bimodel”). The second matrix is usually plotted as vectors. It may have to be rescaled to fit the plot. There is a scale factor available in the plot options dialog box.

There are several special 3D cursors that permit the user to freely rotate the view of the plot.

For 2-dimensional plots see the program MXPLOT.

Note: when plotting the results of a principal components analysis or other ordination analyses, the sign of the axes is arbitrary. For example, specimens with larger values for general size (projection on PC1) may be shown at the left rather than at the right. This can be corrected by using an option is available on the Variables page of the Plot Options dialog to reflect the x and y axes. Right-click on the plot or use the Options menu to display the plot options.

Note: when printing directly to high resolution PCL printers you may have to use the plot options dialog to increase the widths of the lines. In such cases it will usually be more convenient to copy and paste the image as a Windows metafile into a program such a Word. Word will allow the image to be resized and also edited before printing.

Program parameters and batch codes.


MOD3D program parameters

Navigation: Graphics > 3D scatterplots >

MOD3D program parameters

Batch code | Description
O | The name of the input rectangular matrix.
D | The `direction' of the matrix to plot by. The default is to plot the Rows of the matrix against one another.
X | The number of the variable along the abscissa (default is 1).
Y | The number of the variable along the ordinate (default is 2).
Z | The number of the third variable to be plotted (default is 3).
G | Name of graph matrix whose edges are to be superimposed on the plot (optional).
S | The name of a file with integer codes indicating which points should have the same plotting symbol.
O2 | The name of a secondary rectangular input matrix to superimpose as a biplot
D2 | The direction of the secondary matrix that corresponds to the variables to be plotted against one another. The default is ROW.

The viewing direction can be changed by dragging on the plot with the mouse.

Note: there are many important plot options (e. g., viewing position as well as titles, colors, etc. available once the plot is created. The vectors option draws vectors from each point to the origin. From the plot window you can copy the plot to the Windows clipboard or save it as an enhanced Windows metafile.


FOURPLOT - plot outlines

Navigation: Graphics > Fourier plot >

FOURPLOT - plot outlines

This module can be used to plot 2D outline curves, 3D contours, as well as Fourier estimates of 2D and 3D outline curves (see the FOURIER module). The contributions of each harmonic can be shown cumulatively as well as individually. If there is more than one specimen then they are shown in separate plots.

Outlines described as equally-spaced radii as well as in terms of x,y and x,y,z-coordinates are supported. Fourier coefficients based on equally-spaced 2D radii are supported as well as both 2 and 3-dimensional elliptic Fourier coefficients and 2D Fourier coefficients of points treated as complex numbers..

Program parameters and batch codes.


FOURPLOT program parameters

Navigation: Graphics > Fourier plot >

FOURPLOT program parameters

Batch code | Description
O | The name of the file containing the outlines.
OT | A code for the type of outline (see table below). Default is XY.
C | The name of the file containing the Fourier coefficients.
CT | Code for the type of Fourier coefficients (see table below). Default is EFOUR.
H | List of the harmonics to be plotted. If left blank then the highest will be used.

Codes for outline type:

RADII | Lengths of equally-spaced radii from the origin.
XY | X,Y-coordinates of points around the outline. The coordinates for each specimen are stored in a single row in the order x1, y1, x2, y2, etc.
XYZ | X,Y,Z-coordinates of points along a 3D contour. The coordinates for each are stored in a single row in the order x1, y1, z1, x2, y2, z2, etc.

Codes for the type of Fourier coefficients:

EFOUR | Elliptic Fourier transformation of x,y-coordinates.
FOUREQ | Fourier transformation of equally-spaced values.
FOURXY | Fourier transformation of x,y-coordinates.
EFOUR3 | Elliptic Fourier transformation of x,y,z-coordinates

The plot options window allows control over many aspects of the plots including whether plot the cumulative vs. individual contributions of each harmonic. See Fourier details for more information about the different types of Fourier coefficients.


MXCOMP Matrix comparison

Navigation: Graphics > Matrix comparison & Mantel tests >

MXCOMP Matrix comparison

The program performs two kinds of matrix comparisons. It can take two symmetric similarity or dissimilarity matrices and plot one matrix against the other element by element (but with the diagonal values ignored). It can also linearly adjust two matrices for the effects of a third matrix and then plot them against each other for a 3-way Mantel test. In either case It computes the product-moment correlation, r, and the Mantel test statistic, Z, to measure the degree of relationship between the two matrices. There is also an example in the applications section of the help file.

Mantel (1967) developed a test for matrix correspondence that has been widely applied in geography and, more recently, in population biology and other fields due to its generality and to its computational simplicity (e.g., Sokal, 1979 ). The test criterion is

where Xij and Yij are the off-diagonal elements of matrices X and Y. If the two matrices show similar relationships then Z should be large in comparison to what one would expect by chance. While significance tests are possible by making appropriate assumptions about the distributions involved, tests are usually performed by comparing the observed Z-value with its permutational distribution. This is the distribution one obtains if one compares one matrix, say X, with all possible matrices in which the order of the objects (or variables) in the other matrix, Y, has been permuted. In practice the number of possible permutations, t!, is so large that only a random sample of permutations is used.

Because permuting the order of the objects has no effect upon the mean and variance of a matrix, it is convenient to note that the ordinary product-moment correlation coefficient, r, is monotonically related to Z and has the advantage that it is in more familiar standardized units and hence is easier to appreciate (Smouse et al., 1986 ). A general discussion of the Mantel test is given in Hubert (1987) as one example of a quadratic assignment method. He also gives (pages 125‑126) formulas for approximate means and variances of Z.

If one matrix is a cophenetic (ultrametric) value matrix (from the COPH program) and the other the matrix upon which the clustering was based, then the correlation is called the "cophenetic correlation" and it can be used as a measure of goodness of fit for a cluster analysis. The degree of fit can be interpreted subjectively as follows:

Level | Interpretation
0.9 ≤≤ r | Very good fit.
0.8 ≤≤ r < 0.9 | Good fit.
0.7 ≤≤ r < 0.8 | Poor fit.
r < 0.7 | Very poor fit.

Rohlf and Fisher (1968) show that the usual procedures cannot be used to test the significance of such correlations since one matrix is constructed from the other (the same restriction applies to the Mantel test). They also showed that most cophenetic correlations found are statistically significant. In a similar manner, one can also compute distances based upon a k-dimensional ordination analysis and then compare them with the distances between the objects using the original data. Rohlf (1972) gives many examples of the use of this technique.

Lapointe and Legendre (1992) give tables of critical values for matrix correlations when the two matrices correspond to two independently derived cladograms (matrices of patristic distance), two phenograms (matrices of ultrametric distances), or a phenogram and a cladogram. For more than 12 OTUs a correlation greater than 0.5 will be statistically significant at the 1% level.

The three-matrix permutation test used here is described in Smouse et al. (1986). An analysis of some of its properties is given in Oden and Sokal (1992).

Sometimes most of the lack of fit can be due to just a few OTUs. From the Options dialog box you can select an OTU to be highlighted (plotted using a different plot symbol). The plot options dialog box also allows you to indicate whether or not the diagonal elements are to be plotted (they are ignored in all computations). By default they are not plotted.

Note: the files being compared can each contain more than one matrix. If one file contains 1 matrix and the other n matrices then n plots will be produced - comparing the one matrix with each of the n others. If there are the same number of matrices in each file then the corresponding pairs of matrices will be plotted against one another. If there are more matrices in one file than the other then the "remaining" matrices will be plotted against the last matrix in the shorter file. These features are convenient when using NTSYSpc to analyze simulated data sets.

Right-click on the plot or use the Options menu to display the plot options.

Output:

The means, standard deviations, and the correlation coefficient are written to the listing window along with the results of the Mantel test or the Smouse-Long-Sokal 3-way Mantel test. For the 3-way test, the plot options allow six different combinations of matrices to be plotted (Y vs. X, Y residuals vs. X residuals, X residuals vs. Z, Y residuals vs. Z, X vs. Z, and Y vs. Z).

Program parameters and batch codes.


MXCOMP program parameters

Navigation: Graphics > Matrix comparison & Mantel tests >

MXCOMP program parameters

Batch code | Description
X | Name of the input matrix to be plotted along the abscissa.
Y | Name of the input matrix to be plotted along the ordinate.
Z | Name of the input matrix to be used to adjust the X and Y matrices for a 3-way Mantel test.
N | Should the normalized Mantel statistic be used? The default is yes (checked).
NP | The number of random permutations to be used to test the Mantel statistic (default is 0, meaning none).

From the plot window you can copy the plot to the Windows clipboard or save it as an enhanced Windows metafile.


Comparison of matrices

Navigation: Graphics > Matrix comparison & Mantel tests >

Comparison of matrices

Often one wishes to test whether one set of relationships among a set of objects is independent of another. For example one may wish to test whether the degree of morphological difference or genetic distance between samples is related to the geographical distances between the sampled populations (for morphological examples see Sokal, 1979 , genetic example are Feulner et al. (2004) and Whitehead and Crawford (2006)). A simple way to do this is by the use of the Mantel test (Mantel, 1967 ). The test assumes that the two matrices have been obtained independently - one cannot use it to test two matrices where one has been derived from the other. The steps given below assume that one already has a matrix of geographical distance, gdist.nts.

" Compute morphological dissimilarity matrix

*simint o=data.nts c=dist r=mdist.nts d=row

" Compare mdist with gdist, 250 random permutations

*mxcomp x=mdist.nts y=gdist.nts np=250

While less efficient than a specialized program, one can use the above steps to perform spatial autocorrelation analyses. the only modification needed to the above steps is to replace the geographical distance matrix in file gdist.nts with a series of matrices corresponding to a desired geographical distance class. In each matrix an entry is 1 if objects i and j are within the desired distance class and is 0 otherwise. To make a distance correlogram one simply plots the matrix correlations as a function of geographical distance. The Mantel test can be used to determine which coefficients are statistically different from zero.

This program can also be used to perform a Smouse-Long-Sokal 3-way Mantel test. In this test the two matrices being compared are adjusted to take into account their covariation with a third matrix.


PLOT - Plot one or more variables

Navigation: Graphics > Plot >

PLOT - Plot one or more variables

This module makes a 2D plot of one or more rows (or columns) against a single row (or column). The points may be plotted using different symbols and they may be connected with line segments.

This module is useful for plotting variables as a function of another rather than as scatter-plots (see mxplot or mod3d for 2D and 3D scatterplots).

Right-click on the plot or use the Options menu to display the plot options.

See the technical details topic for more information.


PLOT Program parameters

Navigation: Graphics > Plot >

PLOT Program parameters

Batch code | Description
O | Name of the file containing a matrix to be plotted.
D | The direction corresponding to the variables in the data matrices. The default is By ROWs (checked).
X | Number of the variable to plot along the abscissa.
Y | Numbers of the variable(s) to plot along the ordinate. One or more can be selected.
S | Name of a file containing integer codes indicating which points will be plotted with the same symbol. See the technical details topic for more information.


PROCPLOT - plot superimposed configurations of points

Navigation: Graphics > Procrustes plot >

PROCPLOT - plot superimposed configurations of points

This module is used to plot the consensus configuration and the aligned point configurations computed by the PROCRUSTES module. It is designed for 2 and 3-dimensional data sets.

Individual points in the plots can be identified by left-clicking on them (a small window will display information about the selected point).

Note: when printing to high resolution PCL printers you will have to use the plot options dialog to increase the widths of the lines.

Program parameters and batch codes.


PROCPLOT program parameters

Navigation: Graphics > Procrustes plot >

PROCPLOT program parameters

Batch code | Description
C | Name of a file containing one or more matrices giving the consensus configuration for p points in a k-dimensional space.
A | Name of a file containing the aligned configurations of points.
F | The format of the input matrix. The aligned configurations can be given in n SEPARATE k by p matrices or TOGETHER in a single n by kp matrix. The default is TOGETHER.
N | If the TOGETHER format is used then this field indicates the number of dimensions. The default is 2.
G | The name of a graph matrix indicating pairs of point to be connected.
S | The name of a file containing a matrix with integer codes indicating which aligned configurations should have the same plotting symbol. This allows one to distinguish groups corresponding, for example, to different species.

Note: If the TOGETHER format is used then the input files can consist of pairs of consensus and aligned configuration matrices. If the SEPARATE format is used then there can only be a single consensus matrix in the input file.


AUTOREGR - Fit autoregressive model

Navigation: Computational modules > Autoregression (AUTOREGR) >

AUTOREGR - Fit autoregressive model

This module fits the pure autoregressive model

where y is an observed data vector (perhaps standardized to have a mean of zero and a variance of unity), W is an connection matrix (diagonal elements equal to zero and each row sums to 1) and ε is the error (assumed normal). The parameter ρ is sometimes called the autocorrelation coefficient but it is better called an autoregressive coefficient because it is a regression coefficient and not a correlation coefficient restricted to the interval –1 to 1 (it can sometimes be well outside of that range). An option is available to constrain the solution to the range –1 to 1. Curiously, the constrained and unconstrained estimates of ρ tend to be negatively correlated when the estimate is positive. When constrained, negative estimates often are essentially equal to –1 because the likelihood function does not have a maximum within the constrained range.

The vector [image] is the estimate of a data vector y. The residuals from the model are computed as [image] .

The ρ coefficient is often used to describe the relationship between the vectors y and Wy. If ρ = 0 then no prediction is possible. While value of ρ = 1 implies perfect prediction (zero residuals), other perfect solutions are also possible for a given W matrix. All of the eigenvectors of W correspond to data that would yield perfect fits to the model (with the autoregressive coefficient equal to the reciprocals of the corresponding eigenvalues). In contrast to the usual product moment correlation coefficient, ρ is a measure of spatial scale – not a measure of goodness of fit.

While this method has been successfully applied in studies of spatial autocorrelation analysis, Rohlf (2002) is critical of its extension as phylogenetic autocorrelation analysis in comparative studies. In such studies the phylogenetic covariance matrix (which can be computed from a phylogenetic tree by the COPH module) is used as the connection matrix.

Output:

The following information is displayed for each variable: , I’ (the scaled Moran’s I, which is also the correlation between y and [image] ), and the proportion of the residual sums of squares as proportion of the total sums of squares of the variable. Optionally, a matrix of [image] values and a matrix of residuals can also be save to a file. A graphic speed button is available that will display a plot of y vs. . If there is more than one variable then one can use the plot options dialog to select which variables to plot.

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


AUTOREGR - program parameters

Navigation: Computational modules > Autoregression (AUTOREGR) >

AUTOREGR - program parameters

Batch code | Description
O | Name of the input matrix of variables to be analyzed.
D | The direction (rows or columns) of the variables matrix that corresponds to the OTUs. Default is ROW.
C | Name of the input connections matrix. It can be either a similarity or a dissimilarity matrix. It is used to compute the W matrix.
YHAT | Name to be given to a matrix of predicted values of the variables. (optional)
RESID | Name to be given to a matrix of residuals (observed - predicted values of the variables). (optional)
CON | Constrain estimate of ρ to the interval –1 to 1. The default is unchecked (false).


AUTOREGR - technical details

Navigation: Computational modules > Autoregression (AUTOREGR) >

AUTOREGR - technical details

If the input connection matrix is a similarity matrix then the W matrix is constructed by simply replacing the diagonal elements with zeros and then scaling each row so that they sum to 1. If the input matrix is a dissimilarity matrix then the values are all subtracted from the maximum dissimilarity values and then the diagonals are replaced by zeros and the row scaled to sum to 1.

The program estimates the autoregressive parameter, ρ, using maximum likelihood. The maximum likelihood estimate, , is the value of ρ that minimizes the likelihood function (see Cliff and Ord, 1981). In practice, the determinant in the second term of this function is computed using the relationship [image] , where the λ are the eigenvalues of W, because it requires much less computation when the determinant must be computed repeatedly for different values of ρ. While the data vector y can be standardized (expressed as standard deviations from the mean), [image] must not be standardized as was done by Cheverud and Dow (1985: p. 117), Cheverud et al. (1985: p. 1341), and Gittleman and Kot (1990). This is because doing so implies a rescaling of the W matrix in the first term of the likelihood equation without a corresponding adjustment to the second term (D. Griffith, pers. comm.). See Rohlf (2002) for more details about the algorithm used to estimate ρ using maximum likelihood.

Cheverud et al. (1985: p. 1340) state that having each row of W sum to 1 constrains the estimate to [image] . This is not true – their solutions were constrained due to their standardization of [image] . While estimates, [image] , usually are within the interval –1 to 1, the limits are actually from [image] to [image] , the reciprocals of the negative and positive eigenvalues of W that are closest to zero. ). An option is available to constrain the solution to the range –1 to 1. Curiously, the constrained and unconstrained estimates of ρ tend to be negatively correlated when the estimate is positive. When constrained, negative estimates often are essentially equal to –1 because the likelihood function does not have a maximum within the constrained range.

The residuals from the model are computed as [image] . The sum of squares of these residuals can be used as a measure of the degree of fit of the model.


CANPLS - Canonical correlation & 2-block partial least-squares

Navigation: Computational modules > Canonical correlation & partial least-squares (CANPLS) >

CANPLS - Canonical correlation & 2-block partial least-squares

This module performs canonical correlation analysis and two-block partial least-squares analyses. These analyses are useful to study the relationships between two sets of variables.

The purpose of canonical correlation analysis is find pairs of linear combinations of variables such that the correlation between the corresponding pairs in each set is as large as possible. The linear combinations are constrained, however, to be orthogonal (zero correlation) within each set and also between each set except for the paired linear combinations which have maximal correlation. If there is only a single variable in one set then the linear combinations for the other set are standardized partial regression coefficients. Canonical correlation analysis is described in most texts on multivariate analysis. Useful accounts are given in Everitt and Dunn (1992), Krzanowski (1988), and Reyment (1991)

On the other hand, the purpose of the two-block partial least-squares analysis is to find pairs of linear combinations that account for the observed covariances or correlations between the two sets of variables. The linear combinations are not constrained to be orthogonal within each set of variables. The correlations between corresponding linear combinations are not expected to be as large as the canonical correlations but they are often rather close. On the other hand, the linear combinations are often much easier to interpret. This may be a consequence of the fact that they are subject to fewer constraints. This method is relatively new. An introduction is given in Bookstein (1982) and Bookstein (1986b). A description and applications to morphometrics is given in Rohlf and Corti (2000). An application to the study of the effects of prenatal alcohol is given in Sampson et al. (1989).

If a data matrix is provided then permutation tests can be performed for both methods. Counts are made of the number of random permutations of the samples in the first set versus those in the second set that yield correlations equal to or larger than those in the original data. Counts are also made for the cumulative contributions of each dimension.

Output:

The input parameters are written to the output listing along with the input correlations or covariances, estimated linear combinations, correlations between the linear combinations and the variables, and the residual correlation matrix. Graphic speed buttons are available to plot the left and right scores against each other as well as 2D and 3D ordination plots with the linear combinations superimposed as in a biplot.

Program parameters and batch codes.

Technical computational details.


CANPLS program parameters

Navigation: Computational modules > Canonical correlation & partial least-squares (CANPLS) >

CANPLS program parameters

Batch code | Description
O | Name of the input data matrix or matrix of correlations among all of the variables to be operated upon.
D | If a data matrix is used, do the variables correspond to the rows or columns of the matrix. The default is columns (unchecked).
S | A list of the members of the first (“left”) set. Use integers separated by spaces, commas, or plus signs (note: in batch files only the plus sign can be used). All other variables will be assigned to the second (“right”) set.
M | Code for the method to be used CANCOR or PLS (default).
S1 | If a data matrix is used, should the variables in set 1 be standardized? The default is unchecked.
S2 | If a data matrix is used, should the variables in set 2 be standardized? The default is unchecked.
K | The number of linear combinations (dimensions) to be computed. Default is 1.
N | If > 0 then this gives the number of random permutations to be used for a randomization test.
L | Name to be given to the linear combinations of variables in the first set (the matrix on the left, optional).
R | Name to be given to the linear combinations of variables in the second set (the matrix on the right, optional).
VAL | Name to be given to the matrix of singular values (optional).
LS | If a data matrix is used then a matrix of the projections (scores) on the first set of variables can be saved as a matrix using this name.
RS | If a data matrix is used then a matrix of the projections (scores) on the second set of variables can be saved as a matrix using this name.
LC | Name to be given to the matrix of correlations between the linear combinations on the left and all of the variables (optional).
RC | Name to be given to the matrix of correlations between the linear combinations on the right and all of the variables (optional).
W | Name to be given to the block diagonal weight matrix of both sets of linear combinations (optional).
RE | Name to be given to the matrix of residuals from the correlation matrix after the effects of the linear combinations have been removed (optional).


CANPLS technical details

Navigation: Computational modules > Canonical correlation & partial least-squares (CANPLS) >

CANPLS technical details

The computation of the canonical correlations is performed as follows. Let R11 and R22 correspond to the n1 by n1 and n2 by n2 matrices of correlations among the variables in the first and second sets and R12 correspond to the matrix of correlations between the variables in the two sets. The eigenvectors, U, of

are premultiplied by [image] and then scaled so that

to yield the linear combinations for the first set. The corresponding steps are performed for the matrix V of linear combinations for the second set. The maximum number of vectors that could be retained is min(n1,n2).

The correlations among the linear combinations are computed as [image],

where [image] and [image] .

Note: it may be necessary to reflect some of the column vectors so that the correlations between corresponding columns of U and V are positive. The correlations between the linear combinations and the original variables is computed as [image] . The residual of the correlation after the effects of the canonical variables are removed is computed as [image] .

The computational steps for two-block partial least-squares are much simpler. The linear combinations, U and V, are given directly by the singular value decomposition [image] . The matrix of correlations among the linear combinations is computed as [image],

where S and W are as defined above. The correlations between the linear combinations and the original variables is computed as . The residual of the correlation after the effects of the canonical variables are removed is computed as [image] , where C is a diagonal matrix with 1s and 0s on the diagonal to indicate which axes are included or excluded from the computation. Note: all columns of U and V must be used in the W matrix for these computations -- even those with singular values equal to zero. This is because the residuals are computed directly rather than by subtraction as in canonical correlation analysis (this is necessary in order to take the correlation among the axes into account).

If raw data files are input rather than correlation matrices then projections (scores) for each sample can be computed by a simple matrix multiplication of the centered (and perhaps standardized) data matrix times the matrices giving the linear combinations.


CVA - Canonical variates analysis

Navigation: Computational modules > Canonical variates analysis (CVA) >

CVA - Canonical variates analysis

This module performs a canonical variates analysis and can be used to carry out a single classification multivariate analysis of variance (MANOVA). It can also be used as an ordination method to display the relationships among group means relative to the within-group variation or to assign unknown specimens to two or more predefined groups. Additional information is show in the examples section.

An important feature of this program is that it performs a principal components analysis on the pooled within-groups covariance matrix. This enables it to ignore components whose eigenvalues are less than a user-specified cutoff. This allows the program to be used on sets of variables that are known to be redundant (such as coordinates of aligned specimens in geometric morphometrics).

The program has two different modes of input:

• Input a table of group means, group sample sizes, and a pooled within-group variance-covariance matrix (these can be constructed using the POOLVC module). The program will then compute the canonical vectors.
• Begin with the input of a matrix of group means, group sample sizes, and the canonical vectors.

In either case, the program will (optionally) compute the canonical scores, generalized distances between all pairs of groups, covariance of the variables with the canonical axes, or try to assign new specimens to one of the existing groups.

Output:

The program displays the names of the input matrices, input parameters, etc. If a detail listing is requested then additional information will be displayed in the output listing. Of most interest will be a display of the values on the diagonal of the B* matrix (see technical details topic). If the values corresponding to the last within-group PCs have the largest values then there may be problems with singularities in the pooled within-group covariance matrix (due to small sample sizes or large correlations). Various tests of significance will be displayed. A classification table will be displayed if data for testing are also provided.

Since the computation of eigenvalues and eigenvectors can take a while when there are many variables, some information will be displayed on the screen to indicate the progress that the program is making.

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


CVA program parameters

Navigation: Computational modules > Canonical variates analysis (CVA) >

CVA program parameters

Batch code | Description
M | Name of the input matrix of group means.
D | Direction corresponding to variables in the group means matrix: rows or cols (default is by rows). Note: the POOLVC matrix outputs variables as columns
V | Name of the pooled within-groups covariance matrix (optional).
GS | Name of file of group sample sizes.
AV | Name of file for among-groups covariance matrix (optional).
CV | Name of file for canonical vectors (optional).
VV | Name of file for matrix of regressions of group differences on scores (optional).
CS | Name of file for mean canonical scores for each group. These are projections of deviations of group means from the grand mean onto the canonical variates (optional).
GD | Name for a matrix of generalized distances, D, between all pairs of group means.
TD | Name of a file containing one of more data matrices to be used to test the canonical variates (optional). Can be the same as the original data file but better to use independent data. The number of groups need not be the same as in the input.
TS | Name of a file for the canonical scores from the test data (optional).
SD | Show details. Output listing contains more details.
CO | Cutoff criterion for eigenvalues of within-groups variance-covariance matrix. Default is 0. This can be changed to a value such as 10-8 (entered as 1.0E-8) in order to ignore singular dimensions in the data (caused, for example, by having redundant variables or small sample sizes).


CVA technical details

Navigation: Computational modules > Canonical variates analysis (CVA) >

CVA technical details

The module computes the p××p among-groups variance-covariance matrix, B, based on the a××p matrix of group means (weighted by the sample sizes of the a groups) and univariate F-ratios are computed for each of the p variables. Each sample Fs-value is to be compared to an F-distribution with = a-1 over [image] degrees of freedom (where [image] is the size of the ith group).

Next, a principal components analysis is performed on the pooled within-groups variance-covariance matrix, W. If the matrix is found to be singular (eigenvalues found that are smaller than the user-supplied cutoff criterion) then those eigenvalue and vectors will be ignored in subsequent computations.

The module weights the within-group eigenvectors, E, so that their lengths are equal to [image] (where [image] are the eigenvalues greater than the cutoff criterion).

The standardized among-group variance-covariance matrix using the within-group PCs as variables, B*, is computed as B*=Et B E and principal components analysis performed on it. The diagonals of this matrix are displayed if the ShowDetails option is used. If the last few elements are larger than the rest then that indicates that some of the apparent differences among groups may just be due to singularities in the within-group covariance matrix (especially if sample sizes are small).

Let E*denote the normalized eigenvectors of B*. There are at most a-1 vectors with non-zero eigenvalues.

The matrix of canonical vectors, C, is computed as C = EE*. The matrix of canonical scores, P, is computed as [image] , where [image] is the a××p matrix of deviations of the group means from the grand means.

The matrix of regression of group differences on the canonical scores is computed as [image] .

This matrix has the important property that [image] . Thus the matrices P and V represent a factorization of the matrix of deviations of the group means from the grand mean and can be used for a biplot or a bimodel of the group differences. Note that the usual practice of jointly plotting C and P will give an incorrect impression of the relationships between group differences and variation among the variables (unless C happens to be orthogonal). A biplot can be made by the MXPLOT module using the P matrix as the primary input matrix and the V matrix as the secondary input. Normalization should be set to NO.

Eigenvalues and eigenvectors of both W and B* variance-covariance matrices are computed by first reducing the input matrix to tridiagonal form using Givens and Householder reductions. Eigenvalue and eigenvectors are then computed from resulting matrix using a QL algorithm with implicit shifts as described by Press et al. (1989).

Several alternative tests of significance for differences among the group means are provided. A transformation to a F-statistic is also provided. In the formulas given below let q be the rank of the B* matrix ( [image] , unless the W matrix is singular) and the degrees of freedom of W are [image] .

Wilk's lambda:

, [image] ,

where [image] (if [image] > 0, else b = 1),

and the degrees of freedom are

,

The test for Λ can be decomposed to yield a series of tests of whether the kth root of B*, [image] , and subsequent roots are equal to zero and thus the corresponding canonical vectors can be ignored.

Pillai's trace: , where [image] , [image] ,

and the degrees of freedom are [image] and [image] .

Hotelling-Lawley trace: ,

and the degrees of freedom are [image] and [image] .

Roy's maximum root:

, [image] ,

the degrees of freedom are [image] and [image] .

The matrix of generalized distances is computed as ordinary Cartesian distances from the matrix of canonical scores. Note that distances are given not squared distances.

The assignment of each specimen in a set of test data is made on the basis of each specimen's generalized distance to each group mean. Each specimen is assigned to the closest group no matter how far away it is. The printout of individual distances should be examined to see whether a new specimen does not belong to any of the existing groups.


Canonical variates analysis - batch file

Navigation: Computational modules > Canonical variates analysis (CVA) >

Canonical variates analysis - batch file

Canonical variates analysis, CVA, is used to study the variation among two or more groups (samples) of specimens relative the average variation found within the groups. The overall significance test for CVA is also the appropriate significance test for a single classification multivariate analysis of variances, MANOVA.

A CVA is usually performed in two steps. The POOLVC module is used first to compute the means and the average within-group covariance matrix. The POOLVC module requires the data matrices for the groups to be stored one after the other in the same file. They must all have the same number of variables and be oriented the same way (e.g., with rows as variables) The CVA module then does the rest of the computations. An example is given below.

“ display the matrices for checking

*output O=data.nts

“ compute means, pooled cov., and group sizes

*poolvc O=data.nts, D=row, M=means.nts, V=PooledCV.nts, GS=GroupSizes.nts

“ perform CVA

*CVA M=means.nts, D=row, V=PooledCV.nts GS=GroupSizes.nts CS=scores.nts

*mxplot o=scores.nts

Note: the plot options should be used to force the plot to have the proper aspect ratio. If this is not done then you will obtain a distorted impression of the relationships among the points.

It there are more than just a few groups, one may follow this computation up by doing a cluster analysis of the matrix of generalized distances. One will probably also wish to compute a minimum spanning tree and superimpose in on the 2D or 3D plot of the canonical scores.


Combine matrices

Navigation: Computational modules > Combine (COMBINE) >

Combine matrices

This module is used to append one or more matrices to the rows or the columns of another. It can be used, for example, to add additional variables or observations to a data matrix.

If both the O1 and O2 matrices are specified then each matrix in O2 will be appended to the corresponding matrix in O1. If only the O1 matrix is specified then all of the matrices in the O1 file will be combined into a single matrix. If the matrices are rectangular then matrices of group ID codes and group sizes can be created.

Program parameters and batch codes. See also Split.


COMBINE - program parameters

Navigation: Computational modules > Combine (COMBINE) >

COMBINE - program parameters

Batch code | Description
O1 | Name of the first input matrix. The matrix must be either rectangular or diagonal.
O2 | Name of the second input matrix (optional). the matrix must be the same type as the first matrix. If left blank then all the matrices in the first file are combined into a single matrix.
D | The direction (rows or columns) that matrices will be appended. Default is ROW.
R | Name for the resultant combined matrix.
ID | Name for a matrix of ID codes (useful for plotting ID codes in MXPLOT and MOD3D). Only valid if combining rectangular matrices.
GN | Name for a matrix listing the sample sizes for each matrix being combined. Only valid if combining rectangular matrices. This matrix can be useful for input to the SPLIT and CVA modules.


CPCA -- Common principal components analysis

Navigation: Computational modules > Common PCA (CPCA) >

CPCA -- Common principal components analysis

This module performs a common principal components analysis, CPCA, i.e., it is used to fit a common set of principal component axes to two or more variance covariance matrices. Given k p××p covariance matrices Si, the goal is to find an orthogonal matrix B of common principal components such that the [image] are as diagonal as possible for all i. The method is described by Flury (1984, 1988). It will often be of interest to try this analysis when the POOLVCV program indicates that a series of variance covariance matrices are homogeneous.

The input to this module consists of either a file containing two or more raw data matrices or else a file containing two or more covariance matrices. If covariance matrices are used then a matrix of sample sizes must also be provided (this can be a rectangular matrix with one row and columns corresponding to each group).

Note: input matrices should not be singular or close to it. If the principal component axes are very short then it does not make much sense to ask if they are parallel. It will also result in the determinants used in the tests to be very close to zero. Thus one should expect to get better results with fewer and less highly correlated variables.

Output:

The input parameters are written to the output listing along with (if a detailed listing is requested) the pooled variance-covariance matrix, a test for the common principal components model, the common principal components, and the eigenvalues for each group.

Projections (scores) of each observation onto the common axes can be computed using the PROJ module.

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


CPCA program parameters

Navigation: Computational modules > Common PCA (CPCA) >

CPCA program parameters

Batch code | Description
O | Name of the input data matrices (not needed if covariance matrices are entered).
D | The direction of the data matrices corresponding to the variables, default is ROWS (checked).
S | Name of a file containing input covariance matrices (should not be given if data matrices are provided above).
GS | Name of an array of sample sizes for the covariance matrices. Not used if data matrices are entered.
N | Number of dimensions to report.
B | Name for matrix of common principal components.
LAM | Name for a matrix of eigenvalues for each group.
COV | Name for the matrix of covariances among the common principal components in each group.


CPCA technical details

Navigation: Computational modules > Common PCA (CPCA) >

CPCA technical details

The computational algorithm used is that of Clarkson (1988). This is an extension of the methods given in Flury and Constantine (1985). An iterative maximum likelihood method with computing time proportional to k p3 is used. Thus time can increase rapidly as the number of variables increases.

Two tests of significance are provided. The test for goodness of fit of the common principal components model is [image] ,

where [image] , B is the maximum likelihood estimate of the common principal components, and ΛΛi is the matrix of diagonals of [image] . This statistic is to be compared to the χχ2 distribution with (k-1)p(p-1)/2 degrees of freedom.

A test is also performed for testing the hypothesis of equality of covariance matrices versus the common principal components model. The statistic is [image] , which is to be compared to a χχ2 distribution with (k-1)p degrees of freedom.


CONSEN -- Consensus trees and indices

Navigation: Computational modules > Consensus trees & indices (CONSEN) >

CONSEN -- Consensus trees and indices

This module produces a consensus tree and computes consensus indices from two or more rooted labeled trees. A consensus tree is a tree (actually just a dendrogram since it consists of nested sets and their levels, the term "tree" is used in a more technical sense in graph theory) that represents the consensus topology (subset relationships) of two or more trees. A consensus index is a numerical value that indicates the degree to which the consensus tree is resolved (fully bifurcating). If the original trees are fully resolved then the degree to which the consensus tree is fully resolved is a measure of the similarity of the original trees.

The module can be used, for example, to compare trees produced by different clustering methods or to construct a tree that is a summary of many trees. Three different methods of constructing consensus trees are available in this module: strict consensus (Sokal and Rohlf, 1981 ), Stinebrickner consensus (Stinebrickner, 1984 ), and majority rule consensus (Margush and McMorris, 1981 ). Four different consensus indices are computed and included in the output. A description of these methods and indices is given below.

The input to this module consists of sets of nested clusters in the form of a tree matrix - such as produced by the SAHN clustering module. The trees being compared must all have the same number of OTUs. In addition, in order for the results to make any sense, the trees must correspond to the same set of objects that were in the same original order. Trees with OTU height information and trees with branch lengths (nexus files) can also be used but only the information on nested set relations will be used. Branch lengths and OTU heights will be ignored.

There are two modes of input. The trees can be input in two different files, e.g., O1 and O2. The module will do pairwise computations between each corresponding pairs of trees in files O1 and O2. If O2 is empty, then all the trees in O1 will be compared against each other and a single consensus tree will be produced. A convenient way to place several trees from the SAHN module in the same file is to use the same file name and select the append option for the OVERWRITE configuration parameter.

Note: consensus methods consider only the set-relationships implied by the trees. The numerical values of the levels are ignored. In order to take levels into consideration when comparing a pair of trees one could compute a cophenetic (ultrametric) value matrix for each tree (using the COPH module) and compare them using the MXCOMP module.

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


CONSEN technical details

Navigation: Computational modules > Consensus trees & indices (CONSEN) >

CONSEN technical details

A rooted and labeled dendrogram, such as an UPGMA phenogram, can be represented as a collection of sets if the levels of branches are ignored. For a tree with n OTUs each node corresponds to a hypothetical taxonomic unit, HTU, and represents a subset of the n OTUs that is comprised of all OTUs that have that HTU as their ancestor in the tree. Tree A, given in the example below can be represented as {1,2,3,4,5,6,7,8}, {1,2,3,4}, {5,6,7,8}, {1,2}, {3,4}, {5,6}, {7,8}, {1}, {2}, {3}, {4}, {5}, {6}, {7}, {8}. All consensus methods can be represented as rules operating on these subsets.

MAJRUL A majority rule consensus tree is comprised of subsets that are found in majority of the m trees. That is, the subsets must be found in more than S = 50% of the trees. For m = 2, majority rule consensus and strict consensus trees are the same. When there are more than m = 2 trees being compared one can use values of S between 0.5 and 1.0. S = 0.5 corresponds to the usual majority rule method and S = 1 corresponds to the strict consensus of a collection of trees. For this method there is additional output in the listing file— all of the sets, their frequency among the trees, and those included in the consensus tree are listed. This option is also useful when the trees being compared result from bootstrap sampling.
STINEB A Stinebrickner consensus tree has a more complex definition. For each subset of size p ("cardinality p"), containing an OTU i, the intersection and the union are taken through all subsets of the m trees that have p or fewer members and also containing OTU i. The cardinality of the intersection is divided by the cardinality of the union. If this value is equal to or greater than the parameter Sc, then that intersection is included as a subset in the consensus tree. A detailed description of the algorithm is given in Stinebrickner (1984). The Sc parameter can be varied from 0.0 to 1.0. It allows a more flexible approach to the construction of consensus trees than does the strict consensus method. If Sc = 1.0 then this yields strict consensus trees. As the Sc value decreases to 0.0, additional subsets will be included in the consensus tree.
STRICT A strict consensus tree of m trees is a tree represented by a collection of subsets such that each subset of the consensus tree is a member of all m trees. That is, only subsets that are present in all m trees are included in the strict consensus tree.

The module computes the following consensus indices:

Nset The total number of subsets in the consensus tree, excluding the total set, and the subsets with a cardinality of one.
CIc N set divided by the maximum possible value, which is n ‑ 2 for fully resolved trees. This is also known as consensus fork index, or Colless' index.
CIM Mickevich's index (Mickevich, 1980 ) based on a weighted count of the subsets. The index is , where , ni is the cardinality of subset i, t is total number of OTUs, and Nmax is the largest value possible (see Rohlf, 1982 ). This index is known to give higher values for trees that are more imbalanced.
CISF The levels sum index of Schuh and Farris (1981). It represents another way of defining weights on the subsets. It is given by Ni, where Ni = ni(ni ‑ 1)/2. The maximal value can only be reached when the tree is maximally imbalanced and is known to be even more sensitive to shape of the tree than CIM.
CIS The Stinebrickner consensus index is computed if the Stinebrickner consensus tree is computed. The index is equal to ΣΣHi, where Hi is the cardinality of the intersection of subsets divided by the cardinality of the union. The subsets i are considered in the manner described above and the sum is taken only for those subsets belonging to the consensus tree.

For the Majority rule consensus tree, all of the sets found among the various trees are listed along with their frequency. Those included in the final tree are indicated in the listing.

The scale along the consensus dendrogram is arbitrary. It only indicates the nesting relationships of the sets - not an amount of difference between the sets in the original trees. The actual values are not of interest.

The consensus index of a given tree measures how well resolved the tree is (i.e., whether the tree is fully bifurcating or not). If two or more trees are identical in their subset relationships, the resulting consensus tree is fully bifurcating, otherwise incompatible subset relationships result in multifurcating branches. Therefore, consensus indices applied to consensus trees give an numerical measure of similarity between the trees used to construct the consensus tree.


CONSEN program parameters

Navigation: Computational modules > Consensus trees & indices (CONSEN) >

CONSEN program parameters

Batch code | Description
O1 | Name of the input tree matrix 1 (maximum of 500 objects in the tree). Files can be of type NTS or NEX.
O2 | Name of the input tree matrix 2.
M | Consensus method (see list below).
R | Name to be given to the resultant consensus tree matrix.
S | S, index of stringency (used by STINEB and MAJRUL).
SS | Show sets in the consensus? Default = No. For MAJRUL and STINEB frequencies are also shown.
SF | Shows the sets and their frequencies in the final MAJRUL or STINEB consensus trees. Default = Yes.
ST | Display the final consensus trees in the output listing file? Default = No. If shown, character graphics are used. In any case, a graphic plot of the consensus tree is available but clicking on the Graphic speed button.

If the O2 field is blank then the trees are taken from the O1 file. Otherwise trees in the O1 file are paired against the corresponding trees in the O2 file.

Codes for methods:

STRICT | Strict consensus (default).
STINEB | Stinebrickner s-consensus method.
MAJRUL | Majority-rule consensus method.


COPH -- Cophenetic (ultrametric) values

Navigation: Computational modules > Cophenetic (ultrametric) values (COPH) >

COPH -- Cophenetic (ultrametric) values

This module performs three types of computations. First, it can take a hierarchical system of clusters and produce a symmetrical matrix of "cophenetic" (ultrametric) similarity or dissimilarity values. These can be used, for example, to test for the goodness of fit of a clustering to a set of data. An i,j value in this matrix represents the similarity or dissimilarity between object i and object j as implied by the system of nested clusters. A discussion of the properties of cophenetic values is given in Rohlf and Sokal (1981).

Second, it can take a rooted or unrooted tree and produce a matrix of path length distances between all pairs of OTUs. This could be used to test the goodness of fit of an additive tree to a dissimilarity matrix.

Third, it can take a rooted tree and produce a matrix giving the expected variances and covariances based on a Brownian motion model of evolution. The covariances are simply the heights of the most recent common ancestors of each pair of OTUs. The variances are the heights of each OTU on the tree. This matrix can be used as the input covariance matrix for the mulreg module in order to correct a regression analysis for the expected lack of independence among a set of related OTUs.

The input to this module consists of a set of nested clusters in the form of a tree matrix , such as produced by the SAHN clustering module or a tree described in a nexus file. The cophenetic value matrix can be used to test the goodness of fit of a cluster analysis to the data by using the MXCOMP module to compare the original similarity or dissimilarity matrix that was clustered with the cophenetic value matrix. See the discussion in MXCOMP for further information about this technique.

Output:

The input parameters and the resultant cophenetic value matrix are displayed and the cophenetic value matrix is stored on disk. The next step is normally to use the MXCOMP module to compare the cophenetic value matrix with the original matrix that was clustered.

Program parameters and batch codes.


COPH program parameters

Navigation: Computational modules > Cophenetic (ultrametric) values (COPH) >

COPH program parameters

Batch code | Description
O | Name of the input tree matrix to be operated upon.
R | Name to be given to the resultant cophenetic value matrix.
M | Method code. The default is “UltrametricDis”.

Codes for methods:

AdditiveDis | Path length distances.
PhyloCov | Phylogenetic covariances.
UltrametricDis | Ultrametric distances.


CORRESP - Correspondence analysis

Navigation: Computational modules > Correspondence analysis (CORRESP) >

CORRESP - Correspondence analysis

This module performs a correspondence analysis, CA. Correspondence analysis is similar to principal components analysis, PCA, but it differs in several important aspects. First, PCA is appropriate when one has a matrix of measurements of a set of p variables on a set of n objects. In CA the data are in the form of a 2-way contingency table of observed frequencies. The term “correspondence analysis” is sometimes used rather loosely to mean a singular-value decomposition, SVD, applied to a data matrix. In PCA one can obtain a "biplot" in which the objects and the variables are superimposed on the same plot so that one can study their inter-relationships. In CA one obtains an analogous plot for the row and column variables of the contingency table. In PCA one judges proximities among the objects using Euclidean distances and among the variables using covariance (or correlation). In CA one uses Chi-square distances to judge proximities for both the row and for the column variables.

Output:

The input parameters are written to the listing device or file. The trace of the matrix S1, the X2 value for a "Chi-square" test of independence of the rows and columns (the trace times the total sample size), and the eigenvalues of the S1 matrix are output. In addition, the relative frequencies and chi-squared distances to the centroid are listed for both the row and column variables.

The coordinates of the row and column variables on the factors are usually superimposed on the same scatter diagram. This allows one to not only appreciate the relationships among each set of variables (closer points are more similar), but also the relationships among the row and column variables. Note that Lebart et al. (1984, p. 46) warn that one must normally interpret the relative positions of points in one set (rows or columns) only in terms of the set of all points in the other set. It is dangerous to interpret the proximity of a particular row and column point. The interpretation must be in terms of projections (see technical details topic).

The matrices of absolute contributions can be examined to see which variables are the most important contributors to the variance explained by each factor. The matrices of squared correlations can be examined to determine on which factors a variable has the most influence.

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


CORRESP technical details

Navigation: Computational modules > Correspondence analysis (CORRESP) >

CORRESP technical details

The Chi-square distance between two columns i and j, for example, is:

were the "dot" means summation over that subscript. This distance can be computed using the SIMINT module in NTSYSpc. Note that a principal coordinates analysis of a Chi-square distance matrix does not yield the same results as CA — since in CA the objects are weighted according to their frequencies.

In correspondence analysis one fits the following model to the observed data:

where fij are the observed relative frequencies, xij/xŸŸ , fiŸ and fŸj are the relative frequencies of the rows and columns, λk is the kth eigenvalue, and ψik and ϕjk are elements of the row and column factor matrices. Thus, the factors describe the patterns of deviations from independence. If the rows and columns were perfectly independent then the eigenvalues would all be equal to zero. Note: this module outputs matrices of factor coordinates, [image] and [image] , rather than the factors themselves.

The module follows, in part, the computational outline given in Lebart et al. (1984). The module computes eigenvalues and eigenvectors for either the rows or columns (whichever is less) and then computes the other vectors by projection. For example, if the number of columns is less than the number of rows then the module computes the eigenvalues and eigenvectors of the matrix

where [image] , Dn is a diagonal matrix of fiŸ, Dp is a diagonal matrix of fŸj, and F is the n by p matrix of relative frequencies. If n < p then a corresponding matrix is factored to give the row eigenvectors. Note: the first eigenvalue (always equal to 1) and its associated eigenvector are not displayed or saved.

Greenacre (1984) is a general text on correspondence analysis and furnishes many examples and extensive discussions. He also shows how it can be computed using the following singular-value decomposition: ,

where [image] and [image] .


CORRESP program parameters

Navigation: Computational modules > Correspondence analysis (CORRESP) >

CORRESP program parameters

Batch code | Description
O | Name of the input data matrix to be operated upon. This will usually be a contingency table.
N | The number of factors to be extracted (default is 3).
RF | Name to be given to the matrix of coordinates for the row factors, [image] .
CF | Name to be given to the matrix of coordinates for the column factors, [image] .
VAL | Name to be given to a diagonal matrix of the eigenvalues (optional).
RA | Name to be given to the matrix of "absolute contributions" for the row factors (optional). These give the proportion of the variance of a factor explained by each variable.
CA | Name to be given to the matrix of absolute contributions for the column factors (optional).
RC | Name to be given to the resultant matrix of "squared correlations" for the row factors (optional). These give the proportion of the variance of a variable explained by each factor (optional).
CC | Name to be given to the resultant matrix of squared correlations for the column factors (optional).
SD | Show details of the results in the listing.


OUTPUT -- Display matrices

Navigation: Computational modules > Display matrices (OUTPUT) >

OUTPUT -- Display matrices

Formats matrices into tables with labels for the rows and columns. It allows the user to specify the width of each field and the number of decimal places. It is also possible to specify rectangular or tree matrices that give a new ordering for the rows or columns of the matrix. This can be very useful since it displays members of the same cluster next to one another for comparison. Output can be sent to a file and can be input by most word processors. This program can also be used to check whether an input matrix file has been correctly prepared for NTSYSpc.

If the output listing is copied and pasted into Word the columns will not lineup unless a fixed-width font such as Courier is used. An alternative is to use the NTedit module to save a matrix as a .CSV file. These files can be read into Excel and one can then copy and paste a matrix from Excel into Word as a table that can be aligned and formatted for publication.

Output

The matrix is formatted and sent to the listing window. Note: for larger matrices you may find it useful to change the font to use smaller characters and thus more characters per line (both on-screen and in printouts).

The usual method to specify a new order for the rows or the columns of a matrix is to furnish the name of a tree matrix that was produced by the SAHN program. One may also prepare a rectangular matrix (which consists of only a single row or column) that contains a list of integers that give the desired order of output.

Program parameters and batch codes.


OUTPUT program parameters

Navigation: Computational modules > Display matrices (OUTPUT) >

OUTPUT program parameters

Batch code | Description
O | Name of the file containing matrices to be printed. Nexus tree files can also be processed.
W | The width of the output field for each element of the matrix. It should be greater than 0 (default is 9).
D | The number of decimal places to be printed. It must be less than the field width. It can be zero (default is 3).
PW | The width of the output page (default is 80).
L | Should the rows and columns be labeled? (Default is checked.) If not checked then they will just be numbered.
RO | The name of a matrix to specify a new order for the rows.
CO | The name of a matrix to specify a new order for the columns.


DCENTER -- Double center

Navigation: Computational modules > Double center (DCENTER) >

DCENTER -- Double center

This module can be used to transform a symmetric similarity or dissimilarity matrix to scalar product form so that its eigenvalues and eigenvectors can be computed (resulting in a Principal Coordinates analysis, Gower, 1966 ). If the input matrix is a dissimilarity matrix then the off-diagonal element, dij, is first replaced with [image]. The matrix is then “double centered” (the row and column means are subtracted from each element and the grand mean is added on). When this matrix is factored (using the EIGEN module) the elements of the eigenvectors corresponding to positive eigenvalues can be interpreted as the coordinates of each point in a Cartesian space. Rohlf (1972) showed that, when there were missing values in the data, principal coordinates analysis gave much better results than did principal components analysis (but multidimensional scaling did even better). Principal components analysis tends to place objects with many missing values closer to the centroid of the space. When there are relatively few objects but many variables in a study, principal coordinates analysis may also be much faster—due to having to compute eigenvectors of a much smaller matrix.

Note: this module is provided as a convenience. The same operations can be performed using the TRANSF module. There is also an example of it use.

Output

The transformed matrix is listed and stored in the specified file. In the transformed matrix the diagonal elements can be considered to be the squared distance from each object to the centroid of the space. An off-diagonal element, e.g., gij, can be interpreted as [image] , where di and dj are the lengths of vectors connecting objects i and j to the centroid of the space and θθij is the cosine of the angle between these two vectors.

The next step is normally to use the EIGEN module to compute the eigenvectors of the transformed matrix. The resulting vectors are the principal coordinate axes. If there are no missing values then the results are identical to principal components analysis since distance coefficients were used. The results will not be the same if other coefficients (e.g., various association coefficients) are used.

The goodness of fit can be measured by constructing a distance matrix from this eigenvector matrix (using SIMINT ) and comparing it to the original similarity or dissimilarity matrix (using the MXCOMP module). One could also use the percentage of the total variance that is explained by the first few eigenvectors (as printed by the EIGEN module). However, that is often a less useful statistic when one is interested in capturing information on the pattern of relative distances among the objects rather than on the total absolute distance between the objects (see Rohlf, 1972 ).

Program parameters and batch codes.

Program parameters and batch codes.


DCENTER program parameters

Navigation: Computational modules > Double center (DCENTER) >

DCENTER program parameters

Batch code | Description
O | The name of the input similarity or dissimilarity matrix to be operated upon.
R | Name for the resultant transformed matrix.
S | If a dissimilarity matrix is used, should its elements be squared? The default is Yes.


Principal coordinates analysis

Navigation: Computational modules > Double center (DCENTER) >

Principal coordinates analysis

PCOORDA can be thought of as a computational alternative to PCA. The steps shown below will give results identical to PCA. One important consideration is that when there are many fewer points than variables computation time may be much less than for PCA.

The batch file given below performs the following operations: the data matrix is standardized by variables (rows), a matrix of distances between the objects is computed, the distance matrix is double-centered, the double-centered matrix is then factored and a plot is made showing the objects in a 3-dimensional space.

" standardize data if in different units

stand o=data.nts r=sdata.nts

" Compute distances among objects

simint o=sdata.nts r=dist.nts

" Double-center the distance matrix

dcenter o=dist.nts r=distCentered.nts

" eigenvectors correspond to projections of objects

eigen o= distCentered.nts n=3 r=proj.nts val=val.nts

output o=proj.nts

" Display -- Note that direction is "col"

mod3d o=proj.nts d=col

PCOORDA can also be viewed as a distinct ordination method since it can also be applied to various types of similarity and dissimilarity matrices or even to experimentally determined proximity matrices where there is no original “data matrix.” The computational steps would then be as follows:

" Double-center the matrix

*dcenter o=dist.nts r= distCentered.nts

" Extract eigenvectors

*eigen o= distCentered.nts n=3 r=proj.nts val=val.nts

" Output eigenvectors = projections

*output o=proj.nts

" Display -- Note that direction is "col"

*mod3d o=proj.nts d=col

Note that is a 2D plot is made, the plot options must be used to force the plot to have the proper aspect ratio. If this is not done then you will obtain a distorted impression of the relationships among the points.


EIGEN - Eigenvectors

Navigation: Computational modules > Eigenvectors (EIGEN) >

EIGEN - Eigenvectors

Computes eigenvalues and eigenvectors for real symmetric matrices (e.g., correlation matrices, variance-covariance matrices, etc.). What this program does is to find the scalars and the matrix F such that [image] , where A is the n by n symmetric matrix to be operated upon, λλi is the ith eigenvalue (ith diagonal element of a matrix ΛΛ), and fi is the ith eigenvector (ith column of F). By convention, the eigenvalues and eigenvectors are ordered according to the magnitude of the λλi, with the largest given first. For a symmetric matrix the λλi will all be real numbers. The λλi should be ≥≥0 for correlation and variance-covariance matrices. Exceptions can occur when there are missing values in the data matrix and when principal coordinates analysis is applied to an arbitrary matrix. One hopes in such cases that the negative eigenvalues are small so that the corresponding axes (which are imaginary if they have negative variances) can be ignored.

The number of dimensions to be retained and the method of scaling of the lengths of the vectors can be specified. The default scaling (length of the vectors equals the square root of their eigenvalues) is used most often. But when used with matrix algebra operations, the normalized form (length = 1) may be more convenient. Reciprocal scaling yields the eigenvectors of the inverse of the input matrix (but in reverse order).

If the input matrix is a variance-covariance matrix then various tests of significance can be performed if one is willing to assume that the variables follow a multivariate normal distribution. Note that these tests are not appropriate if, as in the usual applications in numerical taxonomy, the OTUs are selected rather than sampled at random from some homogeneous population. If the number of degrees of freedom of the matrix is furnished then Anderson’s (1963) modification of Bartlett’s (1950) test for the equality of roots is computed. This test is sometimes used to indicate the number of statistically significant dimensions (dimensions corresponding to homogenous roots are ignored). Unbiased estimates of the eigenvalues and their standard errors are computed. The proportions of the variance expected under the broken stick model are provided. Those dimensions with observed proportions greater than those of the broken stick model (Joliffe, 1986) explain more of the variance than expected due to chance alone.

If the input matrix is a correlation matrix, then tests are performed for the equality of all roots (equivalent to a test that all correlations are equal to zero) and for the equality of all roots except the first (equivalent to a test that all the correlations are equal).

For large matrices this module requires a significant computation time and the use of a math coprocessor is strongly recommended. The input matrix is reduced to tridiagonal form using Givens and Householder reductions. Eigenvalue and eigenvectors are then computed from resulting matrix using a QL algorithm with implicit shifts as described by Press et al. (1989).

Output:

All of the eigenvalues, their percentages, and their cumulative percentages are listed. However just the requested number, k, of eigenvectors and eigenvalues are saved in the specified files.

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


EIGEN module parameters

Navigation: Computational modules > Eigenvectors (EIGEN) >

EIGEN module parameters

Batch code | Description
O | Name of the symmetric input matrix.
N | The number, k, of dimensions to be retained in the output matrices (default is 3).
R | Name for the eigenvector matrix.
VAL | Name for the eigenvalue matrix (optional).
S | The code for the desired method of scaling of the lengths of the eigenvectors (see below for a list of codes).
NS | Sample size that the covariance matrix is based upon (needed for tests of significance).
DF | Degrees of freedom of the covariance matrix (needed for tests of significance). This will usually be n–1 but it could be less if this were a pooled within-groups covariance matrix.
SD | Show details of the results in the listing.
CO | Cutoff value for the eigenvalues. Values less than this will be considered zero.

Codes for method of scaling:

LAMBDA | Length = eigenvalue, i
SQRT(LAMBDA) | Length = [image] (default)
1 | Lengths all set to 1
1/SQRT(LAMBDA) | Length =
1/LAMBDA | Length = [image] .


EIGEN technical details

Navigation: Computational modules > Eigenvectors (EIGEN) >

EIGEN technical details

Variance-covariance matrices, S:

The test for equality of the last p-k sample estimates of the eigenvalues, lj, uses the following equation:

where p is the number of variables and υυ is the number of degrees of freedom of the S matrix. The resultant X2 value is to be compared with the upper tail of the X2 distribution with [image] degrees of freedom.

The unbiased estimates, [image] , of the eigenvalues are given (Jackson, 1991 ) by the following equation:

where n is the sample size for the matrix. The variances (squares of the standard errors) of the eigenvalues are given by

The expected proportions of the total variance expected under the broken stick model are given (Jolliffe, 1986 ) by the following equation:

By this test, eigenvectors are retained as long as the proportion of the variance explained by each is larger than the corresponding gk.

Correlation matrices, R:

A test is performed to check whether the eigenvalues differ more than would be expected by chance if all the correlations were equal to zero. The criterion is

This value is to be compared to a χ2-distribution with ν = p(p-1)/2 degrees of freedom (Bartlett, 1950 ). This is a test for the complete independence of all p variables. The value for the natural logarithm of the determinate of the correlation matrix (which is also equal to the sum of the logs of the eigenvalues) is also listed.

A test is also performed to test the hypothesis that all of the roots except the first are equal. This is equivalent to a test of the homogeneity of all of the correlations.

where [image] is an estimate of the common correlation. X2 is to be compared to a χ2-distribution with

degrees of freedom (Bartlett, 1951a,b ).


FACTOR - factor extraction

Navigation: Computational modules > Factor extraction (FACTOR) >

FACTOR - factor extraction

This module provides several methods for factor extraction from a correlation matrix, R. It attempts to find a factor matrix, F, that satisfies the relationship [image], where U2 is a diagonal matrix of uniqueness values. Note that [image], where the diagonal of [image] are the communalities (the proportions of the variance of each variable that can be accounted for by variation in common with the other variables). This is to be contrasted with the model, [image], corresponding to principal components analysis.

The FROTATE module is usually used after this module to attempt to rotate the axes to simple structure as this greatly increases their possibility that the axes can be interpreted.

Multiple factor analysis is a complex and somewhat controversial method. Some recent general texts on factor analysis are Reyment and Joreskog (1996) and Kline (1994). It is also discussed in most general texts on multivariate analysis. See, for example, Johnson and Wichern (2002), Morrision (2005), Timm (2002) and Lattin, Carroll, and Green (2002). Gorsuch (1983)gives a good introduction. Some classic technical texts on factor analysis are Harman (1967), Thurstone (1947), and Mulaik (1972).

Output:

If the "Show details" option is selected then the final factor matrix is displayed along with other information that depends on the method used. The output also includes a listing of the input parameters.

Graphic speed buttons are available to provide 2D and 3D plots of the resultant factors. Note that one will often have to rescale the plots so that the origin is included.


FACTOR - program parameters

Navigation: Computational modules > Factor extraction (FACTOR) >

FACTOR - program parameters

Batch code | Description
O | Name of the input p by p correlation matrix.
N | The number, n, of dimensions to be extracted.
M | The method of factor extraction to be used (see table below). The default is PrincipalFactor.
H2M | The method for the initial estimate of the communalities (see table below). The default is Jöreskog63
IH2 | If the method is file, then enter the name of the file containing the initial estimates of the communalities.
R | The name for the resulting p by k factor matrix.
H2 | The name for the final estimates of the communalities, a p by p diagonal matrix.
N | The sample size on which the input matrix is based. Alternatively, one can specify the degrees of freedom (see below).
DF | The degrees of freedom for the input correlation matrix.
SD | Should the details of the results be displayed? The default is NO.
EPS | The convergence criterion. The default is 0.00001.
MAX | The maximum number of iterations to be used to estimate the communalities. The default is 100.

Codes for factor extraction methods:

PrincipalFactor | Function plane rotation method of Katz and Rohlf (1974). Uses the σ parameter.
MaxLike | Primary product function plane method of Katz and Rohlf (1975). Uses the σ parameter.

Codes for communality estimation methods:

MaxDiag | Use the largest (in absolute value) entry for each variable.
SMC | Use the squared multiple correlation of each variable with all others.

Jöreskog63


FACTOR - technical details

Navigation: Computational modules > Factor extraction (FACTOR) >

FACTOR - technical details

Principal factor analysis

The following steps are performed:

The diagonals of the correlation matrix are replaced by an estimate of the communalities.

The eigenvectors of the modified matrix are computed but just k are retained and scaled to have a length equal to the square roots of their corresponding eigenvalues.

New estimates of the communalities are estimated as the diagonal elements of [image]. These are constrained to be less than or equal to 1.

The current estimates of the communalities are compared to the previous ones. Steps 1 through 3 are repeated until the estimates are sufficiently similar or the maximum number of iterations is exceeded.

Maximum likelihood factor analysis

The following steps are performed:.

The matrix [image] is computed using the current estimates of [image].

The eigenvectors of matrix M are computed but just k are retained and scaled as [image].

New estimates of the communalities are estimated as the diagonal elements of [image]. These are constrained to be less than or equal to 1.

The current estimates of the communalities are compared to the previous ones. Steps 2 and 3 are repeated until the estimates are sufficiently similar or the maximum number of iterations is exceeded.

Heywood case

Both methods of factor extraction sometimes have problems due to the fact that they may converge to a solution in which one or more estimated communalities are greater than 1. The program prevents that by constraining the solutions.

General references: General discussions are given in a number of texts. Gorsuch (1983) gives good explanations, examples, and comparisons among many methods. Other texts on factor analysis are Mulaik (1972) and Harman (1967).. Some standard multivariate texts that include factor analysis are: Johnson and Wichern (2002), Morrision (2005),


Example of a factor analysis

Navigation: Computational modules > Factor extraction (FACTOR) >

Example of a factor analysis

An example of a factor analysis using the well-known Harman (1967) 24 psychological variables data. Only the correlation matrix is available for these data.

First, the factors have to be extracted from the correlation matrix. The principal factoring method was used.

The solution converged rapidly as shown below:

Iteration   Ave.|H²diff|

       5      0.0174963

      10      0.0018270

      15      0.0002466

      20      0.0000336

Iteration terminated at 24 with H²diff =  0.0000

Next, the factors must be rotated so they are more likely to be interpretable. The primary product function plane rotation was used here.

The following results were obtained:

PP functionplane required 5 iterations, lnC =   9.78169.

Rotation matrix - Lambda:

            1         2         3         4

  1   0.35436   0.25505   0.31893   0.19514

  2  -0.75247   0.77388  -0.03392   0.26419

  3   0.55484   0.46033  -0.84541  -0.21524

  4  -0.01904  -0.35235  -0.42710   0.91967

The following matrix is not usually interpreted when an oblique method of factor rotation is used.

Reference structure matrix - V:

            1         2         3         4

  1  -0.01718   0.07761   0.60307   0.00745

  2   0.01214   0.00365   0.40325  -0.01425

  3   0.03765  -0.10632   0.50150   0.00982

  4   0.11151  -0.01153   0.45969  -0.05406

  5   0.62052   0.08490   0.01324  -0.03729

  6   0.65206  -0.07028   0.03242   0.05725

  7   0.72068   0.02093   0.00713  -0.11333

  8   0.43858   0.10207   0.19035  -0.03898

  9   0.70810  -0.09369   0.01274   0.04241

 10   0.03787   0.78451  -0.22860   0.03882

 11   0.01835   0.45991  -0.01280   0.25196

 12  -0.12708   0.66056   0.11481  -0.03003

 13   0.01190   0.45191   0.31776  -0.07667

 14   0.09868   0.00126  -0.03751   0.47582

 15   0.00776  -0.00277   0.04146   0.46661

 16  -0.08239  -0.05217   0.34887   0.42736

 17   0.00714   0.14391  -0.02623   0.49254

 18  -0.14643   0.25341   0.22552   0.35466

 19   0.02350   0.09420   0.16591   0.26043

 20   0.24109  -0.02277   0.30054   0.15025

 21   0.01308   0.32967   0.29970   0.06619

 22   0.22709   0.00742   0.28709   0.14765

 23   0.21069   0.09635   0.39124   0.05516

 24   0.20747   0.38366   0.04084   0.13356

The following counts of absolute values of elements of the factor matrix that are “small” is a useful guide to the quality of the rotated factor solution. Large numbers are better than small. For comparison, the counts for a varimax solution are just 9, 10, 5, and 8.

Counts of number of variables within +/- 0.15

Dim Count

 1   15

 2   17

 3   10

 4   16

The following matrix is not usually interpreted except to show indirectly that the rotated axes are correlated.

Correlations among reference axes - Psi:

            1         2         3         4

  1   1.0000

  2  -0.2298   1.0000

  3  -0.3224  -0.1836   1.0000

  4  -0.2666  -0.1689  -0.1576   1.0000

The rotated factor matrix is given next.

Primary pattern matrix - P:

            1         2         3         4

  1  -0.02117   0.08852   0.71141   0.00855

  2   0.01497   0.00417   0.47568  -0.01635

  3   0.04641  -0.12127   0.59159   0.01127

  4   0.13748  -0.01315   0.54227  -0.06203

  5   0.76501   0.09684   0.01562  -0.04279

  6   0.80390  -0.08016   0.03824   0.06569

  7   0.88849   0.02387   0.00841  -0.13003

  8   0.54070   0.11643   0.22454  -0.04473

  9   0.87298  -0.10687   0.01503   0.04866

 10   0.04669   0.89483  -0.26967   0.04454

 11   0.02262   0.52458  -0.01510   0.28910

 12  -0.15667   0.75344   0.13544  -0.03445

 13   0.01467   0.51545   0.37485  -0.08797

 14   0.12166   0.00143  -0.04425   0.54596

 15   0.00957  -0.00316   0.04891   0.53540

 16  -0.10158  -0.05950   0.41154   0.49036

 17   0.00880   0.16415  -0.03094   0.56515

 18  -0.18052   0.28904   0.26603   0.40695

 19   0.02897   0.10745   0.19571   0.29882

 20   0.29723  -0.02597   0.35453   0.17240

 21   0.01613   0.37603   0.35354   0.07595

 22   0.27997   0.00846   0.33866   0.16941

 23   0.25974   0.10990   0.46153   0.06329

 24   0.25578   0.43760   0.04818   0.15325

The following shows that the rotated axes are somewhat correlated.

Correlations among primary axes - Phi:

            1         2         3         4

  1   1.0000

  2   0.4124   1.0000

  3   0.4765   0.3695   1.0000

  4   0.4329   0.3459   0.3605   1.0000

If the raw data were available then the next step would be to compute factor scores giving measurements of the amount of each factor for each observation.


FROTATE - factor rotation

Navigation: Computational modules > Factor rotation (FROTATE) >

FROTATE - factor rotation

This module provides several methods (both orthogonal and oblique) for rotating a factor matrix to simple structure. This module is normally used after the FACTOR module produces a factor matrix from an input correlation matrix.

Some recent general texts on factor analysis are Reyment and Joreskog (1996) and Kline (1994). It is also discussed in most general texts on multivariate analysis. See, for example, Timm (2002) and Lattin, Carroll, and Green (2002). Gorsuch (1983) gives a good introduction. Some classic technical texts on factor analysis are Harman (1967), Thurstone (1947), and Mulaik (1972). .

Output:

If the "Show details" option is selected then the transformation matrices, rotated factor matrices, and the correlations among the axes (for oblique rotation methods) are displayed. The output also includes a listing of the input parameters.

Graphic speed buttons are available to make it convenient to view plots of the factors.


FROTATE - program parameters

Navigation: Computational modules > Factor rotation (FROTATE) >

FROTATE - program parameters

Batch code | Description
O | Name of the input pxk factor matrix.
D | The direction (Row or Col) to take as dimensions from the initial configuration matrix (default is Col).
M | The method of factor rotation to be used (see table below). The default is HKIC.
S | σ, the hyperplane width parameter for the function plane and primary product function plane methods. The default is 0.15.
POW | The exponent to use for the PROMAX method. The default is 3.
LAM | The name for the output transformation matrix, Lambda, to yield the V matrix.
V | The name for the output reference structure factor matrix, V.
PSI | The name for the matrix of correlations among the reference axes.
PP | The name for the output primary pattern factor matrix, P.
PHI | The name for the output matrix of correlations among the primary axes.
SD | Should the details of the results be displayed? The default is NO.

Codes for methods:

FunctionPlane | Function plane rotation method of Katz and Rohlf (1974). Uses the σ parameter.
PPFunctionPlane | Primary product function plane method of Katz and Rohlf (1975). Uses the σ parameter.
HKIC | Harris and Kaiser (1964) independent cluster oblique rotation method.
Varimax | Varimax orthogonal rotation method of Kaiser (1958).
VarimaxNormalized | Normalized varimax orthogonal rotation method of Kaiser (1958). .
Promax | Promax oblique rotation method of Hendrickson and White (1964). Uses the power parameter.
PromaxNormalized | Normalized Promax oblique rotation method of Hendrickson and White (1964). Uses the power parameter.


FROTATE - technical details

Navigation: Computational modules > Factor rotation (FROTATE) >

FROTATE - technical details

The various rotation methods determine a transformation matrix, Λ, that converts the initial orthogonal input factor matrix, A, into a reference structure matrix, V.

The matrix of correlations among these reference axes is computed as

The primary pattern matrix, P, is computed as

,

where D is a diagonal matrix of the reciprocals of the square roots of the diagonals of [image] and [image].

The correlations among the primary axes are given by

.

Note that for an orthogonal rotation, Λ is an orthogonal matrix and thus V=P.

The correlations and communalities estimated by the factor model can be computed as

.

Notes on rotation methods:

General references: General discussions are given in a number of texts. Gorsuch (1983) gives good explanations, examples, and comparisons among many methods. Other texts on factor analysis are Mulaik (1972) and Harman (1967).. Some standard multivariate texts that include factor analysis are: Johnson and Wichern (2002), Morrision (2005),

Promax-normalized. The implementation of the popular promax method varies quite a bit. The original publication says that the input factor matrix should be normalized by rows and columns before the elements are raised to the specified power (the original signs are preserved). Some programs normalize the columns so that the sum of their squared elements sum to 1 but others scale the values in each column so that the largest elements are equal to 1. Some software seems to normalize the columns and then the rows. Thus the results of different programs may not exactly match. The promax-normalized option first adjusts the rows of the factor matrix to be of length 1 and then scales each column so that the largest element is equal to 1. Originally proposed by Hendrickson and White (1964) The setting of the power parameter is discussed in Tataryn, Wood, and Gorsuch (1999).

Promax. For this method the normalization step described above is skipped. The elements are raised to the specified power but the original signs of each coefficient are preserved.

Varimax-normalized. This is the most popular method for orthogonal factor rotation. It is described in detail in most books on factor analysis.

Varimax. This unnormalized version is provided for completeness even though not usually used.

HKIC. This is a very simple oblique rotation method that often works surprisingly well. If the variables are in distinct equal-sized clusters then equally weighting the unrotated axes will tend to make the factors orthogonal. In this method the unrotated axes are normalized, a varimax rotation applied, and then the axes are rescaled to correct for the initial normalization. See Harris and Kaiser (1964) for more information.

Functionplane. This less well known geometrical method can result in more factors in the solution than were in the original input factor matrix. It is thus able to detect the presence of dependent factors. See Katz and Rohlf (1974) for more information.

Primary product functionplane. This less well known geometrical method usually gives very good results. There are usually more variables in the hyperplanes by this method and the correlations among the primary axes are often less than for other oblique methods. See Katz and Rohlf (1975) for more information.


FSCORES - factor scores

Navigation: Computational modules > Factor scores (FSCORES) >

FSCORES - factor scores

This module computes factor scores – estimates of the factors for each specimen or subject. They are the generalization to factor analysis of the projections of specimens onto principal component axes that is commonly done in a principal components analysis. They can be used as one part of a biplot to show both variation among the observations and relationships among the variables.

Unfortunately, the problem is much more difficult in factor analysis than it is in a PCA. This is due to a fundamental indeterminacy. For a given factor solution there can be more than one set of estimated factor scores that satisfies the factor model. For that reason, several different methods of estimation are provided. See the technical details topic for details about the various methods. Especially useful discussions of this topic are given in Grice (2001)and Jackson (1991). Most general texts on factor analysis also discuss factor scores.

Note that when the correlation matrix is singular (very common in biology when more than just a few variables are used), the regression and Anderson & Rubin methods are undefined.

Output:

The output includes a listing of the input parameters and notations about the matrices produced. If the "Show details" option is selected then additional information is displayed. The factor scores coefficients matrix (this matrix times the standardized data yields the estimated scores). A matrix of correlations between the factors and the factor score estimates. The diagonals of this matrix measures of validity – how well the scores estimate the factors. The off-diagonals measure univocality – how well does each score measure just its corresponding factor. A matrix of correlations among the factor scores is also given. Ideally, this matrix should match the Phi matrix (the matrix of correlations among the primary axes). For some methods, factor scores can be correlated even when the factors are orthogonal.

Graphic speed buttons are available to make it convenient to view plots of the factor scores.


FSCORES - program parameters

Navigation: Computational modules > Factor scores (FSCORES) >

FSCORES - program parameters

Batch code | Description
O | Name of the input data matrix. It need not be standardizes as this module will standardize it if necessary.
D | The direction (Row or Col) to interpret as variables in the data matrix (default is Col).
F | Name of the input p by k rotated factor matrix. For oblique solutions, a primary pattern matrix, P, should be provided.
PHI | Name of the input k by k matrix, Φ, of correlations among the primary axes. Needed only for oblique rotated factors.
M | The method to be used to compute factor scores. See the table below. The default is Regression.
SV | The cutoff value used by the multiple group method to select which variables have large enough loadings. The default is 0.6. If a value of 0 is given then the actual loadings will be used.
R | The name for the output n by k matrix of factor scores.
SD | Should the details of the results be displayed? The default is NO.

Codes for methods:

AndersonRubin | Function plane rotation method of Katz and Rohlf (1974). Uses the σ parameter.
Bartlett | Primary product function plane method of Katz and Rohlf (1975). Uses the σ parameter.
LeastSquares | Harris and Kaiser (1964) independent cluster oblique rotation method.
Regression | Varimax orthogonal rotation method of Kaiser (1958).
MultiGroup | Multiple group method (only variables with highest loadings are used).
Thompson | Normalized varimax orthogonal rotation method of Kaiser (1958). .


FSCORES - technical details

Navigation: Computational modules > Factor scores (FSCORES) >

FSCORES - technical details

Methods provided by this module are described below. They differ in how the matrix, W, of factor score coefficients are computed. The scores themselves are computed as [image], where Y is the standardized n by p data matrix, W is the p by k matrix of factor score coefficients, and Z is the n by k matrix of estimated factor scores. Note: for convenience, this module automatically standardizes the data.

The computations are based mostly on the accounts given in Grice (2001) and Jackson (1991).

AndersonRubin

, where U-2 is the p by p matrix of reciprocals of 1-h2 values for each variable and P is the p by k factor matrix. This is the same as the Bartlett estimate but with the additional restriction that the estimated scores are orthogonal, which unfortunately also makes them biased.

This method has been generalized by McDonald (1981) and by ten Berge, Krijnen, Wansbeek, and Shapiro (1999) for oblique factor solutions. , where [image] and [image]. This method ensures that the factor scores have the same correlations as the primary axes.

Bartlett

, where U-2 is the p by p matrix of reciprocals of 1-h2 values for each variable and P is the p by k factor matrix. This is a weighted form of the least-squares estimate. It minimizes the sum of squares for the unique factors.

LeastSquares

, where P is the p by k factor matrix. Jackson (1991) says that this method has been the most popular over the years. For an orthogonal factor matrix this method corresponds to a simple projection of the observations onto the factor axes.

MultiGroup

This is the simplest method. In the multiple group method the elements of the W matrix are set equal to zero unless a variable is considered salient for a factor. A variable is only allowed to have a nonzero value on just one factor – the one with which it has its highest loadings. If a cutoff > 0 is specified then the elements of W are set at ±1 (depending on the sign of the loading) are used if the absolute value of the loading is equal to or above the threshold. If a cutoff of 0 is specified then each variables actual loadings are used for the factor with which they have their highest loadings. Gorsuch (1983) recommends this method because it produces scores better correlated with the true scores.

Regression

Thurstone (1935) proposed [image], where R is the p by p matrix of correlations among the variables and P is the p by k factor matrix. This method is often impractical in biological applications because the correlation matrix can be close to being singular and thus cannot be inverted.

Thompson

, where U-2 is the p by p matrix of reciprocals of 1-h2 values for each variable and P is the p by k factor matrix. Jackson (1991) points out that this is a ridge estimator that minimizes the mean square error but is biased. The coefficients will be scalar multiples of those produced by Bartlett’s method.


FOURIER - Fourier analysis

Navigation: Computational modules > Fourier analysis (FOURIER) >

FOURIER - Fourier analysis

Computes various types of Fourier transformations from data given in a rectangular data matrix. The rows in the results matrix correspond to the objects and the columns will correspond to the coefficients of the Fourier harmonics. The number of columns in the output will depend upon the number of harmonics specified and the type of Fourier transformation selected. For certain methods the FOURPLOT module can be used to display both the outlines and the fitted outlines.

The use of Fourier analysis is popular for the description of the outlines of morphometric structures in terms of relatively few harmonic coefficients. There are several approaches that have been used.

• Polar functions. This approach can be used when the polar coordinates of points along the outline are single-valued with respect to some central point (either a landmark or a constructed point such as the centroid). Input to the Fourier analysis are the distances from the center to the outline for a series of equally-spaced angles (from 0 to 360 degrees and usually starting at some landmark).
• Tangent angles. An alternative approach that is defined for all outlines is to perform a Fourier analysis of the tangent to the outline as a function of distance along the outline from some starting point. Zahn and Roskies' (1972) suggested the use of the normalized net angular change in direction of a tangent, [image] , to the outline as it is moved around the outline in p equal length steps scaled to range from t = 0 to 2. This is defined as [image] . Lohmann (1983) has suggested the direct use of a singular-value decomposition of matrices of [image] coefficients— and omitting the Fourier analysis step.
• Analysis of ΔΔx and ΔΔy coordinates. Kuhl and Giardina (1982) proposed the use of the very general Elliptic Fourier analysis. This involves the Fourier analysis of the ΔΔx and ΔΔy coordinates as joint functions of distance along the outline. Ferson et al. (1985), Rohlf and Archie (1984), and White and Prentice (1987) are examples of papers where this method was used and compared to alternative techniques. Lestrel (1997) contains many examples. The input data consists of coordinates in the order x1, y1, x2, y2, etc. A 3D generalization is also included in this module. For such analyses the coordinates must be provided in the order x1, y1, z1, x2, y2, z2, etc.
• Analysis of x,y coordinates treated as a series of complex numbers. This approach can also be used to fit complicated outlines. The method is described in Wallace and Wintz (1980).

It should be noted that there is some controversy about the routine application of Fourier analysis for the description of organisms (e.g., Bookstein et al., 1982). The problems are: the implied homology of the ith point in different organisms and whether the harmonics themselves have any biological interpretation. In most cases it is just a descriptive tool—it is just curve fitting using sines and cosines of multiple of angles rather than powers when fitting a polynomial. Rohlf (1990) is a review of alternative methods for fitting curves to outlines of organisms. Haines and Crampton (2000) is a recent review.

Size standardization is optional and is performed by division of the coordinates by some measure of size. Choices are AREA (square root of the enclosed area of an outline), PERIM (the length of the perimeter of an outline), or ELLIP1 (the square root of the area of the ellipse defined by the first harmonic in an elliptic Fourier analysis). A vector of these size measures can also be output.

The orientation of each specimen is also important if several specimens are to be compared. One solution is to include the coordinates of two morphological landmarks (perhaps the starting point and one other convenient landmark). Bookstein's shape coordinates can then be used to translate the first landmark to the origin and to rotate the specimen so that the second landmark is aligned with the x-axis. To preserve the original size of each specimen use the SHAPETU transformation (rather than the SHAPET transformation) in the TRANSF module. The coordinates of those points that are not to be used as part of the outline should be deleted using the TRANSF module.

Another solution to the alignment problem is to use one of the orientation options. For both the EFOUR and the FOUREQ methods one can use the ROTATE option to rotate the outline so that the long axis defined by the first harmonic is parallel to the horizontal axis (the phase angle of the first harmonic is set to zero). For the EFOUR method one can also use the START option to change the initial point to the end of the long axis defined by the first harmonic. The BOTH option results in both ROTATE and START options for the EFOUR method. Note that when there are no landmarks available to allow alignment, many workers have ignored the phase angles of each harmonic and used the amplitudes as variables in subsequent analyses. This is undesirable since too much information is discarded (k parameters rather than just one). The ROTATE option only eliminates one parameter corresponding to the single degree of freedom of uncertainty in how the outline should be rotated.

Output:

The module displays the input parameters and then outputs a table with the Fourier coefficients and their harmonic amplitudes (sum of squared coefficients for each harmonic). The output file contains only the Fourier coefficients (or reconstructed data points in the case of inverse transformations) with each row corresponding to a specimen and the columns to the computed coefficients. For the elliptic Fourier method, coefficients B0 and D0 (and F0 for the 3-dimensional generalization) are identically zero and hence are not included in the output. The length of each outline is also displayed when the elliptic Fourier method is used. If the data are to be standardized, then a table giving the area for each object is displayed in the listing file. A vector of the selected size measures can be saved.

When there are no landmarks, the amplitudes are sometimes used as variables in subsequent multivariate analyses rather than the coefficients (with a considerable loss of information. It is much better to orient the outline in some way (at least use the ROTATE option).

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


FOURIER program parameters

Navigation: Computational modules > Fourier analysis (FOURIER) >

FOURIER program parameters

Batch code | Description
O | The name of the input rectangular matrix. Each row (or column) corresponds to an outline.
D | The direction that corresponds to the outlines – rows (checked) or columns.
N | The highest number of harmonics to be computed (or the number of points for an inverse transformation).
M | Code for the method (see table below).
S | Standardization method (see table below). Default is NONE.
OR | Orientation adjustment (see table below). Default is NONE.
R | Name for the resultant matrix.
SV | A name for the vector of size values (not saved if an inverse method is selected).
SD | Show details of the computation. Default is checked.

Codes for methods:

EFOUR | Elliptic Fourier transformation of x,y-coordinates.
EFOUR3 | Elliptic Fourier transformation of x,y,z-coordinates.
IEFOUR | Inverse Elliptic Fourier transformation to estimate x,y-coordinates.
IEFOUR3 | Inverse Elliptic Fourier transformation to estimate x,y,z-coordinates.
FOUREQ | Fourier transformation of equally-spaced values.
FOURXY | Fourier transformation of x,y-coordinates
IFOURXY | Inverse Fourier transformation to estimate x,y-coordinates

Codes for standardization:

AREA | Divide coordinates by the square root of the area enclosed by the contour (2D outlines only).
ELLIP1 | Divide coordinates by the square root of the area of the ellipse defined by the first harmonic (EFOUR method only).
NONE | No standardization (this is the default).
PERIM | Divide coordinates by the length of the perimeter of the outline contour.

Codes for orientation:

BOTH | Use both ROTATE and START adjustments (EFOUR only).
NONE | No adjustment (this is the default).
ROTATE | Rotate outline so phase angle of first harmonic (FOUREQ) is zero or so the long axis of the ellipse defined by the first harmonic is horizontal (EFOUR method).
START | Adjust outline so that the starting point of the outline is located at the end of the ellipse defined by the first harmonic (EFOUR method)..


FOURIER technical details

Navigation: Computational modules > Fourier analysis (FOURIER) >

FOURIER technical details

For the Fourier analysis of equally-spaced values the coefficients are computed as follows for the kth harmonic: ,

The zeroth harmonics are [image] , [image] .

The amplitude of each harmonic is [image] and the phase angle is [image] for each harmonic. Note: the module does not actually perform as many sine and cosine computations as implied above since it uses recurrence relationships. The Fast Fourier algorithm is not used since the number of points, p, is usually relatively small (less than a thousand). The estimated curve can be computed as follows: for [image] .

For the elliptic Fourier method the following equations are solved for kth harmonic.

,

where p is the number of steps (which need not be equally spaced) along the outline, Δxi is the displacement along the x-axis of the contour between steps i‑1 and i, Δti is the length of the linear segment between these steps, ti is the accumulated length of such segments at step i and T (=tp) is the total length of the contour as approximated by the outline polygon. The constant term, A0, is found as follows (B0 = 0).

The coefficients for the y-projection, Ci and Di, are found in the same way using the y-projections.

The elliptic Fourier transformation can easily be inverted so that one can construct x,y-coordinates from a series of coefficients. ,

where N is the total number of harmonics used, and t ranges from 0 to 2ππ. Since one cannot determine the original spacing from the coefficients, the reconstructed coordinates produced by this module are equally-spaced along the outline. Thus even with a large number of harmonics one cannot expect the reproduced coordinates to be exactly equal to the original ones. This is true even if they were equally-spaced since the reproduced coordinates are equally-spaced along the fitted outline not the observed one.

The 3-dimensional generalization is a simple extension of the procedure described above. The contour length, ti, is based on the 3-dimensional curve and new coefficients Ei and Fi are defined using Δzi.

The direct Fourier analysis of x,y-coordinates is not well-known in morphometrics. In this approach the N x,y coordinates are treated as an array of complex numbers in the format [image]. A Fourier analysis is then performed on this sequence of complex numbers. The Fourier coefficients, , for the kth harmonic are computed as

,

where is an angle in radians.

is the centroid of the outline (as a complex number ). Unlike the usual Fourier analyses, the harmonics are both positive and negative. They range from –N/2 to N/2. Each is a complex number with an x and a y component. In this program we list them in the order 0, 1, -1, 2, -2, 3, -3, …, N/2. The are listed as real numbers with the positive and corresponding negative harmonics grouped together. Thus the 0th harmonic consists of two real numbers (giving the centroid of the outline) and the other harmonics consist of four real numbers that describe the shape of the outline.

The inverse of this transformation,

Allows one to estimate points around an outline corresponding to a given set of Fourier coefficients. In this equation the number of angles, θ, need not correspond to the original number of points around the outline.


FREQ - compute frequencies

Navigation: Computational modules > Frequencies (FREQ) >

FREQ - compute frequencies

This module is used to compute the proportion of the time in which a character state is present. It can be used, for example, to compute allele or genotype frequencies from 0/1 (present/absent) data. Several transformations are provided to transform the proportions into values that are approximately normally distributed. Each variable is treated as a separate proportion unless codes are provided indicating which variables belong to the same group (e.g., which alleles correspond to the same locus). In that case the data are checked to make sure that the sum of the proportions for each group sum to 1.

This module produces a matrix with a row for each population sampled and a column for each variable. This matrix can be used as input to the SIMGEND module to compute various genetic distances. The transformed proportions can be used as input to the SIMINT module which provides other measures of similarity or distance between populations.

Samples from different populations can be given in separate matrices in the same input file or they can be combined in a single matrix if codes are provided (the ID matrix) indicating which population each observation belongs to.

Grewal (1962) defines a mean measure of divergence between populations as the sample size corrected squared average distance coefficient between two populations using the Grewal-Smith transformed frequencies as a data matrix.

Program parameters and batch codes.


FREQ program parameters

Navigation: Computational modules > Frequencies (FREQ) >

FREQ program parameters

Batch code | Description
O | The name of the file containing the input data matrix or matrices. See technical details.
D | The direction that corresponds to the samples – rows (checked) or columns.
ID | The name of the file containing codes indicating the population to which each observation belongs. This information is needed only if all observations are combined in the same input data matrix.
LA | The name of the file containing codes indicating the logical grouping of each variable (e.g., alleles at each locus). This information is needed only if it is desired to have the program check to makes sure that the sum of the proportions adds up to 1 for each locus.
R | The name to be given to the matrix of frequencies. It will have as many columns as there are variables and as many rows as there are population samples.
NA | The name to be given to a matrix containing the diagonal matrix of sample sizes of the populations.
T | The transformation to be applied to the frequencies. See below for the available codes. The default is none.
RT | The name to be given to the transformed matrix of frequencies. It will have as many columns as there are variables and as many rows as there are population samples.

Note that alleles from the same locus must be adjacent and that individuals from the same population must either be in their own matrix or else adjacent in a combined matrix (a combined matrix requires the use of the ID code). See file formats for gene frequency data and Technical details.

Codes for the transformation types:

 | No transformation (in which case no name should be provided for the output transformed frequencies matrix)
ASINSQRT |
ASINSQRT-corr. | but with p replaced by 1/4n if p=0 or 1-1/4n if p=1.
Grewal-Smith |
Grewal/Smith-corr. | but with p replaced by 1/4n if p=0 or 1-1/4n if p=1.
Anscombe | , where f is the observed count and n is the sample size.
Freeman-Tukey | , where f is the observed count and n is the sample size.

Note: all angles are in radians. For binomially distributed proportions the expected variance for the ASINSQRT transformation is . The expected variance for the Grewal-Smith transformation is and the expected variance for the Anscombe and Freeman-Tukey transformations is .

Green and Suchey (1976) discuss the use of these transformation when applied to the frequency of various morphological features when analyzing cranial data. The Grewal-Smith transformation was presented by Grewal (1962).


FREQ - technical details

Navigation: Computational modules > Frequencies (FREQ) >

FREQ - technical details

The input file can be in one of two formats.

1. All of the data are in a single matrix and an ID matrix is provided to indicate which rows represent samples from which populations. In the example below the presence or absence of some trait in 15 samples (5 each from 3 populations).

1 15 5 0

1 0 1 1 0

1 0 0 1 1

1 0 1 1 0

0 1 1 1 0

1 0 0 1 1

1 0 1 1 0

0 1 0 1 0

1 0 1 1 0

1 1 0 1 0

1 0 0 1 0

1 0 1 0 1

0 0 1 0 1

1 0 1 0 1

1 1 0 1 1

1 0 0 0 1

In this case an ID matrix must be provided. An example would be:

1 15 1 0

1

1

1

1

1

2

2

2

2

2

3

3

3

3

3

2. The samples for each population could be stored as separate matrices within the same file. In such a case, the ID matrix should not be provided. An example is:

1 5 5 0

1 0 1 1 0

1 0 0 1 1

1 0 1 1 0

0 1 1 1 0

1 0 0 1 1

1 5 5 0

1 0 1 1 0

0 1 0 1 0

1 0 1 1 0

1 1 0 1 0

1 0 0 1 0

1 5 5 0

1 0 1 0 1

0 0 1 0 1

1 0 1 0 1

1 1 0 1 1

1 0 0 0 1


Heat map Display (HEATMAP)

Navigation: Computational modules >

Heat map Display (HEATMAP)

Enter topic text here.


Heat map Display

Navigation: Computational modules > Heat map Display (HEATMAP) >

Heat map Display

This module will display the elements of a rectangular or symmetric matrix using color codes for each element. This allows one to quickly appreciate the overall pattern (if any) in a matrix. Studying the numerical values can be vary tedious for large matrices.

Note: by default a maximum of 30 rows will be displayed. The other rows can be viewed by pressing the "Page down" key or by right-clicking on the plot and setting the page number to be displayed. In addition, one can also increase the number of rows to be displayed on each page. That can also be done by pressing the "+" key repeatedly.

Output

The figure below shows a sample display for a small (16 by 4) matrix. A standardized data matrix was used so that blue values are below the means for each column and red values are above their means.

Program parameters and batch codes.


Heat map Display program parameters

Navigation: Computational modules > Heat map Display (HEATMAP) >

Heat map Display program parameters

Batch code | Description
O | Name of a file containing a rectangular or a symmetric (similarity or dissimilarity) matrix.
MIN | Lowest class limit for the elements in the matrix.
MAX | Upper class limit.
INT | Class interval.
CS | Color scale (see below).

The MIN, MAX, and INT parameters qare used to create a gradient of colors corresponding to the lowest to the largest values in the matrix. If MIN = MAX or if INT = 0 then the observed range of values is divided into 10 classes.

Codes for Color scales:

BLACK2RED | Gradient from black to red.
BLUE2RED | Gradient from blue to red.
WHITE2BLACK | Gradient from white to black.


KGROUPS - clustering methods introduction

KGROUPS - clustering at a single level

Navigation: Computational modules > k-Groups clustering methods (KGROUPS) >

KGROUPS - clustering at a single level

This module performs an analysis in which the OTUs are clustered at a single level (rather than a hierarchical clustering such as done by the SAHN module). At present, only a single method is provided - the k-means method. The k-means method has been described as the single most commonly used clustering method. For this method the n OTUs are grouped into k sets such that the sum of the within-groups sum of squared distances is minimal. This is a difficult computational problem as the only exact solution consists of evaluating the criterion for all possible partitionings of the OTUs into k disjoint and non-empty subsets. The problem is that the number of partitionings becomes very large as n increases. For example, with k = 4 and n = 25 there are more than 1013 partitionings (Steinley, 2006). Thus heuristic methods need to be used in most practical applications. A good historical overview of the k-means method is given by Steinley (2006).

Starting from an initial partition of the OTUs, the algorithm of Hartigan and Wong (1979) is used to interchange OTUs from different subsets until a minimum (possibly local) sum of within-group sum of squared distances is achieved. If the initial cluster memberships and cluster centroids matrices are not provided then a random partition is used initially.

Output:

The within-groups sum of squares and the Calinski and Harabasz (1974) statistic are displayed. If the Show Details option is selected then the membership of each cluster and their sum of squared distances are also displayed.

program parameters.


KFROUPS - clustering program parameters

Navigation: Computational modules > k-Groups clustering methods (KGROUPS) >

KFROUPS - clustering program parameters

KGROUPS program parameters

Batch code | Description
O | Name of a file containing a rectangular data matrix.
D | Direction (rows or columns) corresponding to the OTUs to be clustered.
K | Number of clusters.
ICM | Initial cluster membership matrix (optional).
ICC | Initial cluster centroids (optional).
CM | final cluster membership matrix (optional).
CC | final cluster centroids (optional).
CT | Cluster memberships as a tree matrix (optional).
SD | Should a detail listing of the results be displayed?

The cluster membership matrices ( both the initial and final) are rectangular matrices with n rows corresponding to the OTUs and a single column. The values within the matrix are the number of the cluster to which each OTU belongs.

The cluster centroids matrices have k rows (corresponding to the clusters) and as many columns as there were variables in the input data matrix.

The tree matrix output uses the same format as the output from the SAHN module. The OTUs within the same cluster are shown at level 1 and the clusters join at a level 2.


Technical details

Navigation: Computational modules > k-Groups clustering methods (KGROUPS) >

Technical details

The optimization algorithm used is that described by Hartigan and Wong (1979).

OTUs are allocated to the clusters to which they are closest. The overall objective is to assign OTUs to clusters such that the sum of the within-cluster sum of squares (or some of squared distances) of all OTUs to their cluster centroids is minimal. The criterion can be written as

,

where the summation is over the k clusters, p variables, and the inner summation is over the members of the lth cluster.

Because of the problem of multiple local minima being usually present, Steinley (2003) recommends trying many random initial assignments of the OTUs to the subsets and then selecting be best of the resulting partitions.

Deciding on the proper number of clusters, k, can be difficult for some datasets. because of the sensitivity of the method to outliers, it may be useful to use a fairly large value of k initially. if clusters are found with only a single point then they may correspond to outliers that should be removed from the dataset. A number of criteria have been proposed. Milligan and Cooper (1985) recommended the use of the Calinski and Harabasz (1974) statistic to determine the optimal value for k. The criterion is

,

where B and W are the among and within groups sums of squares matrices ( [image] ). The value of k is sought that maximizes this criterion.

The number of possible partitions of n objects into k disjoint and non-empty subsets is:

(see Weisstein, 2003).

This can be approximated by [image] (Kaufman and Rouseeuw, 1990).


MST - minimum spanning tree

Navigation: Computational modules > Minimum spanning trees (MST) >

MST - minimum spanning tree

Computes a minimum-length spanning tree, MST, from an input similarity or dissimilarity matrix. It is useful for superimposition on ordinations (principal components or principal coordinates plots) to help detect local distortions— pairs of points which look close together in a plot but actually are far apart if other dimensions are taken into account.

Rohlf (1970) shows an example of a MST superimposed on a stereo view of 3-dimensional PCA and MDSCALE ordinations. Gower and Ross (1969) and Rohlf (1973) discuss the relationship between minimum-length spanning trees and single-link cluster analyses. Rohlf (1975b) shows how a MST can be helpful in locating multivariate outliers.

Output:

The output of the module is in the form of a "graph matrix" (simply a list of the edges in the graph and their lengths). If there are t objects, then there will be t ‑ 1 edges in the graph. As an arbitrary convention, the graph matrix is coded as having t rows (OTUs corresponding to vertices) and t - 1 columns (edges). This convention allows the possibility of more general graphs such as those produced by the NJOIN module.

Program parameters and batch codes.


MST program parameters

Navigation: Computational modules > Minimum spanning trees (MST) >

MST program parameters

Batch code | Description
O | Name of a file containing a similarity or dissimilarity matrix.
R | Name to be given to the resultant graph matrix containing the list of edges in a MST.
SD | Show details of the results in the listing file.


MDSCALE -- Multidimensional scaling

Navigation: Computational modules > Multidimensional scaling analysis (MDSCALE) >

MDSCALE -- Multidimensional scaling

This module performs nonmetric multidimensional scaling analysis, nonmetric-MDS (Kruskal, 1964a, 1964b ). This is an ordination technique (like principal coordinates analysis, PCA, or correspondence analysis, CA) for representing the dissimilarity among n objects or variables by n points in a k-dimensional space so that the interpoint distances in the k-dimensional space correspond as well as possible to the observed distances between the objects.

Nonmetric-MDS differs from principal components analysis in that (instead of requiring that the projection of the points into the k-dimensional space explain a maximum percentage of the variation found) it only requires that the distances in the k-dimensional space have a monotone relationship to the original distances. Similar objects should be shown as close together and dissimilar objects should be placed far apart. Linear-MDS is also included in this program. With this method the program attempts to achieve a linear (through the origin) relationship between the distances in the configuration space and the original distances. In practice the results of MDS and PCA are rather similar. MDS has the desirable property that the smaller interpoint distances tend to be preserved more faithfully in MDS than in PCA. This is because a method that maximizes variances gives greater weight to the larger distances.

This method can be used with a wide variety of similarity and dissimilarity coefficients. Zegura et al. (2004) is an example using SNP and microsatellite haplotype data.

MDSCALE starts with an initial configuration for the points (either a random configuration of points or one furnished by the user, usually from a principal coordinates analysis). From this initial configuration, distances, [image] , between all pairs, ij, of points are computed and compared to the original distances, dij. A monotone function, [image] , is fitted to these two variables and the deviations of the points from this monotone function are computed as a normalized sums of squared deviations from the monotone relation. A statistic, called Stress, measures the goodness of fit (actually the badness of fit) of the distances in the configuration space to the monotone function of the original distances. There are several alternative measures that are used, two of them are implemented in this module. They are computed as [image] , [image] ,

where the sums are over all i,j but with i < j. Both coefficients range from 0 to 1. If stress is not sufficiently small then the positions of the points in this configuration space are changed slightly so as to reduce stress, stress is recomputed, and this process repeated until either the maximum number of iterations specified is exceeded or a sufficiently good fit is obtained. If stress becomes small enough, it turns out in practice that zero stress is always achievable. However it may take many iterations of almost infinitesimal movement to achieve it.

How many dimensions should be used? There are no firm rules. In practice, two or three dimensions are used simply because one can plot the results in two or three dimensions. Usually one fits the points into various numbers of dimensions and observes how stress decreases as dimensionality increases and hopes that a point of diminishing returns will be reached quickly (note: for efficiency one can use the final configuration matrix from fitting in 2 dimensions as the initial matrix for fitting into 3 dimensions, etc.). A number of workers, e.g., Klahr (1969), Spence and Ogilvie (1973) and Spence (1972), give guidelines for the range of stress values one would expect from random data.

Output:

The input parameters are listed. If the details of the iterations is requested then a series of statistics are output for each iteration so that one may observe the approach to the minimum stress. The columns contain the iteration number, the current value for stress, the stress ratio between succeeding iterations, an average of the stress ratio for the previous 5 iterations, the scale factor for the gradient, and the step size. For some iterations more than one line will be displayed. The additional lines will not have all the parameters printed. This will occur when a stress value increases rather than decreases so that it is necessary to "back up" along the gradient and reduce the size of the step since it appears that the procedure has gone past a minimum.

Whether or not a minimum or a satisfactory small stress is reached, computation will be terminated after some number of iterations (at least five are required). Whenever computation is terminated the reason is always indicated by remarks such as:

• "minimum was achieved",
• "maximum number of iterations were used",
• "satisfactory stress was achieved", or
• "zero stress was reached".

Kruskal suggests the following verbal evaluations for various levels of stress:

Stress | Goodness of fit
0.40 | Poor
0.20 | Fair
0.10 | Good
0.05 | Excellent
0.00 | "Perfect"

A plot of the distances among the points in the configuration space versus the original similarity or dissimilarity can be obtained using the MXCOMP module. On certain highly clustered datasets nonmetric-MDS can give a degenerate solution with a stress close to zero. This can best be detected by examining such a plot.

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


MDSCALE program parameters

Navigation: Computational modules > Multidimensional scaling analysis (MDSCALE) >

MDSCALE program parameters

Batch code | Description
O | Name of the input similarity or dissimilarity matrix to be operated upon. Note: the maximum size is 512x512.
N | The number of dimensions for the configuration space (default is 2 and the maximum is 10).
I | Name of the initial configuration matrix (optional but recommended). The number of dimensions need not be the same as the number of dimensions requested for the final configuration matrix.
D | The direction (Row or Col) to take as dimensions from the initial configuration matrix (default is Col). The final configuration will be given the same orientation.
R | Name to be given to the final configuration matrix produced by this module. Its orientation will match the initial configuration matrix.
SC | The type of stress coefficient to use, STRESS2 (default) or STRESS1.
RT | The type of regression to use, MONO (default) or LINEAR.
MI | The maximum number of iterations that are to be used (default is 40).
SD | Should the details of the iterations be shown? Default is NO.
MS | Desired minimum value for Stress. Iterations will stop if stress falls below this value (default is 0.001).
MR | The maximum ratio of Stresses in succeeding iterations. If both the stress ratio and the weighted average stress ratio are between this value and 1.0 then a minimum (perhaps only local) will have been achieved and iterations will stop (default is 0.999).
MG | When the scale factor for the gradient is less than or equal to this criterion the iterations are stopped (default is 0.0— which places primary reliance on the stress ratio and minimum stress criteria).
DH | Name for a symmetric matrix of estimated dissimilarity values, [image] , estimated by either monotone or linear regression (optional).
DC | Name for a symmetric matrix of distance values computed between all pairs of points in the final configuration space.


MDSCALE technical details

Navigation: Computational modules > Multidimensional scaling analysis (MDSCALE) >

MDSCALE technical details

This module does a considerable amount of computation (much more than the EIGEN module for the same size matrix). It also requires a large amount of storage for intermediate results and hence cannot process large matrices. The module is limited to 255 points.

Since it is possible for the module to have problems with multiple local minima, one usually uses the results from a principal coordinates analysis or a principal components analysis as an initial configuration matrix. This assures that the result will not be worse than that of a PCA analysis. Usually this is not a problem. In such cases the use of a PCA configuration just reduces the number of iterations needed.

If more than 2 dimensions are to be used then one will probably wish to perform a principal components analysis on the final configuration matrix so that the major trends of variation in the configuration space are lined-up with the coordinate axes. This can be done as follows (assuming a final configuration matrix F):

MDSCALE O=d N=3 R=f

SIMINT O=f C=VARCOV R=vcv

EIGEN O=vcv N=3 R=vec

PROJ O=f D=r F=vec P=newf

The matrix NEWF is the final rotated result which can be plotted using either the MXPLOT or the MOD3D modules with normalization set to NO.


Nonmetric multidimensional scaling

Navigation: Computational modules > Multidimensional scaling analysis (MDSCALE) >

Nonmetric multidimensional scaling

This method is similar to PCOORDA in that it can be used to represent the relationships among a set of points in a low dimensional space. The difference is that in non-metric multidimensional scaling analysis the distances among the points in the final configuration need only have a monotone relationship to the distances implied by the original data matrix. This usually makes it possible to get a much better fit in fewer dimensions than is possible in PCOORDA.

If possible, one begins with the results of a PCOORDA as an initial configuration since this usually results in many fewer iterations being necessary. The orientation of the axes in the final configuration is arbitrary. For that reason it is desirable to perform a PCA on the result so as to rotate it so the axes align with the major axes of variation.

" Use PCOORDA to obtain an initial configuration

*DCENTER O=dist.nts R=distCentered.nts

*EIGEN O=distCentered.nts N=2 R=init.nts

" non-metric MDSCALE using initial solution

*MDSCALE O=dist.nts N=2 I=init.nts R=final.nts

" rotate result for ease in viewing

*SIMINT O=final.nts C=varcov R=vcv.nts

*EIGEN O=vcv.nts N=2 R=vect.nts

*PROJ O=final.nts D=row F=vect.nts R=FinalRotated.nts

" plot the final rotated configuration

*MXPLOT O=FinalRotated.nts

Note: the plot options should be used to force the plot to have the proper aspect ratio. If this is not done then you will obtain a distorted impression of the relationships among the points.


MULREGR - multivariate multiple regression

Navigation: Computational modules > Multivariate multiple regression (MULREG) >

MULREGR - multivariate multiple regression

This module performs several types of regression analyses. The full model it can fit is

Y = XB + ε,

where the matrix Y has n rows (corresponding to observations) and p columns of dependent variables, matrix X has n rows and q columns of independent variables, B is a q by p matrix of regression coefficients, and ε is an n by p matrix of residuals that are assumed to be normally distributed with a covariance matrix of Σ for the n observations. The regression can include an intercept or be forced to go through the origin.

If we assume that the observations are independent and with the same variance, then the following are the common special cases are

• The usual linear regression of Y on X. In this case the X and Y matrices contain only a single variable. Note: these two variables can be stored in the same input file.

• Multiple regression of a single dependent variable onto several independent variables. Optionally, the regression plane can be forced to go through the origin (an uncentered multiple regression).
• Multivariate regression of several dependent variables onto an independent variable.
• Multivariate multiple regression in which several dependent variables are regressed simultaneously onto more than one independent variables.

Additionally, each of the above analyses can be performed as a generalized least-squares, GLS, analysis with a matrix giving the covariance matrix for the observations. This is done to take into account an expected lack of independence of observations as well heterogeneous variances. This method is useful, for example, for the phylogenetic generalized least-squares (PGLS) approach used to study covariation across phylogenetically related species (called the “comparative method). In this case the covariance matrix can be produced by the COPH module. Note: when using the program for the comparative method one does not normally use regression through the origin as is done when using the phylogenetically independent contrasts method. The GLS approach is also useful when working with spatially autocorrelated data. See the Technical details topic and Rohlf (2001) for more information. See also Rohlf (2006) for a discussion of how to interpret what the analysis does.

The PROJ module can be used to estimate Y for new values of the independent variables. It is difficult to adequately display the results of a multivariate multiple regression when there are more than just a few variables involved. One should at least examine the matrix of residuals to check for outliers and for systematic deviations from regression. A PCA of the residual error matrix may be helpful (ideally, it should show no structure (clusters or trends).

Output:

The input parameters are listed as well as squared multiple correlation coefficients and their tests of significance. Multivariate tests are given is there is more than one Y variable. If the “show details” option is specified then more detail is given (means, standard deviations of Y and X, partial regression coefficients and their standard errors and tests of significance for each Y variable separately. The variance inflation factors are also shown to warn of potential problems caused by independent variables that are too highly correlated. There is more than one way in which one could express the degree of fit for a GLS model. See the Technical details topic for information on the approach used in this software.

Program parameters and batch code.

Technical details.


MULREGR - program parameters

Navigation: Computational modules > Multivariate multiple regression (MULREG) >

MULREGR - program parameters

Batch code | Description
OY | Name of a file containing a matrix of dependent variables.
DY | The direction that corresponds to the variables – rows (checked) or columns. Default is columns.
VY | List of the dependent variables to be used. If blank they all will be used.
OX | Name of a file containing a matrix of independent variables. If left blank then the matrix containing the dependent variables will also be used as a source of the independent variables (in which case lists of which variables are to be used must be provided). Note: this matrix does not need to contain the constant vector of all ones because there is an option below to indicate whether or not the regression should be centered (go through the mean) or go through the origin.
DX | The direction that corresponds to the variables – rows (checked) or columns (unchecked). Default is columns.
V | Name of a file containing a matrix of covariances among the observations. This optional parameter is needed only when performing a generalized least-squares regression analysis.
SV | Should the covariance matrix be rescaled so that its trace is equal to the number of samples? The default is yes (checked).
SD | Should more detail be provided in the output listing? The default is no (unchecked).
C | Should the regression be centered? If unchecked the regression line or plane will be forced through the origin. The default is yes (checked).
B | Name to be given to the resultant matrix of partial regression coefficients. The matrix will have q rows and p columns.
YHAT | Name to be given to the resultant matrix of estimated values of Y. The matrix will have n rows and p columns.
R | Name to be given to the resultant matrix of residuals from the regression. The matrix will have n rows and p columns.
YBAR | Name to be given to the resultant matrix of means for the dependent variables. If a covariance matrix is provided above then this will be a generalized least-squares estimates of the means. Otherwise these will be the usual unweighted averages.
TOL | A value used to handle problems with singular X matrices. Singular values less than this quantity will be ignored. The default is zero. A value such as 0.00000001 (1.0E-8) could be used to ignore singular dimensions in the matrix of independent variables. This value is also used in the permutation tests to decide if a value is equal to or more extreme than an observed value.
CO | A value used to handle problems with singular Y matrices. Singular values less than this quantity will be ignored. The default is zero. A small value (depends on the units of the Y variables) could be used to ignore singular dimensions in the matrix of dependent variables.
NP | If > 0 then a permutation test will be performed using this many random permutations in addition to the observed data.


MULREGR - technical details

Navigation: Computational modules > Multivariate multiple regression (MULREG) >

MULREGR - technical details

In order to minimize potential problems with matrices that are singular or nearly singular, the SVDFIT procedure of Press et al. (1989) is used. The X matrix is decomposed into the product X = USVt using the singular value decomposition. The regression coefficients are then computed as , where Ui and Vi are the ith columns of U and V respectively, and si is the ith singular value (the ith diagonal element of the S matrix).

Generalized least-squares. If a covariance matrix for observations is provided then it will be used to weight the observations to yield a generalized least-squares solution. Descriptions of this technique are less common than accounts of the usual ordinary least-squares, OLS, approach. See chapter 4 of Rao and Toutenburg (1999) for a general account.

The Aitken estimate of the regression coefficients for the GLS model can be computed as , where W is the given nxn covariance matrix among the observations. The error (residual) variance is estimated as , where q is the number of independent variables. The covariance matrix for the regression coefficients is then .

A useful trick is to transform the data so that methods similar to those of OLS can be used. Define and then let and . One can then perform an ordinary least-squares regression analysis on these transformed data.

It is natural to consider measuring fit by the sum of squared values. This is not satisfactory because they can be larger than which would imply a negative R2 value. For that reason, this program expresses the R2 values in terms of values.

If the “Show details” box is checked then the dependent and independent variables are listed with their means and standard deviations are given in terms of the raw input data, the data weighted by the inverse of the among-observation covariance matrix, and for data that have been transformed so that the observations are expected to be independent and with homogeneous variances. In addition, the sums of squares (for a centered regression) or the sum of squared observations (for regression through the origin) are given for the dependent variables. This latter information is useful to compare with the residual sum of squares after fitting the regression. For example:

Raw data:

Y Variables Mean Std.Dev. SS

Var_1 4.40465 0.31929 5.40299

X Variables Mean Std.Dev.

Temp 0.00000 0.01296

GLS:

Y Variables Mean Std.Dev. SS

Var_1 4.14924 0.12553 0.83518

X Variables Mean Std.Dev.

Temp -0.00923 0.00829

Transformed data:

Y Variables Mean Std.Dev. SS

Var_1 0.48969 0.51899 14.27583

X Variables Mean Std.Dev.

Temp -0.00036 0.00844

This information is followed by a listing of the y-intercept and the regression coefficients (with their standard errors and significance tests). That is followed by variance inflation factor, VIF, for each independent variable. A VIF value of 1 would be “perfect” (this will happen only if the independent variables are orthogonal. Large values, above 20 or so, indicate that there may be problems due to high correlations among at least some of the independent variables. A value over 100 indicates that there may be very serious problems and the regression coefficients are probably seriously “inflated” (i.e., they are probably much too large).

Finally, whether of not the “show details” box is checked, a summary is printed giving the residual sum of squares, squared multiple correlation coefficient, R2, and its test of significance. When, as in the example, below, there is only a single independent variables this test must agree with the test for the single regression coefficient.

Partial regression coefficients:

Y variable Var_1:

Intercept 4.1481

X variables b SE ts df Prob

Temp -0.1250 2.0993 -0.0595 52 0.95276

Variance inflation factors:

Temp 1.036

Summary results for each Y variable:

Variable SSresid R2 Fs df1 df2 Prob

Var_1 0.83513 0.0001 0.0035 1 52 0.95276

If permutation tests are selected then the order of the observations are scrambled and the number of times that such sample result in more extreme regression coefficients or squared multiple correlation coefficients are counted and expressed as a proportion.


NJOIN - Neighbor-joining method

Navigation: Computational modules > Neighbor joining clustering (NJOIN) >

NJOIN - Neighbor-joining method

The neighbor‑joining (NJ) method was developed by Saitou and Nei (1987) as a method for estimating phylogenetic trees. While the method is based on the idea of parsimony (it does yield relatively short estimated evolutionary trees), the NJ method does not attempt to obtain the shortest possible tree for a set of data. Rather, it attempts to find a tree that is usually close to the true phylogenetic tree. Work by Kim, Rohlf, and Sokal (1992) using simulated datasets has found the NJ method to yield more accurate trees than either UPGMA or parsimony in most of the models they investigated. The unweighted version of the neighbor-joining method by Gascuel (1997) is also included. It is unweighted in the same sense that the UPGMA clustering method is unweighted. Atteson (1997) gives useful insights on why the neighbor-joining method seems to perform so well.

The algorithm used to find NJ trees is similar to that of the distance Wagner procedure (Farris, 1972 ). As in agglomerative clustering (Sneath and Sokal 1973), the algorithm starts with a matrix of distances among the t OTUs and a completely unresolved phylogenetic tree). The closest pair of OTUs is found, merged into a new HTU (hypothetical taxonomic unit) and the original pair of OTUs is deleted until the matrix is reduced to a single HTU and the tree is fully resolved. The "closest pair" of OTUs is defined here as the pair of OTUs (or HTUs from some previous step) where their merging would result in the maximum reduction in length of the graphs. The distance between the new node (from a merging of OTUs i and j) and an existing node k is taken as the simple average of the distances dik and djk. This is a weighted average in terms of the original distance matrix since it does not take into account the fact that OTUs (HTUs) i and j may represent more than one original OTU. In the NJ method trees are constructed by linking together the two OTUs or HTUs that are the closest mutual "neighbors". The distance Wagner algorithm (Farris, 1972 ) differs in the way "closest" is defined and in the way the distance between a new node and the existing nodes is computed.

Algorithms for the computation of the neighbor-joining method are discussed in Studier and Keppler (1988) and Swofford and Olsen (1990).

At each step, several equally close neighbors may exist. As in the SAHN module an option can be set such that the module will compute all possible tied trees.

While the NJ algorithm is fast compared to an exhaustive search for a most parsimonious tree (Steiner tree problem), it requires a considerable amount of computation. For large number of OTUs, t, the computational effort increases in proportion to t3. If there are many ties then a large amount of storage for intermediate results will also be required.

There are many examples of the use of this method. A genetic example is Whitehead, A. and D. L. Crawford. (2006)

The NJ method produces just an unrooted graph. Two alternative methods are provided by the program for rooting the graph to form a tree:

MIDPOINT The path lengths between all pairs of OTUs are computed. The root is then placed at the midpoint of the branch path between the two OTUs that are furthest apart. Therefore, midpoint rooting is most appropriate when the group of organisms can be assumed to have diverged at equal evolutionary rates from a common ancestor.

OUTGROUP For this method the user must designate an OTU as being the outgroup taxon to the remaining OTUs. With this option, the program places the root at the midpoint of the branch that joins the outgroup OTU to the remaining OTUs.

The NJ algorithm estimates the length of each branch (edge) of the graph. This results in a tree that may not have equal branch length (i.e., the path length [patristic distances] may not be ultrametric). The estimation is equivalent to a least-squares fit for completely additive trees (Saitou and Nei, 1987). The program calculates the 2t-3 branch lengths and outputs the result as a graph matrix. The graph matrix contains 3 columns and 2t-3 rows, where the first and second column indicates the OTU or HTU ID codes for the two ends of a given branch and the third column gives the length of each branch. The HTUs are arbitrarily assigned negative numbers as their ID codes. The topology of the rooted NJ tree is also output as a separate tree matrix. Note: it is possible for the estimated branch lengths to be negative. These can be treated as zero length branches.

Output:

The output consists of a listing of the input parameters and an optional display of the resulting tree.

Graphic speed buttons are available.

Program parameters and batch codes.


NJOIN program parameters

Navigation: Computational modules > Neighbor joining clustering (NJOIN) >

NJOIN program parameters

Batch code | Description
O | Name of a file containing a dissimilarity matrix. The maximum number of OTUs is 500 (but the effective limit will be less if there are many ties. In order to use a similarity matrix it must be transformed to a dissimilarity matrix (e.g., use the transf module with the transformation mul(-1)+add(1)).
R1 | Name to be given to the resultant tree matrix.
R2 | Name to be given to the resultant graph matrix.
AN | Should negative branch lengths be allowed? The default is unchecked (No).
M | Method: unweighted or unweighted. The default is weighted.
TM | Code for the method to be used to treat any ties that are found. The default is to just WARN the user. The program can also FIND all alternative trees.
NT | The maximum number of alternative trees to be output in the case of the FIND option (default is 25).
TOL | Two distances that differ by less than this amount are considered to be tied. The default is .
RM | Root the tree by midpoint rooting (MIDPOINT) or outgroup rooting (OUTGROUP).
OTU | The ID number of the outgroup OTU when the OUTGROUP option is selected.

Codes for methods:

UNWEIGHTED | Unweighted method of Gascuel (1997)
WEIGHTED | Weighted method (default).

Codes for method for treating ties:

WARN | Just warn if ties are found (default).
FIND | Find all trees that could result from different choices of tied similarity or dissimilarity values.

Codes for rooting method:

DEFAULT | The root of the tree is determined by the order of joining branches in the algorithm to produce the tree which is really unrooted.
MIDPOINT | Display tree as rooted at midpoint of the longest path through the tree.
OUTGROUP | Display tree as rooted at midpoint of branch connecting the specified outgroup OTU to the rest of the tree..

The FIND option for treating ties is especially important when an association coefficient (such as the simple matching coefficient) is used based on a small number of characters. In such cases there may be many alternative trees— implying that the data do not suggest a unique set of clusters. In such cases it is probably best to report just the strict or the majority-rule consensus tree for the set of alternative trees.


Plot - technical details

Navigation: Computational modules > Plot (PLOT) >

Plot - technical details

Plot symbols file. As in the corresponding files for the mxplot and mod3d modules, this file containing integer codes to group points is simply a rectangular data matrix with as many rows as there are points in the data matrix but just a single column. Such files are produced by the COMBINE module. The following is an example for a data file with 6 points:

“ example symbol ID code file

1 6 1 0

1

1

2

1

3

3

In this example, points 1, 2, and 4 will be given the same plotting symbol, 3 will be uniquely identified, and 5 and 6 will be given the same symbol. Points with the same code can be connected by a line segment.

To control the symbols to be used (including their size and color), select the plot options dialog from the Options menu or else right click on the plot itself.


POOLVC -- Pool covariance matrices

Navigation: Computational modules > Pool covariance matrices (POOLVC) >

POOLVC -- Pool covariance matrices

This program either reads a file containing two or more data matrices or a file containing two or more variance-covariance matrices. If raw data are input then the data for the different groups must each be in their own data matrix but all placed in a single file. The program will then compute a matrix of group means. If covariance matrices are input (again, each in a separate matrix but all stored in the same file) then sample sizes must also be provided (this can consist of a single rectangular matrix with one row and as many columns are there are groups).

Note: if covariance matrices are input then they should be provided using as many significant figures as possible because rounding errors can strongly affect the computation of determinants.

The main purpose of the module is to compute the pooled within-groups covariance matrix and to test for homogeneity of covariance matrices.

The output of this module can be used as input to the canonical variates analysis, CVA, module. See the example in the applications section. While this module permits data with missing values, the resultant pooled covariance matrix may not be compatible with the CVA module (because it may have negative eigenvalues).

Note: this module can test for the homogeneity of the variance-covariance matrices only if there are no missing values. Note also that at present this module cannot easily be used for bootstrapping or other resampling methods.

Output:

The input parameters and information about the input matrices are displayed in the output listing. If a test for homogeneity is requested then the determinant (generalized variance) of each of the covariance matrices is displayed along with the product of the variances for each variable. The ratio of these two quantities measures the degree of intercorrelation among all of the variables.

Program parameters and batch codes.

Technical computational details.


POOLVC program parameters

Navigation: Computational modules > Pool covariance matrices (POOLVC) >

POOLVC program parameters

Batch code | Description
O | Name of a file containing two or more rectangular data matrices.
D | The direction corresponding to the variables in the data matrices. The default is ROW (checked).
C | Name of a file containing variance-covariance matrices for each group (should be provided only if the raw data are not available).
CGS | Name of a diagonal matrix giving sample sizes for each covariance matrix (must be included in covariance matrices are input).
M | Name for the matrix of group means (optional). In this matrix the rows will correspond to groups and the columns to the variables.
V | Name for the pooled within-groups variance-covariance matrix if raw data are furnished (otherwise it is the name of an input file of sample sizes for the variance-covariance matrices).
GS | Name for the rectangular or diagonal matrix of group sample sizes.
TH | Should a test for the homogeneity of variance-covariance matrices be applied? The default is NO (unchecked). Trying to use this option when sample sizes are too small may cause a variety of error messages due to matrices being singular. The test will also fail in a variable is invariant.


POOLVC technical details

Navigation: Computational modules > Pool covariance matrices (POOLVC) >

POOLVC technical details

The test statistic for homogeneity of covariance matrices is

,

where [image] ,

a is the number of groups, and ni is the size of the ith group. This statistic is undefined if the sample sizes for any of the groups are less than or equal to the number of variables.

X2 should be compared to a Chi square distribution with degrees of freedom [image] .


PROCRUSTES - superimposition analysis

Navigation: Computational modules > Procrustes (PROCRUSTES) >

PROCRUSTES - superimposition analysis

This module performs two types of operations. It can center, rotate, and scale one multivariate configuration of points so that they best match another configuration (called Procrustes analysis). This can be useful, for example, to compare the results of two ordination analyses. It can also compute an average configuration of a sample of multivariate configurations and then optimally superimpose the configurations onto this mean (called Generalized Procrustes Analysis, GPA). This is useful, for example, in geometric morphometrics for comparing the shapes of configurations of landmark points in a sample of specimens. The aligned coordinates can then be used as shape variables in multivariate analysis such as PCA, CVA, and multivariate regression. Note: if you use other software to analyze these data then it must be able to allow for the fact that covariance matrices based on these shape variables will not be of full rank.

Program parameters and batch codes.

Technical computational details.


PROCRUSTES program parameters

Navigation: Computational modules > Procrustes (PROCRUSTES) >

PROCRUSTES program parameters

Batch code | Description
O | Name of a file containing one or more rectangular matrices giving the coordinates of p points in a k-dimensional space.
F | The format of the input matrix. The configurations can be given in n SEPARATE k by p matrices or TOGETHER in a single n by kp matrix. The default is TOGETHER.
N | If the TOGETHER format is used then this field indicates the number of dimensions. The default is 2.
O2 | Name of a file containing a configuration to which those in the first file are to be compared. This configuration is stored in the same format as in the first file. Note: The TRANSF module can be used to convert between the k by p versus 1 by kp formats.
D | The direction (rows or columns) corresponding to the specimens (TOGETHER format) or dimensions (SEPARATE format) of the matrices in the input files..
SO | Scaling option for aligned configurations: COS(RHO) or 1. 1 is the default.
PO | Projection option for the aligned configurations: NONE, ORTHOGONAL, and STEREOGRAPHIC. The default is ORTHOGONAL.
PCA | Align consensus to its principal axes? Default is yes (checked).
AR | Allow reflections to improve fit? Default is no (unchecked).
SD | Show detailed output listing? Default is no (unchecked).
C | Name for the file to contain the consensus configuration.
A | Name for the file to contain the aligned configurations.
FO | The format for the consensus and aligned specimen matrices: SEPARATE or TOGETHER as in the input files. The default is TOGETHER.
PD | Name for the file to contain the Procrustes distances.
TD | Name for the file to contain the distances in the tangent space.
CS | The name for a file to contain the centroid sizes of each specimen as a matrix with n rows and 1 column.

If the second file name is blank then a GPA is performed on the configurations given in the first file. An advantage of the TOGETHER format is that independent analyses can be performed automatically if several matrices are placed in the same input file. If the SEPARATE format is used then a single GPA will be performed using all of the matrices found in the input file.

Codes for data file configuration:

SEPARATE | The p by k matrices for each of the n specimens are given one after another in the input file.
TOGETHER | The p by k matrices are strung out as single rows of a matrix with n rows and pk columns. For 2-dimensional data, the elements in each row are given in the order x1,y1, x2,y2, etc. (default).

Codes for projection methods:

NONE | The coordinates of the Procrustes aligned specimens are given as is.
ORTHOGONAL | The coordinates are orthogonally projected onto the tangent space defined by the average specimen (default).
STEREOGRAPHIC | The coordinates are stereographically projected onto the tangent space defined by the average specimen.


PROCRUSTES technical details

Navigation: Computational modules > Procrustes (PROCRUSTES) >

PROCRUSTES technical details

The following method is used to superimpose a configuration S2 onto configuration S1.

S1 and Sd are first centered on the origin and then S2 is then superimposed on S1 using the least-squares orthogonal Procrustes method yielding Ss. for each landmark point. In the 2-dimensional case, B is the vector (the summation is over landmarks and x1, y1, x2, and y2 are x and y coordinates from the two configurations) and is the squared centroid size of the configuration, S2.

The GPA consensus (average) for a set of configurations is obtained by arbitrarily selecting one configuration (e.g., the first) as a trial consensus. The other configurations are then superimposed onto this trial consensus and their average computed. This average configuration is then used as a new trial consensus and the process repeated until it converges (usually very quickly). For more information see Rohlf and Slice (1990) (in this paper this algorithm is called generalized least-squares superimposition, GLS).

The specimens can be size scaled after a GPA alignment in two ways. The following diagram illustrates the differences when variation is shape is very large.

Diagram of a cross-section of Kendall’s shape space (circle with a radius of ½), hemisphere of preshapes aligned to the reference (half circle with a radius of 1), and tangent space (tangent line at top). Procrustes distance is the angle ρ in radians. Point A represent the position of a shape in Kendall’s shape space and B is the corresponding position in the hemisphere after a GPA superimposition when it is scaled to unit centroid size. Point C is the stereographic projection of point A onto the tangent space (yielding shape coordinates) and D is the orthogonal projection of point B onto tangent space (yielding Kendall tangent space coordinates).

In practical applications the differences among the options are never expected to be as large as shown above. When shape variation is “small” they are very hard to distinguish. Why should one care about these distinctions when they make little difference in most real datasets? It is reassuring that options corresponding to points C and D result in a covariance matrix among landmark coordinates that will actually have four eigenvalues equal to zero (corresponding to the fact that variation due to translation, rotation, and scaling have been removed). Options corresponding to points A and B result in just three eigenvalues equal to zero since there still is some variation in centroid size (due to distance from the reference) remaining in the aligned data. For more information see Rohlf (1999).

Note: both projection options will result in aligned specimens whose shape can differ somewhat from the shape of the original specimens. These options are provided for statistical calculations based on the tangent space. If you simply wish to align the specimens then select the “none” projection option.


PROJ - Projection

Navigation: Computational modules > Project points onto vectors (PROJ) >

PROJ - Projection

This module performs several types of projection operations:

The PROJ option gives the usual projection of t objects (measured for n variables) onto one or more factor axes. The data matrix has usually been standardized using the module STAND and the axes are eigenvectors (computed using the EIGEN module) of a matrix of correlations among the variables. This corresponds to the matrix operation [image] , where F is an n variable by k dimensions factor matrix and O is the original input data matrix with n variables and t objects (by default, the objects correspond to the columns but an option is provided to allow for the possibility that the rows correspond to the objects). In the above equation, the matrix F is normalized (so that its length is 1). The projections are divided by [image] so as to make them numerically consistent with average taxonomic distances among a set of objects. If all of the eigenvectors are used, then Euclidean distances between objects based on the projection matrix will be equal to the average taxonomic distance based upon the standardized data. If the MULT option is used then normalization and scaling by [image] are not performed just a simple matrix multiplication. This is appropriate when the vectors are already in an appropriate scale. There are examples in the application section.

If a sufficient number of eigenvectors have been computed then the original data matrix should be well approximated by [image] (using F weighted by the reciprocals of the eigenvalues as a generalized inverse). T2-statistics can be used to measure the length of the residual vector for each OTU. Large values indicate that the position of an OTU is not well summarized by the principal components analysis (it is an outlier) and additional eigenvectors should be extracted. See Jackson (1991: pp. 34-41) for further discussion. The test for residual dimensions is performed if a matrix giving all of the eigenvalues is provided.

The MULT option simply computes [image] without any normalization of the F matrix. This option can be used, for example, to compute canonical variates scores for a new set of data.

The REGR option computes [image] , where O is the input matrix of q independent variables (rows) and n observations (columns). If matrix O is stored as an n by q matrix then the “OTUs are rows?” box must be checked. The vector 1 has 1 row and n columns and F is the q+1 by p matrix of regression coefficients. Thus matrix F must have one more row than there are rows in the O matrix (this is to allow for the intercept term as the first row of F). This operation is useful in predicting values for a new set of independent variables.

The REGRUC option computes [image] , where O is the input matrix of q independent variables (rows) and n observations (columns) and F is the q by p matrix of regression coefficients. Thus matrix F must have the same number of rows as the O matrix. This operation is useful in predicting values for a new set of independent variables using an uncentered regression (i.e., regression through the origin).

The ORTH option gives the projection of the objects onto a space orthogonal to the space spanned by the factor matrix. If there is just a single factor axis, then the data are projected onto its hyperplane. This option is useful for carrying out Burnaby's (1966) method for multivariate size correction. Rohlf and Bookstein (1988) describe this method and show its relationship to the method of "shearing" (Humphries et al., 1981). It also can be used to subtract out the effect of an isometric size vector (such as suggested by Somers, 1986, but using a different algorithm than suggested by him). There is an example in the applications section. There are many other useful applications of this technique.

This option performs the following operation: , where O is, as above, a data matrix with n rows corresponding to variables and t columns corresponding to the objects. L is a matrix that projects a dataset onto the orthogonal space.

,

where In is an n by n identity matrix, and F is the factor matrix (of dimension k).

The resulting matrix has the same dimensions as the input data matrix (but will always have the variables as the rows and objects as columns). Note: the resulting matrix will be singular. This may cause problems when the matrix is used as input to other types of multivariate analyses that require the inverse of a non-singular variance-covariance matrix such as canonical variates analysis or discriminant functions. The CVA module in NTSYSpc is designed to handle such singularities by using a generalized inverse (see the cutoff option in that module).

If the matrices are not the correct size (the numbers of variables do not match) or if the factor matrix has been transposed (the factors must correspond to the columns of this matrix), then the operations are not defined and an error message will be displayed.

Output:

The projection matrix is displayed as it is computed and written to the specified file. One may use the MXPLOT module to plot the axes against one another to complete the ordination analysis. As a measure of goodness of fit, one may also use the SIMINT module to compute a matrix of distances based on these projections. This matrix can then be compared (using MXCOMP) with the distance matrix based on the complete data matrix.

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.


PROJ program parameters

Navigation: Computational modules > Project points onto vectors (PROJ) >

PROJ program parameters

Batch code | Description
O | The name of the input data matrix.
D | The direction on the data matrix that corresponds to the objects – rows (checked) or columns. The default is COL (unchecked) that implies that the data matrix has n rows (variables) and t columns (objects). This will usually be checked for the two regression options.
F | The name of the input factor matrix. This matrix must have n rows (corresponding to the number of variables) and k columns corresponding to the number of axes. For the regression options this is the matrix of regression coefficients.
E | Name of eigenvalue matrix (needed only if analysis of projection residuals is wanted). Note: this matrix must contain the eigenvalues for all dimensions - not just the few retained and used in the input factor matrix. This must be done with a separate run of the eigen module.
PT | The type of operation to be performed. See table below for alternatives. The default is PROJ for the usual projection operation.
R | Name for the output matrix of projections of the t objects onto the k axes. This matrix will always have k rows and t columns.

Codes for projection types:

PROJ | Projection of points onto normalized vectors.
MULT | Matrix multiplication.
ORTH | Projection of points onto a space orthogonal to the given vectors.
REGR | Multiple regression estimates of Y.
REGRUC | Multiple regression estimates of Y for an uncentered regression through the origin.


PROJ technical details

Navigation: Computational modules > Project points onto vectors (PROJ) >

PROJ technical details

The test for outliers relative to the given number of dimensions is based on computing

for each OTU i based on just the retained eigenvectors. The vector [image] contains the means for the variables and [image] is approximated by [image] using just the retained eigenvalues and eigenvectors. The transformation to an F-value is based on the relationship [image] .

The degrees of freedom are n and t-n. The Hawkins (1974) statistic, [image] , is similar but based on only the n-k unretained eigenvalues and eigenvectors.


Principal components analysis

Navigation: Computational modules > Project points onto vectors (PROJ) >

Principal components analysis

(Principal components analysis, PCA, is one of the most important methods of ordination analysis. It constructs a new set of orthogonal coordinate axes such that the projection of points onto them have maximum variance. While defined in terms of variances and covariances, PCA is usually applied to standardized data since the results are sensitive to the often arbitrary choices of units of measurement used in a study.

The following batch file will standardize a data matrix by rows, compute a matrix of correlations among the variables (assumes rows), extract 3 eigenvectors from the correlation matrix, project the standardized data onto these eigenvectors, and then make a 3-dimensional plot of the objects. Various matrices are also output to files.

" Standardize variables (rows)

*stand o=data.nts r=sdata.nts

" Compute correlations among variables (rows)

*simint o=sdata.nts c=corr r=corr.nts d=row

" Output the correlation matrix

*output o=corr.nts

" Extract first 3 PCA axes from correlation matrix

*eigen o=corr.nts n=3 r=vect.nts val=val.nts

" Output principal component axes

*output o=vect.nts

" Project objects onto PCA axes

*proj o=sdata.nts d=col f=vect.nts r=proj.nts

" Output projections

*output o=proj.nts

" Display 3D plot of projection of objects

*mod3d o=proj.nts

" Display 3D plot of variables defining the PCA axes

*mod3d o=vect.nts d=col

The last two plots together comprise a three-dimensional biplot (a “bimodel”) for these data. If the MXPLOT module is used then a 2-dimensional biplot can be produced.

An alternative procedure would be to not standardize the data and to use a variance-covariance matrix rather than a correlation matrix in the above steps. In such a case, the largest weights are given to those variables with the largest variances. This implies that the variables were measured in comparable units of measurement. It might be appropriate, for example, for a matrix of log-transformed variables in a morphometric study (perhaps with means subtracted following Darroch and Mosimann, 1985).


Burnaby method for size adjustment

Navigation: Computational modules > Project points onto vectors (PROJ) >

Burnaby method for size adjustment

The following batch file shows an example of how the ORTH option of the PROJ program can be used for Burnaby's method to remove the effect of a vector from a data set. The data are projected onto the hyperplane orthogonal to the specified vector. In the example given below the first principal component axis is used as "size". Other vectors such as the isometric vector (1,1,...,1) could also be used.

" compute VCV matrix from a data matrix

*simint o=data.nts c=varcov r=vcv.nts d=row

" compute first principal component

*eigen o=vcv.nts n=1 r=pc1.nts

" project data onto hyperplane normal to PC1

*proj o=data.nts f=pc1.nts pt=orth r=bproj.nts

The resultant adjusted data matrix bproj can then be used, for example, to compute a distance matrix which is then clustered by SAHN. The clusters should then not be influenced by variation in the original data set that was parallel to the first principal component—which many would define as due to size. The first principal component points in the direction in which there is the most variation. If the organisms sampled happen to be about the same size, then this vector is apt to represent sexual differences, polymorphisms, etc. In many cases it may be safer to use an a priori defined isometric vector as a size vector or to use the first principal component based only on a carefully selected subset of variables.

The adjusted data matrix could also be used as input for a canonical variates analysis or for the computation of size-free generalized distances (see the CVA program).


RESAMPLE - create samples

Navigation: Computational modules > Resample (RESAMPLE) >

RESAMPLE - create samples

This module is used to create a file with new data matrices generated from a given initial data matrix. The new matrices can be generated as random samples with replacement (bootstrap sampling), with each observation in turn left out (jackknife sampling), as a matrix of normally distributed standard random deviates, or as normally distributed random deviates with the same means and standard deviations as the input data.

A single output file is produced containing all of the generated samples. When modules such as STAND, SIMINT, MULREGR, etc. are run they will perform the same computations on all of the matrices in the input file. Then the resulting matrices can be analyzed by the SUMMARY module.

Note: when running a module on a file with many matrices, the program can be greatly slowed by having to display so much information in the listing window. Thus you may wish to close this window while the computations are being performed. The information will still be saved so that you can examine it after the computations are complete.

Program parameters and batch codes. See also Summary.


RESAMPLE - program parameters

Navigation: Computational modules > Resample (RESAMPLE) >

RESAMPLE - program parameters

Batch code | Description
O | Name of the input matrix. The matrix must be rectangular.
D | The direction (rows or columns) that the matrix will be sampled. Default is ROW.
M | The method used to create the samples. See below for the codes.
N | The number of samples to be generated. This field is ignored for the jackknife method since n samples of n-1 observations will always be generated.
R | Name for the resultant file of matrices.

Codes for methods:

BOOTSTRAP | Bootstrap samples
JACKKNIFE | Jackknife samples
NORMAL(0,1) | Samples of standard normal deviates with the same number of rows and columns as the input matrix.
NORMAL(M,S) | Samples of normal deviates scaled to have the same means and standard deviations as the input matrix.
PERMUTE | Randomly permute the rows or columns of the input matrix.


Example of resampling

Navigation: Computational modules > Resample (RESAMPLE) >

Example of resampling

A simple example of using bootstrap sampling to assess the stability of the eigenvectors of a correlation matrix.

First, 100 bootstrap samples were generated from the rows of the Mammal’s milk data using the resample module.

            Water    Protein     Fat  Lactose

          ---------------------------------

Horse      |    90.1     2.6     1.0     6.9

Donkey     |    90.3     1.7     1.4     6.2

Mule       |    90.0     2.0     1.8     5.5

Camel      |    87.7     3.5     3.4     4.8

Llama      |    86.5     3.9     3.2     5.6

Zebra      |    86.2     3.0     4.8     5.3

Sheep      |    82.0     5.6     6.4     4.7

Buffalo    |    82.1     5.9     7.9     4.7

GuineaPig  |    81.9     7.4     7.2     2.7

Fox        |    81.6     6.6     5.9     4.9

Pig        |    82.8     7.1     5.1     3.7

Rabbit     |    71.3    12.3    13.1     1.9

Rat        |    72.5     9.2    12.6     3.3

Deer       |    65.9    10.4    19.7     2.6

Reindeer   |    64.8    10.7    20.3     2.5

Whale      |    64.8    11.1    21.2     1.6

The resultant file was then processed using the simint module to compute a correlation among the columns for the 100 bootstrap samples. The resultant file was then processed using the eigen module to compute 100 eigenvector matrices. This file was then processed by the summary module to yield the following results:

Means:

            1          2

  ----------------------

1 |    0.98521    0.15727

2 |   -0.97675    0.12184

3 |   -0.96904   -0.22371

4 |    0.95153   -0.26715

The matrix given above is the mean of the eigenvectors of the 100 bootstrap samples.

Standard deviations:

            1          2

  ----------------------

1 |    0.00759    0.04462

2 |    0.00751    0.07155

3 |    0.01160    0.05990

4 |    0.02547    0.08602

The matrix given above gives the standard deviations of each of the elements of the eigenvectors. It demonstrates that the elements in the second eigenvector are less stable than those in the first.

No missing data, all n = 100

alpha/2 limits: 2 and 99 out of 100 samples

Since the input matrices were based on a sampling experiment, the next two matrices give the upper and lower 95% bootstrap confidence limits for the eigenvectors. As expected, the limits for the second eigenvector are much wider than those for the first.

Lower limits:

            1          2

  ----------------------

1 |    0.96234    0.06653

2 |   -0.99257   -0.12097

3 |   -0.99393   -0.30559

4 |    0.87586   -0.47344

Upper limits:

            1          2

  ----------------------

1 |    0.99732    0.26810

2 |   -0.96063    0.23127

3 |   -0.94342    0.00190

4 |    0.98422   -0.08405

To perform a resampling experiment on a UPGMA tree the consensus module would be used to summarize the trees.


SAHN - Sequential agglomerative hierarical nested cluster analysis

Navigation: Computational modules > SAHN clustering (SAHN) >

SAHN - Sequential agglomerative hierarical nested cluster analysis

Performs the various clustering algorithms that Sneath and Sokal (1973) refer to as: Sequential, Agglomerative, Hierarchical, and Nested clustering methods. They and Dunn and Everitt (1982) give clear examples of the various clustering methods. There is an example in the applications section.

Agglomerative clustering methods are not well defined with respect to the treatment of ties found in step 1 of the algorithm listed above. Most modules simply ignore the problem and use the first value encountered. SAHN offers two options for the method to deal with ties. The WARN option simply causes a message to be displayed if SAHN encounters values tied for the closest pair of points found in step 1 above (it still only uses the first value encountered). In order to keep the module “efficient,” the module uses a rather conservative approach and may warn of ties when there actually is only a single tree possible.

The FIND option for ties results in a more involved approach, similar to that used by Hart (1983). Whenever there are tied values for the closest pair of objects (for example, d1,2, d3,7, and d5,6 may all be tied for the distinction of being the smallest distances in the matrix), the module tries each of the alternative clusterings (joining 1+2, 3+7, or 5+6 in the above example) on a copy of the present state of the cluster analysis (which would result in 3 trees being produced). Of course, new ties may be encountered during later steps so that a large number of output trees is possible using this recursive approach (the module itself is not recursive but its handling of the data structures is). Note that this approach can result in duplicate trees— so the results may not be as complex as they seem at first. By default the module uses a rather stringent definition for a “tie”- two values must differ by less than 10-10 (but this can be changed by the user).

The single link method is well behaved in the face of ties— all of the alternative trees are equivalent. The trees are just alternate ways of showing a multifurcation as a series of bifurcations at the same level. For this reason the FIND option is ignored if the SINGLE method is selected. For large matrices the FIND option requires much more computer time - even if no ties are found. If there are many ties the module may run out of working space (space on the “heap”) and it may be forced to terminate its search.

Since clustering methods will always cluster data whether or not there are really clusters present in the data, it is important that some check be made for the existence of clusters. The simplest procedure is to first run the SAHN module to cluster the data and then to use the COPH module to compute a cophenetic value matrix using the tree matrix produced by SAHN. The MXCOMP module can then be used to compare the cophenetic value matrix with the original matrix that was clustered. It is also helpful to perform a principal components or a principal coordinates analysis on the same data. It is very reassuring to see the same clusters in plots of the first 2 or 3 dimensions (of course it is possible for there to be distinct clusters that cannot be seen in the first 3 dimensions - but that seems to be unusual in real data).

Output:

The output of the module is in the form of a tree matrix . The tree matrix is an efficient method for describing a system of nested clusters where each cluster has a corresponding level. The tree matrix can be displayed by using the plot speed button or by using the TREE module.

If the FIND option is specified and there are ties in the input matrix that can influence cluster membership then up to NT alternative tree matrices will be written to the output file. Otherwise, the module will just warn if ties are found. The WARN option is conservative - it sometimes warns when the ties do not actually influence the clustering. The algorithm used was optimized for speed in clustering not for efficiency in determining the consequence of ties in the input similarity or dissimilarity matrix.

The next step is usually to use the COPH module to compute a matrix of cophenetic values and then to use the MXCOMP program to compute the correlation between the cophenetic value matrix and the original matrix being clustered. This is a useful measure of the goodness of fit of the cluster analysis. This correlation can also be used to select the best tree from among the tied trees that may be produced by SAHN (the alternative is to use their consensus).

It is also useful to output both the similarity or dissimilarity matrix used by SAHN and the original data matrix with the order of the objects changed so that they are in the same order as in the phenogram produced by SAHN (see the OUTPUT module).

Graphic speed buttons are available.

Program parameters and batch codes.

Technical computational details.

Example of a cluster analysis using UPGMA.


SAHN program parameters

Navigation: Computational modules > SAHN clustering (SAHN) >

SAHN program parameters

Batch code | Description
O | Name of a file containing a similarity or dissimilarity matrix. With the FIND option a considerable amount of storage may be needed.
CM | Code name for the clustering method. The available choices are listed in the table given below (default is UPGMA).
TM | Code for the method to be used to treat any ties that are found. The default is to just WARN the user. The module can also FIND all alternative trees.
NT | The maximum number of alternative trees to be output in the case of the FIND option (default is 25).
TOL | The tolerance for determining if two values are tied. The default is .
ST | Should the resulting tree(s) be written to the listing file? Default is “No” (unchecked).
R | Name for the resultant tree matrix.
B | The value for the beta parameter if the flexible method is selected (default value is -0.25). Values must be in the range -1 to 1.

Codes for clustering methods:

COMPLETE | Complete-link method.
FLEXI | Flexible clustering (see B, beta, parameter).
SINGLE | Single-link method.
UPGMA | Unweighted pair-group method, arithmetic average (default).
WPGMA | Weighted pair-group method, arithmetic average.
WPGMC | Weighted pair-group method, centroid average (assumes dissimilarity).
WPGMS | Weighted pair-group method, Spearman's average (assumes correlation).

Codes for method for treating ties:

WARN | Warn if ties are found (default).
NOWARN | In case of ties print a warning message but do not wait for a user response.
FIND | Find all trees that could result from different choices of tied similarity or dissimilarity values.

While the UPGMA clustering method is used most often, it is a good idea to also try both the single-link and the complete-link clustering methods. If the results are very similar then the clusters must be rather distinct. Those clusters which are identical in both analyses are called “ball clusters” (in these clusters the most dissimilar objects within the cluster are more similar to each other than any object within the cluster is to any object outside of the cluster). They can be found most easily by computing the strict consensus tree of the single and complete link trees.

The FIND option for treating ties is especially important when an association coefficient (such as the simple matching coefficient) is used based on a small number of characters. In such cases there may be many alternative trees — implying that the data do not suggest a unique set of clusters. In such cases it is probably best to report just the strict or the majority-rule consensus tree for the set of alternative trees.


SAHN technical details

Navigation: Computational modules > SAHN clustering (SAHN) >

SAHN technical details

Basically, what this module does is to implement a version of the following standard algorithm for agglomerative clustering (sometimes called a “greedy algorithm”).

1. Search the input matrix for the pair of objects (i, j) that are most similar (or least dissimilar).
2. Merge these objects into a new cluster.
3. Update the matrix to reflect the deletion of the pair of objects, i and j, that were merged and the addition of a new “object” corresponding to the new cluster. Similarities or dissimilarities have to be computed between the existing objects and the new cluster (the different SAHN methods differ only in the formulas used at this step).
4. Go back to step 1, above, if the size of the new matrix is greater than 2××2 - else stop. Note that 2 objects are deleted and one is added at each step so this algorithm must terminate.

The above algorithm implies that the computational effort to cluster a matrix increases by a factor proportional to [image] (the above steps will be performed t-1 times and each time the elements of an object by object matrix need to be searched). A more efficient algorithm is used in practice so that, on the average, computing effort increases proportional to just [image] .


SIMGEND - Similarity for genetic data

Navigation: Computational modules > Similarity for genetic data (SIMGEND) >

SIMGEND - Similarity for genetic data

Computes a variety of coefficients for genetic data. The genetic distance coefficients assume the use of gene frequency data see file formats for gene frequency data). If the original data are raw frequencies for different alleles then the TRANSF module can be used first to convert them to proportions. See this topic for the format of data files for allele data.

The Jukes and Cantor distance coefficient assumes that the variables are DNA sequences of nucleotides (with the base types coded numerically such as A=1, C=2, G=3, and T=4). This coefficient is based on the model that each of the four base types has the same chance of mutating and is equally likely to mutate to any of the other types (Weir, 1989 ).

The band similarity coefficient of Lynch (1990) is appropriate for RAPD and microsatellite data where each individual has pairs of band codes at each locus.

Output:

The resultant symmetric dissimilarity matrix is stored in the specified file. The OUTPUT module should be used to view the file.

Program parameters and batch codes.


SIMGEND program parameters

Navigation: Computational modules > Similarity for genetic data (SIMGEND) >

SIMGEND program parameters

Batch code | Description
O | The name of the input data matrix. Alleles for the same locus must be adjacent if the LA array (see below) is used.
C | The code name of the desired coefficient (default is NEI72). The list of available coefficients is given below.
NA | The name of a rectangular matrix giving a list of the sample sizes for each OTU. This information is needed for NEI-UB and HILLIS-UB coefficients.
LA | The name of a rectangular matrix giving codes to indicate the relationship between alleles and loci. All alleles with the same code value are taken as belonging to the same locus (see example below). This information is needed to compute the ARC, HILLIS, HILLIS-UB, PREVOSTI, and ROGERS coefficients.
R | Name for the resulting similarity or dissimilarity matrix.
D | The “direction” in which distance are to be performed. ROW (checked) = use the rows of the input matrix as the variables and COL = use the columns (unchecked by default).
L | Total number of loci, nloci. Used in CHORD, NEI-UB, and ROGERS-W distances.

Notes: The N matrix mentioned above is a rectangular matrix with a single row or column listing the sample sizes for the populations. The LA matrix is a similar matrix giving the identification number for the locus that each allele belongs to. For example, it you have a locus with two alleles and two loci with three alleles (a total of 8 alleles) then the codes would be 1 1 2 2 2 3 3 3. Note that alleles from the same locus must be adjacent (but with a space between each). See file formats for gene frequency data and file formats for allele data.

In the formulas given below, the summation indicates a summation over all loci. The inner summations are over alleles within each locus. The symbol [image] is the number of loci as computed from the input array giving codes to indicate which alleles belong to which loci. When there are missing values [image] may not be the same for all pairs of OTUs. The quantity nloci is given by the L parameter above.

Codes for gene frequency data:

ARC | Cavalli-Sforza and Edwards (1967) arc distance
 | , where
BS | Balakrishnan and Sanghvi (1968) distance.
CHORD | Cavalli-Sforza and Edwards (1967) chord distance.
HILLIS | Hillis (1984) distance
HILLIS-UB | Swofford and Olsen's (1990) suggestion to unbiass the distance by using same correction as in Nei's distance.
NEI72 | Nei's (1972) distance (default).
NEI-UB | Nei's (1978) unbiased distance. Formula as above but with denominator:
PREVOSTI | Prevosti (Wright, 1978 ) distance.
ROGERS | Rogers (1972) distance
ROGERS-W | Rogers distance as modified by Wright (1978).

Codes for DNA sequence data:

J&C | Jukes and Cantor (1969) distance modified for DNA sequence data.
 | , where qij is the proportion of bases in common.

Note: the Jukes and Cantor distance is set to 9999 if qij ≤ 0.25.

Codes for RAPD and microsatellite data

BAND | Lynch (1990) shared band similarity index.
 | , where Nxy is the number of bands in common and Nx and Ny are the numbers of bands in the two individuals being compared. A pair of individuals can have 0, 1, or 2 bands in common at each locus. See file formats for gene frequency data for an example of such a data file.


SIMINT - Similarity for interval data

Navigation: Computational modules > Similarity for interval data (SIMINT) >

SIMINT - Similarity for interval data

Computes a variety of similarity and dissimilarity coefficients for interval measure (quantitative) data. The input is in the form of a rectangular data matrix (possibly standardized) and the output is a symmetric matrix.

The average “taxonomic” distance and the average Manhattan distance coefficients are commonly used as measures of dissimilarity in numerical taxonomy. The correlation and cosine coefficients are often used when the presence of a size-factor seems to have an undesirable effect. They are based on the idea that “size” corresponds to the distance of a point from the origin and that “shape” corresponds to the angular difference between vectors (with the centroid of the space usually taken as the origin). The Bray-Curtis, Morisita, and Renkonen coefficients are often used in Ecology. The Tanimoto coefficient is sometimes used in Chemistry. The other coefficients are provided for special applications. For example, the XXT operation can be used to reproduce a correlation matrix from a factor matrix (if the lengths of the factors have been scaled to be [image] .

The texts by Sokal and Sneath (1963) and Sneath and Sokal (1973) give extensive accounts of the applications of similarity and dissimilarity measures to taxonomy. Pielou (1984) and Legendre and Legendre (1983) describe their applications in ecology. These references all furnish simple examples and discuss the problems of selecting among the available indices.

In all cases missing values are taken into account. For a pair of objects i, j only those values for k are used for which yki and ykj are both present. This means that different elements of the resulting matrix may be based on different sample sizes (which explains the emphasis on average coefficients). The N “coefficient” can be specified to get a matrix of sample sizes.

Output:

The resultant matrix is listed as it is stored in the specified file. The OUTPUT module should be used in order to format the output matrix into blocks of row and columns that can be viewed or inserted into wordprocessors.

Program parameters and batch codes.


SIMINT program parameters

Navigation: Computational modules > Similarity for interval data (SIMINT) >

SIMINT program parameters

Batch code | Description
O | The name of the input data matrix.
C | The code name of the desired coefficient. The list of available coefficients and their codes is furnished in the table given below (default is DIST).
R | Name for the resulting similarity or dissimilarity matrix.
D | The “direction” in which coefficients are to be computed. ROW (checked) = use the rows of the input matrix as the variables and COL = use the columns (unchecked by default).

Codes for coefficients— dissimilarity measures:

BRAYCURT | Bray-Curtis distance.
CANBERRA | Canberra metric
CHISQ | Chi-squared distance (as in correspondence analysis).
 | , where the "dot" means summation over that subscript.
DIST | Average taxonomic distance (default).
DISTSQ | Squared average distances.
EUCLID | Euclidean distances.
EUCLIDSQ | Euclidean distances squared.
MANHAT | Average Manhattan distances (city block).
PSHAPE | Penrose's shape coefficient.
PSIZE | Penrose's size coefficient.

Codes for coefficients— similarity and other indices:

CORR | Pearson product-moment correlation.
COSINE | Cosine of angle between vectors from the origin.
N | Sample sizes for each coefficient (this is of interest when there are missing values in the data matrix).
MORISITA | Morisita's (1959) index
 | , where
MORISIT2 | Horn's (1966) modification of Morisita's (1959) index for proportions.
RENKONEN | Renkonen's (1938) percentage similarity index.
VARCOV | Covariance matrix with variances on main diagonal and covariances on off diagonal.
XXT | Data matrix times its transpose, C = XXt if direction = COL, else C = XtX.
TANIMOTO | Tanimoto coefficient must be used on non-negative data. Usually one will first scale the data using the STAND module so the variables range from 0 to 1.

Note: the TRANSF module can be used to subtract a similarity coefficient from 1 to convert it to a dissimilarity coefficient.

See the texts by Sokal and Sneath (1963) and Sneath and Sokal (1973) for applications of similarity and dissimilarity measures to taxonomy and Pielou (1984) and Legendre and Legendre (1983) for applications in ecology.


SIMQUAL - Similarity for qualitative data

Navigation: Computational modules > Similarity for qualitative data (SIMQUAL) >

SIMQUAL - Similarity for qualitative data

Computes a variety of similarity and dissimilarity coefficients (association coefficients) for qualitative (nominal) data. It is often difficult to know which coefficient should be used in a particular application. Descriptions of the coefficients are given in many texts. The account given in Sokal and Sneath (1963) is especially complete. Pielou (1984) and Legendre and Legendre (1983) describe their applications in ecology. These texts furnish simple examples and discuss the difficult practical problem of selecting the appropriate index for use in a given study.

This module is also used on genetic data and the coefficients used as genetic distances, Babaei, A., S. R. Tabaei-Aghdaei, M. Khosh-Khui, R. Omidbaigi, M. R. Naghavi, G. D. Esselink (2007). Balestre et al. (2008) compare several coefficients for use on microsatellite markers. Landry and Lapointe (1996) compare several coefficients for use with RAPD markers and suggest the use of the Jaccard or the Dice coefficients with no less than 12 primers.

The input is in the form of a rectangular data matrix of codes for the states of each variable and the output is a symmetrical similarity or dissimilarity matrix. Note that many of the coefficients require the user to identify which character state code corresponds to a property being present and which corresponds to its absence. This same code applies to all characters. Thus a uniform convention must be used for all characters. For example, one might use “1” for present and “0” for absent.

Output:

The resultant matrix is listed and stored in the indicated file. The OUTPUT module should be used to break the rows and columns into convenient blocks that can be viewed.

Program parameters and batch codes.


SIMQUAL program parameters

Navigation: Computational modules > Similarity for qualitative data (SIMQUAL) >

SIMQUAL program parameters

Batch code | Description
O | The name of the input data matrix.
C | The code name of the desired coefficient. Default is SM. The coefficients provided for are listed in a table given below. See Sokal and Sneath (1963) for their definitions. Sneath and Sokal (1973) define the more commonly used coefficients.
R | Name for the resulting matrix.
D | The “direction” in which computations are to be performed. ROW (checked) = use the rows of the input matrix as the variables and COL = use the columns (default).
+ | The numerical value of the state to be considered “positive” for the 2-state association coefficients (default is 1).
-- | The numerical value of the state to be considered “negative” for the 2-state association coefficients (default is 0).

Codes for coefficients for multi-state data:

H | Hamann's (1961) coefficient: (m--u)/n.
RT | Rogers and Tanimoto's (1960) distance: m/(n+u).
SM | Simple matching coefficient: m/n (default).
UN1 | “Unnamed” coefficient no. 1: 2m/(n+m).
UN3 | “Unnamed” coefficient no. 3: m/u.

Codes for coefficients for two-state data (all require the + and - parameters):

DICE | Dice (1945) Coefficient (also Nei and Li, 1979): . Note: this is the same as the Sørensen (1948) similarity index.
J | Jaccard (1908) coefficient: .
K1 | Kulczynski (1927) coefficient no. 1: a/u.
K2 | Kulczynski (1927) coefficient no. 2:
PHI | Phi coefficient:
RR | Russel and Rao (1940) coefficient: a/n.
UN2 | “Unnamed” coefficient no. 2: .
UN4 | “Unnamed” coefficient no. 4:
O | Ochiai (1957) coefficient: .
UN5 | “Unnamed” coefficient no. 5:
 | .
Y | Yule (1911) coefficient: .

In the above table a, b, c, d, m, n, and u are defined as follows for a two-way frequency table for all pairs of two objects i and j:

 |  | j
 |  | + | –
i | + | a | b
 | – | c | d

then m = a+d (number of matches), u = b+c (number of “unmatches”), and n = u+m (total sample size).

Discussion of these coefficients can be found in Sokal and Sneath (1963). Some are also discussed in Sneath and Sokal (1973) and Legendre and Legendre (1983).


SVD - Singular-value decomposition

Navigation: Computational modules > Singular value decompositons (SVD) >

SVD - Singular-value decomposition

Performs a singular-value decomposition of a rectangular matrix. This operation has several mathematical interpretations but the most important one for multivariate data analysis is that of factoring a data matrix, A, into left, L, and right, R, eigenvector matrices and a diagonal matrix of singular values, W. A = LWRt. This equation implies that

.

If just a few of the singular values, wk, are much larger than the rest then matrix A can be well approximated by just a few columns of L and R. Greenacre and Underhill (1982) refer to SVD as finding the basic structure of a matrix. They also furnish examples different types of biplots constructed using a SVD of a matrix. Stewart (1993) gives a historical review. There is also a discussion in the applications section.

By default both the L and R matrices are scaled as length 1 but that is usually not appropriate. For example, a PCA for a data matrix A that has been standardized by rows (corresponding to the variables), then matrix L should be scaled to unit length (1) to yield the normalized eigenvectors of the matrix of correlations among the variables. Matrix R should then be scaled as LAMBDA to yield the projections of the points onto the L eigenvectors. Note that the singular values of A are the square roots of the eigenvalues of correlation matrix so scaling by LAMBDA here is equivalent to scaling by SQRT(LAMBDA) in the eigen module. Other applications of this versatile analysis require other combinations of scaling.

Lohmann (1983) proposed the use of a singular value decomposition on matrices of Zahn and Roskies' (1972) [image] coefficients. He refereed to this as “eigenshape analysis.” See Rohlf (1986) for a discussion of the relationship between this method and Fourier analysis.

The computational methods used are Householder reductions to bidiagonal form followed by a diagonalization of the bidiagonal form using QR transformations as described in Press et al. (1989). Discussions of the mathematical properties of SVDs are found in many texts on applications of matrix algebra. Greenacre and Underhill (1982) is a useful reference.

Output:

The input parameters are listed and then SVD is computed. The resulting singular values (eigenvalues)—but not the left and right eigenvector matrices - are displayed.

A biplot of the left and right eigenvector matrices can be plotted using the MXPLOT module. One can, for example, use the left matrix as the primary input matrix and the right matrix as the secondary input matrix. The normalization option should be set to NO.

Graphic speed buttons are available.

Program parameters and batch codes.


SVD program parameters

Navigation: Computational modules > Singular value decompositons (SVD) >

SVD program parameters

Batch code | Description
O | The name of the input rectangular matrix.
N | The number of dimensions to be retained in the output matrices (default is 3).
L | Name for the resultant left eigenvector matrix.
R | Name for the resultant right eigenvector matrix.
VAL | Name for the resultant singular value matrix.
SL | The code for the desired method of scaling for the left eigenvector matrix (default = LAMBDA based on the assumption that rows correspond to points and columns correspond to variables).
SR | The code for the desired method of scaling for the right eigenvector matrix (default = 1).
MI | The maximum number of iterations to be used. Default = 40.

Codes for method of scaling lengths of eigenvectors:

SQRT(LAMBDA) | Square root of the singular values.
LAMBDA | singular values.
1 | 1 (normalized singular vectors). Default.
1/LAMBDA | Reciprocal of singular values.

Note: different choices of scaling for the left and right singular vector matrices will usually be more appropriate for particular applications.


Sort matrix (SORTMX)

Navigation: Computational modules >

Sort matrix (SORTMX)

Enter topic text here.


Sort matrix

Navigation: Computational modules > Sort matrix (SORTMX) >

Sort matrix

The module enables one to sort the rows and/or columns of a rectangular or a symmetric matrix according to the elements in another matrix. The other matrix can be either be a rectangular matrix whose first column gives the new order or it can be a tree matrix such as produced by the SAHN module. this latter choice enable the raw data matrix to be sorted so that similar rows or columns are placed close together. This may make it easier to see patterns in the data - especially if the HEATMAP module is used to display the sorted matrix.

Program parameters and batch codes.


Sort matrix program parameters

Navigation: Computational modules > Sort matrix (SORTMX) >

Sort matrix program parameters

SORTMX program parameters

Batch code | Description
O | Name of a file containing a rectangular or a symmetric (similarity or dissimilarity) matrix.
R | The name for the resulting sorted matrix.
RO | The name of the matrix giving the new row order (optional)
CO | The name of the matrix giving the new column order (optional)

Note: the row and column order matrices are each optional but at least one must be specified or no sorting can be done.


SPLIT - split matrices

Navigation: Computational modules > Split a matrix (SPLIT) >

SPLIT - split matrices

This module is used to split (partition) a matrix into two or more separate matrices within the same file. The partitioning is defined by another file that lists the sizes of each partition. The matrix can be split by either rows or columns.

Program parameters and batch codes. See also Combine.


SPLIT - program parameters

Navigation: Computational modules > Split a matrix (SPLIT) >

SPLIT - program parameters

Batch code | Description
O | Name of the input matrix. The matrix must be either rectangular or diagonal.
S | List of the sizes of the sub-matrices to be produced. In interactive mode the numbers can be separated by blanks or plus signs. In batch mode they must be separated by plus signs without any blanks. Alternatively, the GN field can be used to read the values from a file.
GN | Name of a rectangular input matrix with a list of split sizes as a single column of values (such as produced by the COMBINE module). Either the S or the GN fields must be given – but not both.
D | The direction (rows or columns) that matrices will be split. Default is ROW.
R | Name for the resultant combined matrix.


STAND -- Standardization of variables

Navigation: Computational modules > Standardization of variables (STAND) >

STAND -- Standardization of variables

Performs a variety of linear transformations of the variables in a data matrix. The default options correspond to the usual standardization of a matrix used in numerical taxonomy. This module is used prior to SIMINT so as to reduce the effects of different scales of measurement in different characters. The linear transformation used is of the form:

where several optional values for a, b, and c are provided. Note that by using the proper codes for a and b several different standardizations are possible. The most common standardization is to subtract the mean and then divide by the standard deviation. However, Cooper and Milligan (1987) found that subtracting the minimum and then dividing by the range often produced better results for their test data that had a known structure.

The principal components of shape (Darroch and Mosimann, 1985) can be computed as follows: compute the log transformation of all variables (using the TRANSF module), standardize just by subtracting the mean of each transformed variable. The resulting log-shape variables can then be subjected to a principle components analysis.

Note: this module is provided as a convenience. The same operations (and many additional ones) can also be performed using the TRANSF module.

Output:

The means, variances, sample sizes, minima, and maxima for each variable are listed as the transformed data are written to the specified output file. The output file is usually used as input to the SIMINT module in order to compute a matrix of dissimilarities among all pairs of objects.

Program parameters and batch codes.


STAND program parameters

Navigation: Computational modules > Standardization of variables (STAND) >

STAND program parameters

Batch code | Description
O | The name of the input data matrix.
D | The “direction” in which the standardization operation is to be performed. Standardization by ROWs is the default which assumes the matrix has n rows (variables) and t columns (objects).
R | Name for the resultant standardized data matrix. This matrix will be the same size and shape as the input data matrix.
A | Coded for the quantity to be subtracted from the data values (default is YBAR). The subtract options are listed below.
B | Coded for the quantity to be divided into the difference Y -- A (default is STD). The divide options are listed below.
C | The value of a constant to be added after the above operations have been performed.

Subtract options:

MIN | The minimum value for each variable is subtracted.
YBAR | The mean of each variable, [image] , is subtracted (default).
0 | Nothing is subtracted.

Divide options:

MAX | Divide by the maximum value of each variable.
RANGE | Divide by the range of each variable.
STD | The difference is divided by the standard deviation (default).
SQRT(SS) | Divide by the square root of the sums of squares [image] for each variable, i.
SQRT(SY) | Divide by the square root of the raw sum of Y, [image] ,for each variable, i.
SQRT(SY2) | Divide by the square root of the raw sum of Y squared, [image] , for each variable, i.
SUMY | Divide by the raw sum of Y, [image] , for each variable (should not use if the sum is zero).
1 | No division is performed.


SUMMARY - summarize matrices

Navigation: Computational modules > SummarIize resampled results (SUMMARY) >

SUMMARY - summarize matrices

SUMMARY - summarize matrices

This module is used to summarize the results of analyses of bootstrap, jackknife, or other sampling. The module computes the element wise means and standard deviations. If the samples were based on a resampling experiment then confidence limits are estimated based on the input matrices.

If the samples were based on random permutations then matrices after the first are compared element wise to the first matrix and the proportion that are less than or are greater than those in the first (original) matrix. Elements of the matrices are declared “significant” if these proportions are less than or equal to 0.025 (for a two-tailed test at the 5% level.

This method of applying resampling and permutation tests is quite flexible. Note that this module can only summarize the output expressed as matrices that were saved to a file. It cannot summarize results that were only printed in the listing output.

Note that this module cannot summarize dendrograms (output of SAHN or NJOIN) resulting from a resampling experiment. While not yet as convenient as it should be, the CONSEN module can be used for that. Select the MAJRUL method and check the “show sets” checkbox. The listing output will then show how frequent the various sets (clusters) are among the input dendrograms. This can become rather tedious if there are many OTUs and a large amount of variability among the trees.

See also Resample.


SUMMARY - program parameters

Navigation: Computational modules > SummarIize resampled results (SUMMARY) >

SUMMARY - program parameters

SUMMARY - program parameters

Batch code | Description
O | Name of the input matrix. The matrix must be rectangular, symmetric, or diagonal.
A | Alpha, the probability value used to create confidence limits from the bootstrap, jackknife, or other samples.
M | The method that was used to create the samples. See below for the codes.
R | Name for the resultant file of averaged matrices.
SD | Name for the resultant file of standard deviations.
UL | Name for the resultant file of upper limits.
LL | Name for the resultant file of lower limits.
SD | Should the details of the computations be listed? The default is No.

Codes for methods:

RESAMPLE | Input matrices are the result of a resampling experiment. Computes upper and lower confidence limits based on alpha.
PERMUTE | Input matrices are the result of randomly permuting and input matrix. Computes how often elements of the input matrices are less than or are greater than the elements in the first matrix (assumed to be based on the original data that had not been permuted).


TPSWTS - Thin-plate spline weights

Navigation: Computational modules > Thin-plate spline weights (TPSWTS) >

TPSWTS - Thin-plate spline weights

TPSWTS - Thin-plate spline weights

Projects a series of specimens (described in terms of 2D or 3D coordinates) onto the principal warps and uniform components of a thin-plate spline defined relative to a reference specimen. This method is useful for the statistical analysis of shape variation for landmark based geometric morphometrics. An overview (with examples) of this field is given in Rohlf and Marcus (1993). Bookstein (1991) is a comprehensive text. The advantage of using partial warp scores (including the uniform component) is that they provide a non-redundant set of shape variables. Thus standard statistical software can be used that does not allow for the redundancy in the aligned coordinates.

See the technical details section for more information – especially for the new methods of estimating the uniform component for 3D data.

This module is provided as a convenience for statistical analysis since these same computations (but for only the 2-dimensional case) and interactive graphics are already provided in the freely-distributed tps series of programs for morphometrics by F. James Rohlf (click for WWW link). The tpsRegr program not only allows one to regress shape (as captured by the weight matrix) on an independent variable but it also allows one to visualize the shape change associated with an arbitrary linear combination of principal warps. Thus it can also be used to visualize canonical variates, principal components, etc. that may be computed using the weight matrix produced by this module.

Output:

The input parameters are written to the output listing and the bending energies (eigenvalues) associated with each principal warp. The matrix of partial warp scores can include or exclude the 2D or 3D estimates of the uniform component. The uniform component can also be saved to a separate file.

One can output the matrix of normalized principal warps, E. This may be of interest if one wants to compute the matrix of relative warp loadings, R' = (E ⊗⊗ I) R, where R = matrix of normalized relative warps, I = a 2 by 2 or 3 by 3 identity matrix, and ⊗⊗ = a matrix direct product (note: this operation is not built into NTSYSpc but with some effort one can simulate it by using the PROJ module to do a matrix multiplication separately for x, y, and z coordinates). See Rohlf (1993) for details.

Program parameters and batch codes.

Technical computational details.


TPSWTS program parameters

Navigation: Computational modules > Thin-plate spline weights (TPSWTS) >

TPSWTS program parameters

TPSWTS program parameters

Batch code |  | Description
O |  | Name of the input matrix of coordinates (these can have been aligned by the PROCRUSTES module but this module will repeat the alignment). The matrix is assumed to have n rows and k*p columns as in the TOGETHER format of the PROCRUSTES module.
F | The format of the input matrix. The configurations can be given in n SEPARATE k by p matrices or TOGETHER in a single n by kp matrix. The default is TOGETHER.
D |  | The direction of the matrix corresponding to the n observations, default is rows.
DIM |  | The dimensionality of the coordinates (2 or 3). Default is 2.
A |  | The value of the exponential weight, αα. Default is 0.
AFF |  | Option for inclusion of uniform shape components. Default is BOOKSTEIN96 but one of the other two methods must be used for 3D data.
AR |  | Check to align the reference to its principal axes. Default is checked.
SD |  | Check to show additional details of the computations. The default is unchecked.
W |  | Name for the resulting matrix of weights (partial warp scores).
U |  | Name for the matrix of uniform component scores.
UC |  | Name for the matrix of coefficients that define the uniform components.
PW |  | Name for the matrix of principal warps (eigenvectors of the bending energy matrix).
CS |  | The name for an n by 1 matrix of centroid sizes for each object.

Codes for data file configuration:

SEPARATE | The p by k matrices for each of the n specimens are given one after another in the input file.
TOGETHER | The p by k matrices are strung out as single rows of a matrix with n rows and pk columns. For 2-dimensional data, the elements in each row are given in the order x1,y1, x2,y2, etc. (default).

Options for estimation of uniform component

EXCLUDE | Do not include estimates of the uniform component in the matrix of partial warp scores.
BOOKSTEIN96 | Include the uniform component scores computed using Bookstein's (1996) method. Valid only for 2D data. (default)
COMPLEMENT | Include the uniform component scores computed using the complement method described in Rohlf and Bookstein (2003). Can also be used on both 2D and 3D data.
REGRESSION | Include the uniform component scores computed using the regression method described in Rohlf and Bookstein (2003). Can also be used on both 2D and 3D data.


TPSWTS technical details

Navigation: Computational modules > Thin-plate spline weights (TPSWTS) >

TPSWTS technical details

TPSWTS technical details

Briefly, the approach consists of Procrustes fitting the x, y (or x, y, z)-coordinates of the landmarks for each specimen in a sample to an average in order to eliminate variation due to differences in location, orientation, and scale. These values are then projected into Kendal tangent space so as to eliminate these now singular dimensions (4 for 3D data and 7 for 3D data) from the aligned coordinates. These new values (partial warp scores) can then be used in standard multivariate analyses. See Rohlf (1999) for a discussion of these ideas.

The partial warp scores can be used as shape descriptors to study variation in shape among the specimens. The values depend on the coordinates of the landmarks in a reference configuration. The reference is the mean configuration of landmarks after a GPA alignment of the specimens. The parameters can then be analyzed by conventional methods of multivariate statistics since, for a fixed reference configuration, the thin-plate spline parameters are simply orthogonal weighted linear combinations of the difference between each specimen and the reference configuration. Under the null hypothesis that there are no real differences in shape (specimens differ by only random normally distributed variation such as digitizing error at each landmark), then the parameters will be normally distributed and have homogeneous covariance matrices. Of course, the methods also inherit the usual potential for problems such as atypical values and lack of homogeneity of variances and covariances (see Krzanowski, 1988, for approaches to handle such problems).

The matrix of partial warp scores, W (“weight matrix”) is computed as

where is an n by kp matrix of differences between each specimen and the reference. The columns are in the order x,y, x,y, etc. This matrix is n××2p--6 for 2D data and n××3p--7 for 3D data. Appending the uniform component adds 2 columns for 2D data and 5 columns for 3D data. The symbol ⊗ denotes a direct (Kronecker) product of two matrices. The matrices E and Λ are from an eigen decomposition of the bending energy matrix (Bookstein, 1989 ). The bending energy matrix, [image] is the upper left p××p submatrix of the inverse of the L matrix which is a function of the reference configuration (see Bookstein, 1991, or Rohlf, 1993, for further details). An eigen decomposition of [image] yields Λ the a p×p diagonal matrix of eigenvalues and E the p×p matrix of eigenvectors (the columns correspond to the normalized eigenvectors and the rows to the landmarks).

Bookstein (1989) calls the eigenvectors, E, the principal warps. The magnitudes of their corresponding eigenvalues are inversely related to scale. Large eigenvalues correspond to principal warps that describe small-scale features (deformations of landmarks that are close together). Small eigenvalues correspond to principal warps that describe large-scale features. The last three eigenvalues must be equal to zero since they correspond to the affine components that are of infinite scale (scale, translation, rigid rotation, and uniform shape change). These zero eigenvalues and their corresponding eigenvectors are usually deleted to reduce ΛΛ to a (p‑3)×(p‑3) matrix and E to a p×(p‑3) matrix. When the principal warps are weighted appropriately (see Bookstein, 1991, and Rohlf, 1993 ) so as to yield the transformation (total warp) required to deform the reference configuration into that of a particular specimen they are called partial warps.

The elements of the n×2(p‑3) W matrix describe each specimen as a weighted linear combination of the principal warps. Since the Λ matrix is of rank p‑3, the weight matrix represents a projection of the variation at each of the p landmarks (k = 2 or 3 dimensions at each of the p landmarks) onto a 2(p‑3) or 3(p‑3) dimensional subspace. What this projection leaves behind is variation among the specimens with respect to size, translation, rotation, and uniform shape differences. The rows of the weight matrix describe the shape of each specimen as a deformation of the reference configuration.

The BOOKSTEIN96 option appends vectors that capture shape variation that can be described in terms of a uniform stretching or compression of a shape. For 2D data when the option to align the reference to its PCA axes is selected, Bookstein’s (1996) linearized Procrustes estimate is used. When the reference is not aligned and for 3D data the following method is used. First, the p by p matrix is computed, where E is a p by p-4 matrix of principal warps and Ip is a p by p identity matrix. Then, a singular-value decomposition is performed on , where V is the n by kp matrix of differences between each specimen and the reference configuration and Ik is a k by k identity matrix. The product of the first two (for 2D data) or 5 (for 3D data) left singular vectors and their singular values gives the scores for the uniform component. What the above procedure does (in a somewhat brute force manner) is to remove the effect of non-affine variation from the Procrustes aligned specimens. Any variation that remains must be due to the uniform component. The first tow or five columns of the right singular values matrix give the coefficients that define the uniform components. Under the null hypothesis of no uniform shape variation (just random normal digitizing error around each landmark), these should follow a normal distribution with equal variances and no correlation.

The COMPLEMENT and REGRESSION methods can be used for both 2D and 3D data. They are described in Rohlf and Bookstein (2003). They should both produce the same results. For 2D data they give results equivalent to the BOOKSTEIN96 method (they differ by a rotation). These methods have the advantage they do require the reference shape to first be rotated to its principal axes.


TRANSF - Transformation

Navigation: Computational modules > Transformations (TRANSF) >

TRANSF - Transformation

Performs a variety of linear and non-linear transformations of the elements of an entire matrix or upon selected rows or columns. It is also possible to apply several transformations in sequence. The transformations in the list are evaluated in a strict left to right order.

The simple transformations, the addition or multiplication by a parameter, and random number transformations can be applied to all types of matrices. The standardization related transformations can only be applied to rectangular matrices. The DCENTER transformation can only be applied to a symmetrical matrix. The deletion operations can be applied to rectangular, symmetrical, and diagonal matrices.

All transformations applied to symmetrical matrices are applied in a way so as to preserve symmetry. For example, when a row is deleted the corresponding column is also deleted.

There are also transformations to change the way elements in the matrix are stored. For example, a matrix can be transposed and rectangular (but square) matrices can be converted to symmetric matrices. It is also possible to split a row into two rows such that odd numbered elements are in one row and even in the other. Its inverse transformation is included as well as the analogous operation for three rows.

Output:

The input parameters for each transformation are listed before each transformation is applied.

Program parameters and batch codes.


TRANSF program parameters

Navigation: Computational modules > Transformations (TRANSF) >

TRANSF program parameters

Batch code | Description
O | The name of the input data matrix (note: some transformations are not defined for certain types of matrices).
D | The “direction” in which the operations are to be performed on a rectangular matrix. The default is by Rows (checked).
T | A list of transformations to be applied. Each item is of the format: t(p)[r] and items are separated by + signs (or blanks when used interactively). t is a transformation code (see list below), (p) is a list of parameters required by some transformations, and [r] specifies the range of rows or columns to be transformed (see below).
R | Name for the resultant matrix. The size and type of the matrix depends upon the transformations applied.

If the range code, r, is omitted then the entire matrix is used. Otherwise, it must be of the following format: [b-e], where b is the beginning row or column and e is the ending one. If b is omitted then the range will be taken as starting with the first row or column. If e is omitted then the range is assumed to extend to the last row of column. If a single number is given and the - is not present then only a single row or column is transformed. For example: [2-5] specifies rows 2 through 5, [-5] specifies the first 5 rows, [2-] specifies rows 2 though the last row, and [4] specifies that only row 4 will be transformed. Note: for the SHAPET transformation a and b indicate the variables to be used as x and y-coordinates rather than to a range of variables. If more than one parameter value, p, is required, e.g., for the SHAPET transformation, they should be separated by spaces or commas. If the parameter p is omitted, then a value of zero is assumed.

Simple transformations:

If the transformation code is left blank then no transformation is applied and the input matrix is copied to the output file. A number of common statistical transformations are provided. The format is the same for all of them. For example, to convert an entire matrix to logs enter LOG or to transform rows 3 through 5 to [image] enter SQRT5[3-5]. These transformations can be applied to all types of matrices. The result of an invalid operation, such as the square root of a negative number, is stored in the output matrix as a “missing value”. Note: that the “arcsine transformation” often used to transform binomial proportions is actually the inverse sine of the square root of the proportion. It must be done in two steps (SQRT+ASIN).

 | (no transformation)
ABS | Absolute value transformation
ACOS | , inverse cosine transformation
ASIN | , inverse sine transformation
EXP | , exponential transformation
LN | .
LOG | .
LOG1 | .
NEG | change the sign of elements
RECIP |
SQ | .
SQRT | .
SQRT5 | . .

Random numbers:

These transformations are useful for simulation and stability studies.

RANDU | yij replaced by random uniform number.
RANDN | yij replaced by random normal deviate with µ = 0 and σσ = 1.

Deletion:

These “transformations” can be used to delete a range of rows or columns from a matrix. When applied to symmetrical matrices, both rows and columns are deleted simultaneously so that the resultant matrix is still symmetrical. To delete the rows 1 through 5 of a matrix enter: DEL[1-5]. Note: this can also be abbreviated to DEL[-5]. The deletion operation cannot be applied to TREE or GRAPH matrices (matrix type codes 5 - 8). The codes for a series of deletions can be entered in any order. For example, if one wishes to delete rows 5, 6, and 10 then this can be specified as either DEL[5-6]+DEL[10] or DEL[10] +DEL[5-6].

Note: when more than one deletion is specified, the requests will be accumulated and performed at once unless there is a command (such as transp, 1TO2, shapet, etc.) that changes the storage of the matrix. For example, DEL[5]+SQRT+DEL[6]+TRANSP will take the square root of all elements of the matrix, then delete rows 5 and 6, and finally transpose the resultant matrix. On the other hand, The operations in a different order can have very different results. For example, DEL[5]+TRANSP+DEL[6]+SQRT will delete row 5, transpose the matrix, delete row 6 (which was column 6), and then take the square root of the remaining elements of the matrix.

DEL | Delete specified rows (or columns).
DELR | Delete a randomly selected row (or column) from within the indicated range.
DELRX | Delete a randomly selected row (or column) from within the indicated range. Will not delete an already deleted row (or column).
KEEP | Delete all except specified rows (or columns).

Standardization related operations:

These transformations can be used to scale the rows (or columns) of a rectangular matrix. The usual standardization of a matrix can be specified as: SUBYBAR+DIVSTD. To convert to proportions: DIVSUMY. As for the other transformations, these can also be applied only to selected rows or columns. See below for Bookstein’s transformation to shape coordinates.

DIVMAX | divide by maximum value in row i.
DIVRANGE | divide by MAXi-MINi for each row.
DIVSS | divide by sums of squares for each row.
DIVSTD | divide by the standard deviation for each row.
DIVSUMY | divide by row sums.
DIVSY2 | divide by [image] .
DIVV | divide by corresponding elements of row p, where p is the parameter, DIVV(p)
SUBMIN | subtract off the minimum value in each row.
SUBYBAR | subtract off the mean of each row.
SUBV | subtract off the corresponding elements of row p, where p is the parameter, SUBV(p)

Add or multiply by a parameter:

These transformations all require that a numerical parameter, p, be furnished in parentheses following the code for the transformation and preceding an optional range, given in [ ]. For example, to add 5 to the first 3 rows of a matrix enter the transformation: ADD(5)[‑3].

ADD | yij + p, p is a constant parameter.
DIV | yij / p, p is a constant parameter.
MUL | yij ×× p, p is a constant parameter.

Binarize:

The BIN transformation converts a continuous variable into a binary one. All values greater than p are replace by 1 and all others are changed to 0. This might be done, for example, to transform a few variables to binary so that a simple matching coefficient can be used on all of the data. If the parameter p is not specified then zero is assumed. This transformation can be combined with others. For example to use the mean of each variable rather than an overall constant, use the codes: SUBYBAR+BIN.

BIN

1 if yij > p, else 0, p is a constant parameter.

Misc. transformations:

The DCENTER transformation can be used to convert a distance matrix into scalar product form for principal components analysis as follows: SQ+NEG+MUL(0.5)+ DCENTER. The matrix type code will be changed to 3 to indicate that it is now a similarity matrix. For a similarity matrix one need only use DCENTER. In the resultant matrix, the diagonal elements can be considered to be the squared distance from each object to the centroid of the space. An off-diagonal element, e.g., gij, can be interpreted as didj cos θθij, where di and dj are the lengths of vectors connecting objects i and j to the centroid of the space and θθij is the angle between these two vectors.

The SHAPET transformation applies Bookstein’s (1986a, 1991 ) transformation to shape coordinates.

where p1 and p2 (the values of the two parameters) are the landmarks columns (or rows) used to define the base of the triangles. The rows (or columns) corresponding to the variables x and y are indicated by the lower and upper limits of the specified range, [x-y]. After the transformation the configuration of points has been translated, rotated, and rescaled so that xp1= yp1= yp2= 0 and xp2= 1. After this transformation the coordinates for landmarks p1 and p2 will be invariant and must be ignored in many types of multivariate analyses. For example, the code SHAPET(1,3)[2-5] indicates that the landmarks corresponding to columns 1 and 3 are to be used to define the baseline and that rows 2 and 5 contain the x and y-coordinates. The SHAPETU transformation translates and rotates but does not scale to a unit length baseline as does the SHAPET transformation. Thus the x-coordinate of landmark p2 will not be invariant.

The SHAPET2 and SHAPETU2 transformations are as defined above but for data matrices in which each row (or column) corresponds to a single specimen and the columns (rows) consist of alternating x and y-coordinates for all landmarks. The 2TO1 and 1TO2 transformations convert between these alternative formats. It is usually more convenient to have each specimen correspond to a single row (or column) of a matrix. However, one will wish to convert to having x and y-coordinates in separate rows in order to use the MXPLOT module to plot the landmarks for a specimen.

The SYMD, SYMS, and TRANSP transformations are used to change the storage format for a file. SYMD and SYMS convert symmetric matrices stored as rectangular matrices into the lower half matrix format required by NTSYSpc. The matrix must have the same number of rows and columns. The i,jth element of the output matrix will be the average of the i,j and j,i elements of the input matrix. No other transformation codes can follow SYMD or SYMS. Other transformations can follow the TRANSP (matrix transpose) operation. These transformations are often useful for the import of files from other modules.

The 1TO2 and 2TO1 transformations are intended for the manipulation of matrices of x,y-coordinates for elliptic Fourier analysis which requires all the coordinates for a specimen to be in a single row or column (x1, y1, x2, ...). It is also useful for the PROCRUST and PROCPLOT modules. They are also convenient for transforming many specimens to Bookstein shape coordinates (SHAPET2 transformation). The 1TO2 transformation separates the x and y coordinates into pairs of rows (or columns) so the specimen can be plotted using the MXPLOT module. The 2TO1 transformation combines pairs of rows. The 1TO3 and 3TO1 transformations provide analogous operations for x,y,z-coordinates and allow plotting using the MOD3D module. Deletion operations are performed before the following are applied because they change the structure of the matrix.

1TO2 | Split alternate elements in a row (or column) into separate rows (columns).
1TO3 | Split each triplet of elements in a row into three separate columns.
2TO1 | Combine two rows (or columns) into a single row by alternating elements.
3TO1 | Combine three rows (columns) into a single row by alternating among the three rows.
DCENTER | , the “double centering” operation for symmetric matrices that is required for principal coordinates analysis.
SHAPET | Bookstein’s transformation to shape coordinates. The two parameters indicate the two landmarks used to define the base of the shape triangles. The x and y-coordinates must be in separate rows (or columns). The rows (columns) to be interpreted as x-and y-coordinates are those corresponding to the beginning and ending range.
SHAPETU | Translate and rotate as in SHAPET but do not rescale to unit baseline length.
SHAPET2 | Bookstein’s transformation to shape coordinates. The two parameters indicate the two landmarks used to define the base of the shape triangles. The data must be arranged so that the x and y-coordinates alternate along a single row (or column).
SHAPETU2 | Translate and rotate as in SHAPET2 but do not rescale to unit baseline length.
SYMD | Convert square matrix to symmetrical storage with matrix type code set to dissimilarity.
SYMS | Convert square matrix to symmetrical storage with matrix type code set to similarity.
SYM2RECT | Convert symmetric matrix to a full square rectangular matrix.
TRANSP | Transpose the input rectangular matrix (interchange rows and columns).


Tree plot

Navigation: Computational modules > Tree plot (TREE) >

Tree plot

TREE plot

Displays a tree matrix (such as produced by the SAHN module) or the NJOIN module.

The algorithm used to convert a tree matrix into a dendrogram display is given in Rohlf (1975a). A generalization of this procedure is used to plot a tree with different heights for each OTU.

Note: The tree is displayed only a page at a time. The number of OTUs per page (30 is the default) can be changed by either opening the plot options window or by pressing the + or - keys. The current page to be displayed can be selected either from the plot options window or by pressing the z and x keys.

Note: Printing large trees can be a problem. If you increase the number of OTUs on a page then they will be crowded unless you use the plot options to reduce the size of the font used for the OTU labels. The lines will be printed with the width in pixels as specified in the plot options dialog. On a high resolution PCL printer lines only one pixel wide (the default) may be invisible. In such cases the widths should be increase to at least three pixels. The tree will then look rather ugly on the screen but it should then print correctly. As for the other graphics in NTSYSpc, the currently displayed plot can be saved to a file or else copied to the Windows clipboard and then pasted into such programs as Word. Note: Word has a built-in metafile editor that allows one great control over the details of a plot.

Right-click on the plot or use the Options menu to display the plot options.

Program parameters and batch codes.


TREE program parameters

Navigation: Computational modules > Tree plot (TREE) >

TREE program parameters

TREE program parameters

Batch code | Description
O | Name of the input tree matrix.

From the plot window you can copy the plot to the Windows clipboard or save it as an enhanced Windows metafile. Plot options include flipping the tree to place the OTU labels on the left or the right side. The number of OTUs per page can be changed by either opening the plot options window or by pressing the + or - keys. The current page to be displayed can be selected either from the plot options window or by pressing the z and x keys.


Statistical analyses in NTSYSpc

Navigation: Examples of applications >

Statistical analyses in NTSYSpc

Listed below are short descriptions of the programs that are included in NTSYSpc.

AUTOREGR Fits data using the pure autoregressive model. Used in spatial and phylogenetic autocorrelation analyses.

CANPLS Performs canonical correlation and partial least-squares analyses. Used to study correlations between two sets of variables.
COMBINE Combine two or more matrices into a single matrix.
CONSEN Computes a consensus tree for two of two or more trees (such as multiple tied trees from SAHN or between two different methods). Several consensus indices are also computed to measure the degree of agreement between trees.
COPH Produces a cophenetic value matrix (matrix of ultrametric values) from a tree matrix (produced, e.g., by the SAHN program). This matrix can be used by the MXCOMP program to test the goodness of fit of a cluster analysis to the similarity or dissimilarity matrix on which it was based. Can also compute a matrix of path-length distances from the results of the NJOIN program. These matrices can be used by the MXCOMP program to measure the goodness of fit to the similarity or dissimilarity matrix on which they were based. A phylogenetic covariance matrix can be computed to use in the AUTOREGR and MULREG modules for comparative studies.

CORRESPCorrespondence analysis. This is a useful way to investigate the structure of 2‑way contingency table.

CPCACommon principal components analysis. Fits a single set of eigenvectors to a series of variance-covariance matrices.

CVA Performs a canonical variates analysis (a generalization of discriminant function analysis).

DCENTER Performs a "double‑centering" of a matrix of similarities or dissimilarities among the objects. The resulting matrix can then be factored to perform a principal coordinates analysis (a method for displaying relationships among objects in terms of their positions along a set of axes based on a dissimilarity matrix).

EIGEN Computes eigenvector and eigenvalue matrices of a real symmetric similarity matrix. This program can be used to perform a principal components or a principal coordinates analysis by extracting eigenvectors (factors) from a correlation or variance‑covariance matrix.
FACTOR Factor extraction from a correlation matrix.
FOURIER Computes Fourier and elliptic Fourier (both 2D and 3D) transformations.FOURPLOT Plots outlines and estimated outlines from a Fourier analysis. Used with the FOURIER module.
FREQ Computes matrices of gene frequencies (allele frequencies or genotype frequencies) or proportions. The result can be used as input to the SIMINT or SIMGEND modules.
FROTATE Factor rotation.
FSCORES Computation of factor scores.

MDSCALE Nonmetric and linear multidimensional scaling analysis. This can be used as an alternative to PCA.

MOD3D Plots a 3‑way scatter diagram as a 3‑D perspective view of a model with t "objects" at tops of wires attached to a base plane. The view can be rotated interactively. This program is often used to view the results of a principal components or principal coordinates analysis. This program operates only in graphics mode.
MST Computes a minimum‑length spanning tree from a similarity or dissimilarity matrix. This is useful for showing the nearest neighbors of objects based on their positions in a multidimensional space.
MULREGR Performs various types of regression analyses. Includes simple bivariate regression, multiple regression, multivariate regression, and generalized least-squares regression (to take into account non-independence of observations).

MXCOMP Compares two symmetric matrices by computing their matrix correlation and then plotting a scatter diagram. The statistics for a Mantel test are also computed. It can be used to compute the goodness of fit of a cluster analysis to a dataset (by comparing a cophenetic value matrix with a dissimilarity matrix). It can also compare two matrices with the effects of a third matrix held constant (the Smouse-Long-Sokal 3-way Mantel test).

MXPLOT Plots 2‑way scatter diagrams of rows or columns of a matrix. Many plot options are available to customize the plots.
NJOIN Computes Saitou and Nei's (1987) and Gascuel’s (1997) unweighted neighbor-joining method to produce estimated phylogenetic trees.
OUTPUT Formats matrices into pages for printing. The files can also be read by most word processors. This formatted output is also useful for checking to make sure that an input file has been prepared in the correct format for NTSYSpc.
PLOT Plot one or more columns of a matrix against a selected column. Points can be connected by lines.

POOLVC Computes a pooled within-groups variance-covariance matrix from two or more data matrices. Can also perform a test for homogeneity.

PROCPLOT Plot superimposed configurations of points and their consensus configuration. Used with the PROCRUSTES module.
PROCRUSTES Aligns one matrix to best fit another or else computes an average matrix and aligns the matrices to best match their average.
PROJ Projects a set of objects onto one or more vectors—or onto a space orthogonal to a set of vectors. In principal components analysis one will project standardized data onto the eigenvectors of the correlation matrix in order to see the best (in a least‑squares sense) low‑dimensional view of a data set. The orthogonal projection option can be used to implement Burnaby's (1966) method for size adjustment.
MULREGR Multivariate multiple regression with options for uncentered regression as well as weights based on a covariance matrix among the observations.
RESAMPLE Generate samples from an initial input data matrix. Options are provided for bootstrap and jackknife samples as well as random permutations and random normal deviates.
SAHN Performs the sequential, agglomerative, hierarchical, and nested clustering methods as defined by Sneath and Sokal (1973). These include such commonly used clustering methods as UPGMA and single-link. The program can find alternative trees when there are ties in the input matrix.

SIMGEND Computes matrices of genetic distance coefficients from gene‑frequency and DNA sequence data.

SIMINT Computes various similarity or dissimilarity indices for interval measure (continuous) data (e.g., correlation, distance, etc. coefficients).

SIMQUAL Computes various association coefficients for qualitative data— data with unordered states (e.g., simple matching, Jaccard, phi, etc. coefficients).

SPLIT Split a matrix into two or more separate matrices within the same file.
STAND Performs a linear transformation of a data matrix so as to eliminate the effects of different scales of measurement.
SUMMARY Summarize the results of a resampling experiment.
SVD Computes a singular-value decomposition of a rectangular matrix. It allows you to compute principal axes and projections in a single step.
TPSWTS Computes projections of the 2D or 3D coordinates of objects onto the principal warps of a thin-plate spline bending energy matrix. This is done to enable separate statistical analysis of the uniform and non-affine components of shape variation.
TRANSF Performs various linear and non‑linear transformations of the rows or columns of a matrix. Can also be used to delete rows or columns, and alter the form of storage of some matrices matrix.
TREE Displays a tree (e.g., from a cluster analysis) as a phenogram using graphics. Options are provided for scaling and scrolling through a tree interactively.


Typical applications

Navigation: Examples of applications >

Typical applications

Several examples of typical applications of NTSYSpc are provided.

A few tutorial examples are provided below.

Cluster analysis using UPGMA.

Principal components analysis

Factor analysis

Resampling

Two-block partial least-squares

The following show the required steps as sequences of statements for use in batch files. These statements can be used as a guide to the sequence of programs to be selected from the main window and the filling in of the forms (the parameter values are the same for both interactive and batch modes). Note that lines that begin with a quote character are treated as comment lines and are ignored. This provides a convenient method for including comments within a batch file.

Examples:

Cluster analysis

Comments on ordination analyses

Principal components analysis

Principal coordinates analysis

Nonmetric multidimensional scaling

Burnaby’s method for size adjustment

Comparison of matrices

Canonical variates analysis

Geometric morphometrics

Comparative method


Example of a cluster analysis using UPGMA

Navigation: Examples of applications >

Example of a cluster analysis using UPGMA

If one starts with a data matrix consisting of variables that are not necessarily all in the same units, then one must first standardize the data matrix. This can be done using the STAND module. The screen shot below shows the entry window for STAND. The test.nts file will be standardized by rows (which correspond to the variables) to produce the testStand.nts file. The most common standardization is to subtract the mean and then divide by the standard deviation. However, Cooper and Milligan (1987) found that subtracting the minimum and then dividing by the range often produced better results for their test data that had a known structure. If the variables were all in the same units (e.g., gene frequencies) or are qualitative then this step can be skipped.

The listing results are shown below (various statistics are shown for the five variables).

Next, a similarity or dissimilarity matrix must be produced that measures the degree of dis/similarity between all pairs of OTUs (columns) of the standardized data matrix. It is sometimes difficult to decide which coefficient is the most appropriate. Unfortunately, this decision is very important. The SIMGEND module is used for gene-frequency type data and SIMQUAL for qualitative (e.g., presence/absence) data. Because our test data represents continuous variables we will show the use of the SIMINT module to compute a distance matrix.

The listing results are shown below (consists of just annotations about the input and output files). Note that comments have been added to the input file so that one is reminded of the fact that the data have previously been standardized.

Now one is ready to use the SAHN module to actually perform a UPGMA cluster analysis. The input parameters are shown below. Note the specification of testTree.nts as the name for a tree matrix. While not needed to perform the analysis and to display the tree, it is needed in order to compute a matrix of cophenetic values (ultrametric distances) to check on how well the cluster analysis represents the original matrix of distances among OTUs.

Once the analysis is successfully run, the tree plot icon will be shown at the bottom left of the NTSYSpc window as shown below.

The listing results only show the input parameters and information about the input file. If one clicks on the tree icon the following window will be displayed. If you have more than 30 OTUs then only the part of the tree corresponding to the first 30 OTUs will be displayed. Right-click on the plot to open the plot options window where you can specify the number of OTUs per page and which page to display.

Of course a cluster analysis will always yield clusters. In order to see how well a cluster analysis represents your distance matrix one will want to use the COPH module to transform the tree matrix to a matrix of ultrametric distances (a matrix of distances implied by the cluster analysis). The input to the COPH module would be as follows.

The listing only gives information about the input parameters and the files. The next step is to use the MXCOMP module to compare this testCoph.nts file with the testDist.nts file. The MXCOMP entry form is shown below.

The plot is shown below after using the plot options to change the background color of the points to red.

In addition to the usual listing of input parameters and input file information, the list includes the following information.

The only information of interest here is the matrix correlation (also known in this context as a cophenetic correlation). The probabilities are not of interest because they are based on the assumption that the two matrices being compared were obtained independently (this is not true here because the testCoph.nts matrix was computed based on a cluster analysis of the testDist.nts matrix).

Example of a batch file to perform the above computations


Example of a principal components analysis

Navigation: Examples of applications >

Example of a principal components analysis

If one starts with a data matrix consisting of variables that are not necessarily all in the same units, then one must first standardize the data matrix. This can be done using the STAND module. The screen shot below shows the entry window for STAND. The test.nts file will be standardized by rows (which correspond to the variables) to produce the testStand.nts file. If the variables were all in the same units (e.g., log-transformed morphological measurements) then this step can be skipped.

The listing results are shown below (various statistics are shown for the five variables).

The next step is to compute either a correlation or a covariance matrix among the variables. Use a correlation matrix if the data were standardized.

The listing results are shown below (consists of just annotations about the input and output files). Note that comments have been added to the input file so that one is reminded of the fact that the data have previously been standardized. The output would have been similar if a covariance matrix had been computed.

Next, one uses the EIGEN module to compute the eigenvalues and eigenvectors (the principal component axes) of the matrix produced in the previous step..

The listing results show the eigenvalues, the eigenvalues as percentages and as cumulative percentages. For comparison, the expected proportions explained under the simple broken-stick model are also shown. If the sample size and degrees of freedom were provided on the input form then the results of tests of all correlations are equal or that all correlations are equal to zero are also given.

Once the EIGEN module is successfully run, plot icons will be shown at the bottom left of the NTSYSpc window as shown below. These plots are of the eigenvectors. Each point corresponds to a variable in the original data matrix. One interprets relations in this plot not in terms of proximity of points but in terms of closeness of angles from the origin. To better see these angles, open the plot options window an select “vectors”. You will usually (as in the present example) have to rescale the plot in order to include the origin in the plot. One can see from the plot below that the variables have positive correlations. Variables 3 and 4 seem to be separated by a small angle, which would imply a large positive correlation.

To produce the actual ordination of the observations, OTUs, one more step is required. The PROJ module is used to project the observations onto the principal component axes. The usual setup is shown below. Note that the standardized data are used for the input file (rather than the raw data) because we computed the eigenvectors of the correlation matrix in out examples. The “OTUs are rows?” checkbox is not checked because in our case the rows of our data matrix correspond to the variables. The matrix of eigenvalues was provided to permit a test for outliers.

If running the PROJ module is successful then two plot icons will appear at the bottom left of the NTSYSpc window. They will produce a plot such as the following. You may wish to open the plot options window to select options to improve the appearance of the plot (in our example, labels were selected and the background color for the points was changed to black). In this plot one interprets proximity of points and looks for interesting patterns and trends. Note that point “D” seems to be an outlier (actually, “F” is more of an outlier but one cannot see that in this two-dimensional plot). The listing output includes a test for outliers if the matrix of eigenvalues was provided in the input.

In an actual analysis one would wish to interpret the plots of the eigenvectors and the projections simultaneously. This can be done most easily by using the MXPLOT (for 2D) module directly. Note that the matrix of eigenvectors is provided as the “secondary input file” and that the “Plot secondary by rows?” checkbox is not checked.

The plot given below shows both the observations (as points) and the variables (as vectors). Plot options have been used to label the points and the secondary points and to show vectors for the secondary points. Note: in this and the other plots shown above, it is essential that the proper aspect ratio be maintained for the x and y-axes. In the plot options window Options tab there is a “General” button that provides access to the maintain aspect ratio check box.

While quoting the percentage of variation explained is a standard way to describe how well a principal components analysis captures variation in two or three dimensions, it is not the best index if ones purpose to produce an ordination where similar points are plotted close together and dissimilar ones are plotted far apart. An alternative is to compute just two eigenvectors. Then use the resulting 2-dimensional projection matrix as if it were a data matrix to compute a matrix of distances between all pairs of points using the SIMINT module. This matrix can then be compared to a distance matrix based on the actual data (or standardized data) matrix by using the MXCOMP module. The resulting matrix correlation is a direct measure of the extent to which small or large distances in the ordination actually imply small or large distances in the data.

Example of a batch file to perform the above computations


Example of a two-block PLS analysis

Navigation: Examples of applications >

Example of a two-block PLS analysis

A data matrix giving two demographic variables (population size and the number of large manufacturing concerns) and environmental variables (SO2 levels, average temperature, average wind speed, amount of precipitation, and the number of days with precipitation) for 41 US cities was analyzed to see whether there was any relation between them.

Input screen:

The following results were obtained:

Cross set covariances/correlations to be analyzed:

                S02      TempF     WindSp     Precip PrecipDays

        -------------------------------------------------------

Manuf   |    0.64477   -0.19004    0.23795   -0.03242    0.13183

PopSize |    0.49378   -0.06268    0.21264   -0.02612    0.04208

The purpose of the analysis is to try to describe the pattern of covariances or correlations shown in this matrix by as few linear combinations as possible. In this example a single linear combination is able to account for most of the correlations between the two sets of variables (see below) even though the correlations are not very large..

Cross set analysis:

 i Covariance    Covar^2    Percent Cumulative

 1    0.90297    0.81536   99.15449   99.15449

 2    0.08338    0.00695    0.84551  100.00000

Sum of squared covariances =    0.82231

Correlations between left and right scores

   1    0.54913

   2    0.28920

These show that the relationship is mostly one-dimensional (99% of the covariation accounted for by the first dimension).

A permutation test was also performed. The results are as follows:

Results of permutation test:

(Note: counts include observed and small percentages imply "significance")

Number and percent of squared singular values >= observed

(Expressed as a proportion of the total.)

 Dim.  Observed  Count  Percent

    1  0.991545    141    14.10%

Number and percent of cumulative squared singular values >= observed

(Expressed as a proportion of the total.)

 Dim.  Observed  Count  Percent

    1  0.991545    141    14.10%

Number and percent of correlations >= observed:

 Dim.  Observed Count  Percent

    1  0.549132    40     4.00%

    2  0.289200   145    14.50%

While the correlation is statistically significant, the proportion more deviant was just 4%, the relationship is not very strong because the correlation is only about 0.55. For comparison, the first pair of linear combinations from a canonical correlation analysis yields a correlation of 0.75556 with a probability of just 0.10%. The following plot shows scores for first left and right PLS linear combinations.

It usually is of interest to prepare biplots based on the first and second sets of variables. In the following plots the points correspond to the individual samples (cities) and the vectors to the variables. By comparing these two plots one can see that cities with larger populations and manufacturing concerns also tend to have more SO2 pollution and a higher average wind speed. Vectors parallel to the x or y axes are more strongly correlated with those axes. Variables with vectors pointing in similar directions in the two plots tend to be correlated (negatively if they point in opposite directions). One can compare these predictions with the printout of the cross set covariances/correlations matrix displayed above.

Note that one almost always has to open the plot options dialog, select the secondary points tab, and change the scale factor used to adjust the lengths of these vectors so that they properly display.

A canonical correlation analysis is performed in a similar way. The correlations are usually larger but the interpretation of the results is often more difficult.


Comments on ordination analyses

Navigation: Examples of applications >

Comments on ordination analyses

In ordination analyses the goal is to position points along coordinate axes in low dimensional spaces (rather than to form sets of points as in cluster analysis). There are many different methods depending upon the criteria used to define what is meant by the “best” low-dimensional representation of the relationships among the points. Several programs in NTSYSpc can be used to perform these analyses. Several examples are described below.

When an original data matrix is available it is possible, and usually desirable, to form a joint plot called a “biplot” that gives an ordination of the points superimposed on an ordination of the variables. This allows one to not only see the patterns, trends, etc. among the points and of relationships (usually correlation) among the variables, but also the relationships between the points and the variables at least to the extent that they can be summarized in a few dimensions. Unfortunately, there seems to be no strong consensus about how to scale the two ordinations relative to one another. Gabriel (1971, 1972, 1980, 1981) defines a biplot of an n××p matrix Y as a simultaneous bivariate plot of the n points in each column of a matrix A and of the p variables in each column of matrix B if Y=ABt (it would be a bimodel if a 3-dimensional plot were made). Matrices A and B can be expressed in terms of a singular-value decomposition of matrix Y: Y=UΛVt. One could set A=UΛ and B=V (called a JK biplot by Gabriel and Odoroff, 1986). In terms of principal components analysis, this corresponds to computing normalized eigenvectors from the correlation or variance-covariance matrix for the variables and then using the PROJ program to project the points onto these vectors. The rows of A are plotted as points and the rows of B are plotted as vectors. Note that the matrix Λ of singular values is the square root of the eigenvalue matrix obtained in a principal components analysis. This type of decomposition of a data matrix is called preference scaling or repertory grid analysis in psychology and sociology.

One can equally well set A=U and B=VΛ (GH biplot of Gabriel and Odoroff, 1986). One could also multiply both U and V by √√ΛΛ (an SQ biplot). This latter choice would seem most appropriate in correspondence analysis where both the rows and columns can be interpreted as variables The matrix Λ could also be apportioned in any other way to U and V as long as their product is Λ.

A problem with a JK biplot is that the vectors for the variables are of unit length and thus are not in the same scale as the vectors for the points. Since the vectors for the variables are dimensionless a plot of them does not indicate how well the variance of each variable is explained by the number of dimensions used. For this reason I prefer to deviate from a true biplot and multiply both U and V by Λ. As a consequence, one cannot visually estimate an element, say yij, of the original data matrix as simply the inner product of row i of A and row j of Bone must compute the projection of row i of A onto row j of B. One compares the relationships between the ordinations of the points and of the variables by examining the angles between them. Jackson (1991) indicates that this alternative is popular “among French practitioners.”


Example of consensus trees

Navigation: Examples of applications >

Example of consensus trees

It is often useful to compare two or more dendrograms - perhaps the results of clustering using different methods or different data sets. Another situation would be when bootstrapping the results of, for example, a UPGMA cluster analysis.

Example comparing two dendrograms computed by different methods using the same data.

Tree 1:

Tree 2:

Setting of parameters for the consensus module:

Listing output produced:

(The sets in the consensus are displayed using numbers of the original positions of the objects in the input matrix rather than using their labels which would make the sets long and more difficult to read.)

Frequency of subsets over 2 input trees

Subset, Count, & Proportion:

[1,2,3]              <-- a set in the consensus

<  2> 1.000         <-- the number of trees in which found

[14,15,16]

<  2> 1.000

[12,13,14,15,16]

<  2> 1.000

[1,2,3,4,5,6]

<  2> 1.000

[1,2,3,4,5,6,7,8,9,10,11]

<  2> 1.000

Sets with counts marked with "< >" are included in the consensus tree

0.800     0.700     0.600     0.500     0.400     0.300     0.200

|---------|---------|---------|---------|---------|---------|       Level

                                                           .-Horse       0.200

                                                           |

                                                           .-Donkey      0.200

                                                           |

                                       .-------------------L-Mule        0.400

                                       |

                                       .---------------------Camel       0.400

                                       |

                                       .---------------------Llama       0.400

                                       |

                    .------------------L---------------------Zebra       0.600

                    |

                    .----------------------------------------Sheep       0.600

                    |

                    .----------------------------------------Buffalo     0.600

                    |

                    .----------------------------------------Guinea_Pig  0.600

                    |

                    .----------------------------------------Fox         0.600

                    |

.-------------------L----------------------------------------Pig         0.800

|

|                   .----------------------------------------Rabbit      0.600

|                   |

|                   .----------------------------------------Rat         0.600

|                   |

|                   |                  .---------------------Deer        0.400

|                   |                  |

|                   |                  .---------------------Reindeer    0.400

|                   |                  |

L-------------------L------------------L---------------------Whale      -----

Consensus indices for 2 trees:

 CI_c   =    0.35714

 CI_m   =    0.32143

 N sets =     5

 CI_sf  =    86

The same consensus tree displayed using the Graphic speed button:

Example of a bootstrap consensus dendrogram

To summarize trees after bootstrapping input the name of the file with the bootstrap trees as the first input tree file and leave the second file name blank. Then use the majority rule consensus method and check the boxes for "Show all sets?" and "Show just final?".

The listing of sets will then give the proportion of the bootstrap dendrograms that contain that set. Unfortunately, the program does not yet place these values directly on the dendrogram.


Analysis of gene frequencies

Navigation: Batch files >

Analysis of gene frequencies

The FREQ and SIMGEND modules are designed to be used with gene frequency data.

The FREQ module computes matrices of gene frequencies with each row corresponding to a different population and the columns corresponding to the alleles or the genotypes. The input matrices have entries of ‘0’ corresponding to the absence of an allele or genotype or ‘1’ corresponding to its presence in an individual. Samples from different populations can be provided in separate matrices included one after the other in the same input file or they can be combined into the same matrix and a vector of codes provided to indicate the population from which each specimen was sampled.

The SIMGEND module is used to compute various genetic distance coefficients. The output from SIMGEND can be clustered using the SAHN module, a phylogenetic tree estimated using the NJOIN module. Alternatively, an ordination analysis can be performed by using either DCENTER and EIGEN for a principal coordinates analysis or else the MDSCALE module for a non-metric multidimensional scaling analysis.

An example of a possible analysis is given below.

“ The following assumes that data for each population are in separate

“ matrices but all stored in the same file ‘genedata.nts’. The rows

“ correspond to individuals and the column correspond to alleles.

*freq o=genedata.nts d=row na=popsizes.nts r=genefreq.nts

“ The following assumes that there are 25 loci in the data.

“ Compute distances among the rows (populations).

*simgend o=genefreq.nts d=row c=NEI-UB na=popsizes.nts L=25 r=neidist.nts

“ Perform a UPGMA of the Nei distance matrix.

*sahn o=neidist.nts t=neitree.nts


Cluster analysis

Navigation: Batch files >

Cluster analysis

The most common use of NTSYSpc is for performing various types of agglomerative cluster analysis of some type of similarity or dissimilarity matrix. The following is an example of a batch file that will standardize a data matrix, in file data, compute distance coefficients among the columns of the standardized data matrix, cluster the distance matrix using the single-link clustering method, compute a cophenetic-value (ultrametric ) matrix, compute the cophenetic correlation, and then plot the results in the form of a phenogram. The distance matrix is also output.

" Standardize the variables

*stand o=data.nts r=sdata.nts

" Compute a distance matrix

*simint o=sdata.nts r=dist.nts c=dist

" Do a single-link cluster analysis of the distance matrix

*sahn o=dist.nts r=tree.nts cm=single

" Compute cophenetic values

*coph o=tree.nts r=coph.nts

" Compute the cophenetic correlation

*mxcomp x=coph.nts y=dist.nts

" Display phenogram

*tree o=tree.nts

" Display distance matrix

*output o=dist.nts


Comparative method

Navigation: Batch files >

Comparative method

Ordinary statistical methods cannot be used when it is known that the observations have not been sampled independently. An important example is when correlation or regression analyses are performed across phylogenetically related species. In such cases one expects the values for closely related species to be more similar on average than more distantly related species. The effect of this violation of assumptions is to greatly increase the chance of a type I error (statistics will appear significantly different from zero too often). While several approaches have been proposed, the most useful is phylogenetic generalized least-squares analysis. To carry out such an analysis one must first compute a phylogenetic covariance matrix. The COPH module can do this based on the assumption that evolution is a continuous Brownian motion type of random walk. Note that there is no requirement for the tree to not have multifurcations. The tree does have to have accurate branch lengths and be rooted. The MULREGR module is can used to regress Y on X with this covariance matrix used to correct for the expected lack of independence. For more information see Rohlf (2001). See also Rohlf (2006) for a discussion on the interpretation of such analyses.

An example is given below.

“ given a phylogenetic tree with branch lengths, compute cov. Matrix.

*coph o=tree.nex r=phylocov.nts m=PhyloCov

“ regress Y on X taking into account PhyloCov

*mulreg y=Y.nts x=X.nts V=phylocov.nts b=regr.nts sd=y

Note that regression through the origin option should not be used in this type of application.


Geometric morphometrics

Navigation: Batch files >

Geometric morphometrics

NTSYSpc can be used for the statistical computations need in2D or 3D landmark-based geometric morphometric studies. First, a matrix must be constructed in which each row corresponds to a specimen and the rows correspond to the x,y coordinates of the landmarks. The Procrustes module computes the average landmark configuration and then aligns all of the specimens to it. The procplot module can be used to view the variation at each landmark.

The matrix of aligned specimens can then be analyzed in various ways. A principal components analysis of the covariance among the landmark coordinates corresponds to an analysis of relative warps with the alpha parameter set equal to zero.

One can also test for group differences in shape by using the poolvc and cva modules. In order to do this all the specimens must be superimposed together using the Procrustes module. The aligned coordinates for the different groups must then be separated into their own matrices in order to use the poolvc and cva modules. Note that you must set the threshold parameter to a value slightly larger than zero (e.g., 0.00000001) because the within-groups covariance matrix must be singular.

For just two groups one can use the mulreg module to regress a dummy variable (with values of 1 for one group and –1 for the other group) onto the aligned specimens. In this case one must also set the tolerance parameter to a value slightly larger than zero. One can also regress shape onto one or more independent variables.

An example is given below.

*Procrustes o=mosq.nts n=2 a=aligned.nts

*procplot o=aligned.nts

“ analysis of relative warps

*svd o=aligned.nts n=2 l=pcaScores.nts

“ discrimination between two groups

*mulreg y=groups.nts x=aligned b=regrcoeffs.nts tol=0.000000001 sd=y


Technical support

Navigation: Technical support & updates >

Technical support

For technical support, contact the author: F. James Rohlf, Stony Brook University. It is usually best to communicate via e-mail (f.james.rohlf@stonybrook.edu) so that data files and other information can be attached. Note: version 2.2 represents a significant upgrade and thus more than the usual chance for bugs. Free service releases will be made available from Applied Biostatistics' web page at http://www.appliedbiostat.com. Also check the “Frequently Asked Questions” page at that site for helpful hints.

e-mail Send e-mail to f.james.rohlf@stonybrook.edu.

For sales support, email support@appliedbiostat.com.

Browse Applied Biostatistics' home page at http://www.appliedbiostat.com.


Updates

Navigation: Technical support & updates >

Updates

Version 2.2 was released in June 2004. Information on updates to this software can be obtained from Applied Biostatistics through their WWW home page (http://www.AppliedBiostat.com) . For your convenience, they can be accessed using the button given below.

WWW Download current NTSYSpc updates.

For the convenience of the many previous users of NTSYSpc, version 2.2 was designed to be as compatible as possible with the previous versions. There are several important differences however (see the notes in red below).

Some of the new features in version 2.2 are listed below.

Changes to the user interface:

• The design of the user interface has been changed to make NTSYSpc input dialogs more standard and easier to use.

• Menu of modules is less crowded.
• Configuration module improved.
• Added CSV and matlab output options to most modules.
• Can now read Office 2007 xls and xlsx files.
• Help file converted to the compiled HTML format (*.chm files).
• The user may now specify the “,” to be used as a decimal separator using the configuration option. This also changes the CSV separator to a semicolon “;” character (and also as the optional separator in NTS files).

New modules:

• COMBINE – combine two or matrices into one

• FACTOR – factor extraction.
• FROTATE – Factor rotation.
• FSCORES – factor scores.
• RESAMPLE – generate samples from a data matrix
• SPLIT – split (partition) a matrix
• SUMMARY – summarize results of resampling experiments (bootstrap and permutation)

Improved modules

• CANPLS – Now allows for input of data matrices rather than just correlation matrices. This allows permutation tests and additional plots to be made.

• CPCA – Better organization of the results of the statistical tests.
• CONSEN – Added option to just list sets in the final consensus tree.
• MOD3D – A second matrix can be plotted to permit the display of a 3D biplot (a “bimodel”).
• POOLVCV – Added tests for homogeneity of subsets of covariance matrices.
• TPSWTS – Added new methods for computation of the uniform component.

NTedit:

• Can now append matrices.

• Drag and drop files from the Windows explorer to the edit window.
• Cells in the data grid are now color-coded.

Changes from version 2.0 to 2.1

Changes to the user interface:

• The design of the user interface has been changed to make NTSYSpc easier to use. The computational modules are now organized in folders in a bar along the left side of the main window.

• A customize option allows the user to place frequently used modules in a user defined folder.
• Excel data files can now be read directly by all appropriate NTSYSpc modules (the less reliable DDE and OLE methods are no longer used). Note: this change required a slight change in the Excel file format.
• CSV (comma separated variables) format files can now be read by NTSYSpc. The layout is identical to that for Excel files.
• Nexus tree files can now be read and the NTS file format has been extended to allow trees with OTUs at different heights.
• Plot options (choice of fonts, colors, etc.) can now be saved and reloaded in graphics options files. The options are now organized in a convenient tabbed notebook display.
• The NTS extension is now associated with the NTedit program and NTB is associated with the NTSYS program (this means these programs can be started by double-clicking on a file name in Windows Explorer and to the Open menu item when you right-click on a file name). NTedit and NTSYS added to the Windows “Send to” folder.
• Plot and listing windows now have icons on the Windows taskbar. This makes it easier to find a window hidden under others.
• The “;” can now be used as an end of line character in batch files (any information after the ; is ignored).

New modules:

• AUTOREGR - Fits data using an autoregressive model.

• FOURPLOT – Plot outlines and estimated outlines using Fourier coefficients computed in the FOURIER module.
• FREQ - Compute frequencies of traits such as alleles, genotypes, etc. Also provides transformations for proportions.
• PROCRUSTES – Procrustes superimposition of coordinates of 2D or 3D landmarks on specimens or superimpositions of multivariate ordinations of any dimension. Left-click on a point to identify it.
• PROCPLOT – 2D and 3D plot of the results of a Procrustes superimposition.
• MULREG – generalized multivariate multiple regression. Can be used to perform simple bivariate regression, multiple regression, multivariate regression, and generalized least-squares regression (as used for the comparative method).
• PLOT – Plot one or more columns of a rectangular matrix against a selected column. Points can be given different symbols and connected by lines.

Improved modules:

• CONSEN – Input trees can be in the nexus file format.

• COPH – Input tree can be in the nexus format. Path length (additive) distances and Phylogenetic covariances can be computed in addition to the usual ultrametric distances.
• CORRESP – Note: suppressed some of the listing output unless “Show details” is checked.
• CVA – Can now compute canonical variates scores for individual observations.
• EIGEN – Note: suppressed some of the listing output unless “Show details” is checked.
• FOURIER – Note: many changes were made to make this module more useful. Added Fourier analysis of coordinates of points treated as a sequence of complex numbers. Linked to the new FOURPLOT module for direct viewing of the results.
• MDSCALE – Increased maximum size from 255 to 511 points.
• MOD3D – Rewritten to provide interactive 3D rotation (drag with the mouse) and better axis labeling. Different symbols can be given to different points. 3D biplots can be produced.
• MST – Note: suppressed some of the listing output unless “Show details” is checked.
• MXCOMP – The Smouse-Long-Sokal 3-way Mantel test has been added along with the additional plots it requires.
• MXPLOT – Points can be given different symbols. 2D biplots can be produced.
• NJOIN – Completely rewritten to greatly increase its speed. Large datasets (more than 500 OTUs) can now be processed. Results can be saved in nexus format or as an extended NTS tree format that allows for unequal heights of the OTUs in the tree. An option has been added for unweighted neighbor-joining trees.
• OUTPUT – Supports Excel files, the new tree format, and nexus files.
• POOLVC – Allows missing values in data when computing the mean and covariance matrices.
• TPSWTS – For convenience, it now includes the Procrustes superimposition step (note: the REF parameter has been deleted and several new ones added). It also now provides an estimate of the uniform component for 3D data.
• TRANSF – Added ABS transformation. Added DELR to delete a randomly selected row (or column) within a specified range. DELRX also deletes but will skip over those that are already deleted.
• TREE – Can now plot trees with unequal heights of the OTUs. It can also read nexus tree files. The yu and d keys can be used to scroll through a tree with many OTUs. The + and – keys can be used to increase or decrease the number of OTUs/page.

NTedit:

• Can now directly read rectangular matrices from Excel files (the DDE and OLE methods are no longer used) and from CSV files.

• Can now save files in the MATLAB *.m file format.
• A new text-mode display allows NTedit to be used to edit any ASCII file (including NTSYSpc batch command files). Files sizes up to 16MB with line lengths up to 32K can be edited in text mode. Standard cut, copy, paste, search, replace, and other text editing commands are supported.
• The current matrix or file being edited can now be printed from within the editor.

For those just now upgrading from version 1.80 (for DOS), the changes from version 1.8 to version 2.0 are listed below.

When the old DOS program was converted to Windows major changes had to be made in the user interface. The way in which the program is used was preserved. Some of the major changes are listed below.

• The entry forms have been simplified and the listing results are saved to a Listing notebook window where you can save, delete, or edit the results. You can also cut and paste them into other software.

• Input file formats: there is no longer a length restriction to the input lines (they were limited to just 255 characters). Long names permit more descriptive identifiers — often very important in more complicated analyses involving many files.
• A new NTedit program replaces the previous NTEDITOR program. The new program recognizes the various file formats and displays files in a spreadsheet-like grid.
• Graphics: Can now call up the appropriate graphics modules directly from many of the computational modules. The entry forms for the graphics programs have also been simplified since the graphic options are now available from option dialog boxes brought up by clicking on a plot with the right mouse button. You can now control the colors, fonts, line widths, etc. of most aspects of the plots.
• Batch files have been changed to allow both longer lines and the ability to have continuation lines for a command. The program now requires that the start of each command begin with an “*”.
• The information in the previous User Manual has been divided into this User Guide and the very extensive help file. The help file contains the detailed technical descriptions of each computational module. Sections can be printed from the help file if you want the information in a printed form. This User Guide contains only general information about how to use the program.

Note: In batch files the name of a module must now begin with an asterisk (*). In the CPCA module the batch code for the array of group sizes was changed from “N” to “GS” (this was done because a new parameter giving the number of dimensions was added). Since this module is used with the CVA and POOLVC modules, the same change was made in them also. Other changes include: NTedit program which can import Excel spreadsheets , no limit on the length of input lines and no limit on the number of groups in POOLVC. At present MXPLOT does not support the matrix of plots feature.


Internal error codes

Navigation: Technical support & updates >

Internal error codes

While users should never see these system error codes, they are provided here as a reference because they sometimes occur. Only the codes marked with an asterisk (*) are likely to be caused by a user error. If you receive one of the other error codes then please contact us as soon as possible. Please provide a description of the situation leading up to this problem. It usually helps to provide copies of the relevant input files. Please also let us know if you obtain any other mysterious error codes.

Code | Meaning | Notes
2 | File not found |
3 | Path not found |
4 | Too many open files |
5 | Access denied |
8 | Not enough memory |
11 | Bad format |
12 | Invalid access |
13 | Invalid data |
14 | Not enough memory |
15 | Invalid drive |
19 | Write protect |
21 | Not ready |
23 | CRC error |
26 | Not DOS disk |
27 | Sector not found |
28 | Out of paper |
29 | Write fault |
30 | Read fault |
32 | Sharing violation |
33 | Lock violation |
34 | Wrong disk |
39 | Disk full |
53 | Bad net path |
54 | Network busy |
61 | Print queue full |
62 | No spool space |
65 | Network access denied |
80 | File exists |
86 | Invalid password |
88 | Net write fault |
100* | Disk read error | Attempt to read past the end of the file.
101* | Disk write error | Disk full. You could try a different disk drive.
102 | File not assigned | File variable not assigned.
103 | File not open | Attempt to read or write an unopened file.
104 | File not open for input | Attempt to read from an unopened file.
105 | File not open for output | Attempt to write to an unopened file.
106* | Invalid numeric format | Numeric value read from a text file does not conform to the proper numeric format.
200 | Division by zero |
201 | Range check error |
202 | Stack overflow | Program ran out of memory
203 | Heap overflow error | Program ran out of memory
204 | Invalid pointer operation |
205 | Floating point overflow | Number is too large
206 | Floating point underflow | Number is too small
207 | Invalid floating point operation |
215 | Arithmetic overflow (integer only) | Number is too large
216 | Access violation |


References

Navigation: References cited >

References

Adams and Rohlf (2000)

Anderson (1965)

Atteson (1997)

Balakrishnan and Sanghvi (1968)

Bartlett (1950)

Bartlett (1951a)

Bartlett (1951b)

Bookstein (1982)

Bookstein (1986a)

Bookstein (1986b)

Bookstein (1989)

Bookstein (1991)

Bookstein (1996)

Bookstein et al. (1982)

Burnaby (1966)

Cavalli-Sforza and Edwards (1967)

Centroid size

Clarkson (1988)

Darroch and Mosimann (1985)

Dice (1945)

Dunn and Everitt (1982)

Everitt and Dunn (1992)

Farris (1972)

Ferson et al. (1985)

Flury (1984)

Flury (1988)

Flury and Constantine (1985)

Gabriel (1971)

Gabriel (1972)

Gabriel (1980)

Gabriel (1981)

Gabriel and Ordoroff (1986)

Gascuel (1997)

Gorsuch (1983)

Gower (1966)

Gower and Ross (1969)

Graphics speed buttons

Greenacre (1984)

Greenacre and Underhill (1982)

Green and Suchey (1976)

Grewal (1962)

Grice (2001)

Haines and Crampton (2000)

Harris and Kaiser (1964)

Haman (1961)

Harman (1967)

Hart (1983)

Hartigan and Wong (1979)

Hawkins (1974)

Hendrickson and White (1964)

Hillis (1984)

Horn (1966)

Hubert (1987)

Humphries et al. (1981)

Jaccard (1908)

Jackson (1991)

Johnson and Wichern (2002)

Joliffe (1986)

Jukes and Cantor (1969)

Kaiser (1958)

Katz and Rohlf (1974)

Katz and Rohlf (1975)

Kim, Rohlf, and Sokal (1992)

Klahr (1969)

Kline (1994)

Kruskal (1964a)

Kruskal (1964b)

Krzanowski (1988)

Kuhl and Giardina (1982)

Kulczynski (1927)

Landry and Lapointe (1996)

Lapointe and Legendre (1992)

Lattin, Carroll, and Green (2002)

Lebart et al. (1984)

Legendre and Legendre (1983)

Lestrel (1997)

Lohmann (1983)

Mantel (1967)

Margush and McMorris (1981)

McDonald (1981)

Mickevich (1980)

Milligan and Cooper (1987)

Morisita (1959)

Morrison (2005)

Mulaik (1972)

Nei (1972)

Nei (1978)

Nei and Li (1979)

Ochiai (1957)

Oden and Sokal (1992)

OTU

Pielou (1984)

Press et al. (1989)

Rao and Toutenburg (1999)

Renkonen (1938)

Reyment (1991)

Reyment and Jőreskog (1996)

Rogers (1972)

Rogers and Tanimoto (1960)

Rohlf (1970)

Rohlf (1972)

Rohlf (1973)

Rohlf (1975a)

Rohlf (1975b)

Rohlf (1977)

Rohlf (1982)

Rohlf (1986)

Rohlf (1993)

Rohlf (1990)

Rohlf (1995)

Rohlf (1996)

Rohlf (1998)

Rohlf (1999)

Rohlf (2000a)

Rohlf (2000b)

Rohlf (2002)

Rohlf (2001)

Rohlf (2006)

Rohlf and Archie (1984)

Rohlf and Bookstein (1988)

Rohlf and Bookstein (2003)

Rohlf and Corti (2000)

Rohlf and Fisher (1968)

Rohlf, Loy, and Corti (1996)

Rohlf and Marcus (1993)

Rohlf and Slice (1990)

Rohlf and Sokal (1981)

Russel and Rao (1940)

Saitou and Nei (1987)

Sampson et al. (1989)

Schuh and Farris (1981)

Slice (1992)

Slice, Rohlf, and Bookstein (1996)

Smouse et al. (1986)

Sneath and Sokal (1973)

Sokal (1979)

Sokal and Rohlf (1981)

Sokal and Sneath (1963)

Somers (1986)

Sørensen (1948)

Spence (1972)

Spence and Ogilvie (1973)

Steinley (2006)

Stewart, G. W. (1993)

Stinebrickner (1984)

Studier and Keppler (1988)

Swofford and Olsen (1990)

Tanimoto, T. T. (1958)

Tataryn, Wood, and Gorsuch (1999)

ten Berge, Krijnen, Wansbeek, and Shapiro (1999)

Thurstone (1935)

Thurstone (1947)

Timm (2002)

Ultrametric

Wallace and Wintz (1980)

Weir (1989)

White and Prentice (1987)

Wright (1978)

Yule (1911)

Zahn and Roskies (1972)


.topic 1053
   Babaei, A., S. R. Tabaei-Aghdaei, M. Khosh-Khui, R. Omidbaigi, M. R. Naghavi, G. D. Esselink (2007)
Babaei, A., S. R. Tabaei-Aghdaei, M. Khosh-Khui, R. Omidbaigi, M. R. Naghavi, G. D. Esselink. 2007. Microsatellite analysis of Damask rose (Rosa damascena Mill.) accessions from various regions in Iran reveals multiple genotypes. BMC Plant Biol., 7:12. doi: 10.1186/1471-2229-7-12.

.topic 211
   Babaei et al. (2007)
Babaei, A., Tabaei-Aghdaei, S.R., Khosh-Khui, M., Omidbaigi, R., Naghavi, M.R., Esselink, D., Smulders, M.J.M., 2007. Microsatellite analysis of Damask rose (Rosa damascene Mill.) accessions from various regions reveals multiple genotypes. BMC Plant Biol, 10: 7-12.

.topic 212
   Balestre et al. (2008)
Balestre, M., R.G. Von Pinho, J.C. Souza and J.L. Lima. 2008. Comparison of maize similarity and dissimilarity genetic coefficients based on microsatellite markers. Genetics and Molecular Research, 7 (3): 695-705.

.topic 1055
   Balestre, M., R.G. Von Pinho, J.C. Souza and J.L. Lima (2008)
Comparison of maize similarity and dissimilarity genetic coefficients based on microsatellite markers. Genet. Mol. Res., 7: 695-705.

.topic 209
   Feulner, P.G.D., W. Bielfeldt, F. E. Zachos, J. Bradvarovic, I Eckert, and G. B.  Hartl. (2004)
Mitochondrial DNA and microsatellite analyses of the genetic status of the presumed subspecies Cervus elaphus montanus (Carpathian red deer). Heredity, 93:299-306.

.topic 178
   Green and Suchey (1976)
Green, R. F. and J. M. Suchey. 1976. The use of inverse sine transformations in the analysis of non-metric cranial data. American Journal of Physical Anthropology. 45:61-68.
.topic 177
   Grewal (1962)
Grewal, M. S. 1962. The rate pf genetic divergence of sublines in the C57BL strain of mice. Genetic. Res., Camb. 3:226-237.
.topic 129
   Adams and Rohlf (2000)
Adams, D. C. and F. J. Rohlf. 2000. Ecological character displacement in Plethodon: Biomechanical differences found from a geometric morphometric study. Proceedings of the National Academy of Science (USA), 97:4106-4111.
.topic 25
  Anderson (1965)
Anderson, T. W. 1965.  Some optimum confidence limits for roots of detrimental equations. Ann. Math. Stat., 36:468-488.
.topic 173
   Atteson (1997)
Atteson, K. 1997. The performance of the neightbor-joining method of phylogeny reconstruction.  Pp. 133-147 in B. Mirkin, F. R. McMorris, F. S. Roberts, and A. Rzhetsky, eds. Mathematical hierarchies and biology. DIMACS series in discrete mathematics and theoretical computer science, Vol. American Mathematical Society, Providence, R.I.
.topic 26
  Balakrishnan and Sanghvi (1968)
Balakrishnan and Sanghvi. 1968.
.topic 27
  Bartlett (1950)
Bartlett, M. S. 1950. Tests of significance in factor analysis. Br. J. Psych., 28:97-104.
.topic 28
  Bartlett (1951a)
Bartlett, M. S. 1951a. The effect of standardization on a 2 approximation in factor analysis.  Biometrika, 38:337-344.
.topic 29
  Bartlett (1951b)
Bartlett, M. S. 1951b. A further note on tests of significance in factor analysis. Brit. J. Psych. Stat. Sec., 4:1-2.
.topic 30
  Bookstein (1982)
Bookstein, F. L. 1982.  The geometric meaning of soft modeling, with some generalizations.  In Joreskog, K. G.  and Wold, H. (eds.) Systems under indirect observation: causality-structure-prediction, vol. II.  Amsterdam: North-Holland.  Pp. 55-74.
.topic 31
  Bookstein (1986a)
Bookstein, F. L. 1986a. Size and shape spaces in two dimensions. (With discussion and rejoinder).  Stat. Sci., 1:181-242.
.topic 32
  Bookstein (1986b)
Bookstein, F. L. 1986b. The elements of latent variable models.  Advances in developmental psychology, 4:203-230.
.topic 33
  Bookstein (1989)
Bookstein, F. L.  1989b.  Principal warps: Thin-plate splines and the decomposition of deformations.  I.E.E.E. Transactions on Pattern Analysis and Machine Intelligence, 11:567-585.
.topic 34
  Bookstein (1991)
Bookstein, F. L. 1991.  Morphometric tools for landmark data.  Cambridge Univ. Press: New York, 435 pp.
.topic 35
  Bookstein (1996)
Bookstein, F. L. 1996. Standard formula for the uniform shape component in landmark data. Pp.  153-168 in Marcus, L. F., M. Corti, A. Loy, G. Naylor, and D. E. Slice (eds.)  Advances in Morphometrics. Proceedings of the 1993 NATO Advanced Studies Institute on Morphometrics in Il Ciocco, Italy. Plenum Publishing Corp., New York.
.topic 137
  Bookstein et al. (1982)
Bookstein, F. L., Straus, R. E., Humphries, J. M., Chernoff, B. C., Elder, R. L., and Smith, G. R. 1982. A comment upon the uses of Fourier methods in systematics. Systematic Zool., 31:85-92.
.topic 36
  Burnaby (1966)
Burnaby, T. P. 1966. Growth-invariant discriminant functions and generalized distances. Biometrics, 22:96-110.
.topic 37
  Cavalli-Sforza and Edwards (1967)
Cavalli-Sforza, L. L. and A. W. F. Edwards. 1967. Phylogenetic analysis: models and estimation procedures. Evol., 32:550-570.
.topic 38
  Clarkson (1988)
Clarkson, D. B. 1988.  A remark on algorithm AS 211.  The F-G diagonalization algorithm.  Applied Stat., 37:147-151.
.topic 40
  Darroch and Mosimann (1985)
Darroch, J. N. and J. E. Mosimann. 1985. Canonical and principal components of shape. Biometrika, 72:241-252.
.topic 41
  Dice (1945)
Dice, L. R. 1945. Measures of the amount of ecologi8c association between species.  Ecology, 26:297-302.
.topic 42
  Dunn and Everitt (1982)
Dunn, G. and B. S. Everitt. 1982. An introduction to mathematical taxonomy. Cambridge. New York. 152 pp.
.topic 43
  Everitt and Dunn (1992)
Everitt, B. S. and Dunn, G. 1992.  Applied multivariate data analysis.  Oxford Univ. Press: New York.  304 pp.
.topic 44
  Farris (1972)
Farris, J. S. 1972. Estimating phylogenetic trees from distance matrices. Amer. Natur., 106:645-668.
.topic 45
  Ferson et al. (1985)
Ferson, S., F. J. Rohlf, and R. K. Koehn. 1985.  Measuring shape variation of two-dimensional outlines.  Systematic Zool., 34:59-68.
.topic 46
  Flury (1984)
Flury, B. N. 1984. Common principal components in k groups.  J. Amer. Statist. Assn., 79:892-898.
.topic 47
  Flury (1988)
Flury, B. 1988. Common principal components and related multivariate models.  Wiley: New York. 258 pp.
.topic 39
  Flury and Constantine (1985)
Flury, B. N. and G. Constantine. 1985. The F-G diagonalization algorithm. Applied Stat., 35:177-183.
.topic 151
  Gabriel (1971)
Gabriel, K. R. 1971. The biplot - graphic display of matrices with application to principal component analysis. Biometrika, 58: 453-467.
.topic 152
  Gabriel (1972)
Gabriel, K. R. 1972. Analysis of meteorological data by means of canonical decomposition and biplots. J. of Applied Meteorology, 11:1071-1077.
.topic 153
  Gabriel (1980)
Gabriel, K. R. 1980. Biplot. In Johnson, N. L. and Kotz, S. (eds.) Encyclopedia of Statistical Scciences, vol. 1. Wiley: New York.
.topic 154
  Gabriel (1981)
Gabriel, K. R. 1981. Biplot display of multivariate matrices for inspection of data and diagnosis. Pp. 147-173 in Barnett, V. Interpreting multvariate data. Wiley, New York.
.topic 155
  Gabriel and Ordoroff (1986)
Gabriel, K. and Odoroff, C. L. 1986. Illustrations of model diagnosis by means of three-dimensional biplots.  Pp. 257-274 in Wegman, E.J. and DePriest, D.J. (eds.). Statistical image processing and graphics, Marcel Dekker, New York.
.topic 172
   Gascuel (1997)
Gascuel, O. 1997. Concerning the NJ algorithm and its unweighted version, UNJ. Pp. 149-170 in B. Mirkin, F. R. McMorris, F. S. Roberts, and A. Rzhetsky, eds. Mathematical hierarchies and biology. DIMACS series in discrete mathematics and theoretical computer science, Vol. American Mathematical Society, Providence, R.I.
.topic 196
   Gorsuch (1983)
Gorsuch, R. L. 1983. Factor analysis. 2nd ed. Lawrence Erlbaum Assoc.: Hillsdale, NJ.
.topic 48
  Gower (1966)
Gower, J. C. 1966. Some distance properties of latent root and vector methods used in multivariate analysis. Biometrika, 53:325-338.
.topic 49
  Gower and Ross (1969)
Gower, J. C. and G. J. S. Ross. 1969. Minimum spanning trees and single-linkage cluster analysis. Applied Statistics, 18:54-64.
.topic 50
  Greenacre (1984)
Greenacre, M. J. 1984. Theory and applications of correspondence analysis. Academic Press. New York. 364 pp.
.topic 51
  Greenacre and Underhill (1982)
Greenacre, M. J. and L. G. Underhill. 1982. Scaling a data matrix in a low-dimensional Euclidean space. In Hawkins, D. M. (ed). Topics in applied multivariate analysis. Cambridge Univ. press. New York. pp. 183-268.
.topic 200
   Grice (2001)
Grice, J. W. 2001. Computing and evaluating factor scores. Psychological Methods, 6: 430-450.
.topic 181
   Haines and Crampton (2000)
Haines, A. J. and J. S. Crampton. 2000. Improvements to the method of Fourier shape analysis as applied in morphometric studies. Paleontology, 43:765-783.
.topic 52
  Hamann (1961)
Hamann, U. 1961. Merkmalbestand und Verwandtschaftsbeziehungen der Farinosae. Ein Beitragzum System der Monokotyledonen. Willdenowia, 2:639-768.
.topic 193
   Harman (1967)
Harman, H. H. 1967. Modern factor analysis. 2nd edition. Univ. of Chicago Press: Chicago. 474 pp.
.topic 201
   Harris and Kaiser (1964)
Harris, C. W.  and H. F. Kaiser. 1964. Oblique factor analytical solutions by orthogonal transformations. Psychometrika, 29: 347-362.
.topic 133
  Hart (1983)
Hart, G. 1983. The occurrence of multiple UPGMA phenograms.  In Felsenstein, J. (ed.). Numerical Taxonomy. Springer-Verlag. New York. pp. 254-258.
.topic 3017
Hartigan, J., and M. A. Wong. 1979. Algorithm AS 136: A k-means clustering algorithm. Applied Statistics 28:100-108.
.topic 53
  Hawkins (1974)
Hawkins. 1974.
.topic 186
   Hendrickson and White (1964)
Hendrickson, A. E. and P. O. White. 1964. PROMAX: a quick method for rotation to oblique simple structure. British j. of Statistical Psychology. 17:65-70.
.topic 54
  Hillis (1984)
Hillis, D. M. 1984. Misuse and modification of Nei's genetic distance. Syst. Zool., 33:238-240.
.topic 55
  Horn (1966)
Horn, H. S. 1966. Measurement of "overlap" in comparative ecological studies. Amer. Nat., 100:419-424.
.topic 56
  Hubert (1987)
Hubert, L. J. 1987. Assignment methods in combinatorial data analysis. Marcel Dekker. New York. 326.
.topic 57
  Humphries et al. (1981)
Humphries, J. M., F. L. Bookstein, B. Chernoff, G. R. Smith, R. L. Elder, and S. G. Poss. 1981. Multivariate discrimination by shape in relation to size. Systematic Zool., 30:291-308.
.topic 58
  Jaccard (1908)
Jaccard, P. 1908. Nouvelles rescherches sur la distribution florale.  Bull. Soc. Vaud. Sci. Nat., 44:223-270.
.topic 59
  Jackson (1991)
Jackson, J. E. 1991. A user’s guide to principal components. Wiley: New York.  569 pp.
.topic 203
   Johnson and Wichern (2002)
Johnson, R. A. and D. W. Wichern. 2002. Applied multivariate statistical analysis. 5th ed. Prentice Hall.
.topic 60
  Joliffe (1986)
Joliffe, I. T. 1986. Principal component analysis. Springer-Verlag: New York.
.topic 61
  Jukes and Cantor (1969)
Jukes, T. H. and C. R. Cantor. 1969. Evolution in protein molecules. H. N. Munro (ed.). Mammalian Protein Metabolism. Academic Press. New York., pp. 21-123.
.topic 187
   Kaiser (1958)
Kaiser, H. F. 1958. The varimax criterion for analytic rotation in factor analysis. Phsychometrika, 23:187-200.
.topic 188
   Katz and Rohlf (1974)
Katz, J. O. and F. J. Rohlf. 1974. Functionplane – a new approach to simple structure rotation. Psychometrika, 39:37-52.
.topic 189
   Katz and Rohlf (1975)
Katz, J. O. and F. J. Rohlf. 1975. Primary product funcitonplane: an oblique rotation to simple structure. Multivariate Behavioral research, 10: 219-232.
.topic 62
  Kim, Rohlf, and Sokal (1992)
Kim, J.., F. J. Rohlf, and R. R. Sokal. 1992. The accuracy of phylogenetic estimation using the neighbor-joining method. Evolution, 47:471-486.
.topic 63
  Klahr (1969)
Klahr, D. A. 1969.  A Monte Carlo investigation of the statistical significance of Kruskal’s nonmetric scaling procedure.  Psychometrika, 34:319-330.
.topic 195
   Kline (1994)
Kline, P. 1994. An easy guide to factor analysis. Routledge: New York. 194 pp.
.topic 64
  Kruskal (1964a)
Kruskal, J. B. 1964a. Multidimensional scaling by optimizing goodness of fit to a nonmetric hypothesis. Psychometrika, 29:1-27.
.topic 65
  Kruskal (1964b)
Kruskal, J. B. 1964b. Nonmetric multidimensional scaling: a numerical method. Psychometrika, 29:28-42.
.topic 66
  Krzanowski (1988)
Krzanowski, W. J. 1988. Principles of multivariate analysis: a user’s perspective.  Clarendon Press: Oxford.  563 pp.
.topic 67
  Kuhl and Giardina (1982)
Kuhl, F. P. and C. R. Giardina. 1982. Elliptic Fourier features of a closed contour.  Computer Graphics and Image Processing, 18: 236-258.
.topic 68
  Kulczynski (1927)
Kulczynski, S. 1927. Die Pflanzenassoziationen der Pienienen.  Bull. Intern. Acad. Pol. Sci. Lett. Cl. Sci. Math. Nat., B (Sci. Nat.), 1927(Suppl. 2):57-203.
.topic 69
  Lapointe and Legendre (1992)
Lapointe, F.J. and P. Legendre.  1992.  Statistical significance of the matrix correlation coefficient for comparing independent phylogenetic trees.  Systematic Biology, 41:378-384.
.topic 205
   Lattin, Carroll, and Green (2002)
Lattin, J., D. Carroll, and P. Greenl. 2002. Analyzing Multivariate Data. Duxbury Press.
.topic 70
  Lebart et al. (1984)
Lebart, L., A. Morineau, K. M. Warwick. 1984. Multivariate descriptive statistical analysis. Wiley. New York. 231 pp.
.topic 71
  Legendre and Legendre (1983)
Legendre, L., and P. Legendre. 1983. Numerical Ecology. Elsevier. New York. 419 pp.
.topic 72
  Lestrel (1997)
Lestrel, P. 1997. Fourier descriptors and their applications in biology. Cambridge Univ. Press: New York, 466 pp.
.topic 73
  Lohmann (1983)
Lohmann, G. P. 1983. Eigenshape analysis of microfossils:  a general morphometric procedure for describing changes in shape. Math. Geol., 15:659-672.
.topic 126
   Lynch, M. (1990)
Lynch, M. 1990. The similarity index and DNA fingerprinting. Molecular Biology and Evolution, 7:478-484.
.topic 74
  Mantel (1967)
Mantel, N. A. 1967. The detection of disease clustering and a generalized regression approach. Cancer Res., 27:209-220.
.topic 75
  Margush and McMorris (1981)
Margush, T. and F. R. McMorris. 1981. Consensus n-trees. Bull. Math. Biol., 43:239-244.
.topic 198
   McDonald (1981)
McDonald, R. P. 1981. Constrained least squares estimators of oblique common factors. Psychometrika, 46: 337-341.
.topic 76
  Mickevich (1980)
Mickevich, M. F. 1980. Taxonomic congruence: Rohlf and Sokal's misunderstanding. Syst. Zool.. 29:162-176.
.topic 206
   Milligan and Cooper (1987)
Milligan, G.W. and M. C. Cooper. 1987. A Study of Variable Standardization," College of Administrative Science Working Paper Series, 87 -63, Columbus, OH: The Ohio State University.

.topic 77
  Morisita (1959)
Morisita, M. 1959. Measuring of interspecific association and similarity between communities.. Mem. Fac. Sci. Kyushu U., ser. E (Biol.), 3:65-80.
.topic 202
   Morrison (2005)
Morrison, D. F. 2005. Multivariate statistical methods. 4th ed. Brooks/Cole Thompson Learning.
.topic 190
   Mulaik (1972)
Mulaik, S. A. 1972. The foundations of factor analysis. McGraw-Hill: New York. 453 pp.
.topic 171
   Oden and Sokal (1992)
Oden, N. and R. R. Sokal. 1992. An investigation of three-matrix permutation tests. Journal of Classification, 9:275-290.
.topic 82
  OTU
Operational Taxonomic Unit.  A general term for the objects (specimens, species, etc.) being classified.
.topic 83
  Pielou (1984)
Pielou, E. C. 1984. The interpretation of ecological data. Wiley. New York. 263 pp.
.topic 168
   Press et al. (1989)
Press, W. H., B. P. Flannery, S. A. Teukolsky, and W. T. Vetterling. 1989. Numerical recipes. Cambridge. New York. 759 pp.
.topic 125
   Rao and Toutenburg (1999)
Rao, C. R. and H. Toutenburg. 1999. Linear models: least squares and alternatives, second edition. Springer: New York.427 pp.
.topic 86
  Reyment (1991)
Reyment, R. A. 1991. Multidimensional paleobiology. Pergamon Press: New York, 377 pp.
.topic 194
   Reyment and Joreskog (1996)
Reyment, R. and L. G. Joreskog 1996. Applied factor analysis in the natural sciences. Appendix by Leslie F. Marcus. Cambridge Univ. Press: New York. 371 pp.
.topic 87
  Rogers (1972)
Rogers, J. S. 1972. Measures of genetic similarity and genetic distance. Studies in Genet. VII. Univ. Texas Publ., 7213:145-153.
.topic 89
  Rohlf (1970)
Rohlf, F. J. 1970. Adaptive hierarchical clustering schemes. Systematic Zool., 19:58-82.
.topic 90
  Rohlf (1972)
Rohlf, F. J. 1972. An empirical comparison of three ordination techniques in numerical taxonomy. Systematic Zool., 21:271-280.
.topic 91
  Rohlf (1973)
Rohlf, F. J. 1973. Algorithm 76.  Hierarchical clustering using the minimum spanning tree. Computer J., 16:93-95.
.topic 92
  Rohlf (1975a)
Rohlf, F. J. 1975a. Note on Algorithm 81: Dendrogram plot. Computer J., 18:90-92.
.topic 93
  Rohlf (1975b)
Rohlf, F. J. 1975b. Generalization of the gap test for the detection of multivariate outliers. Biometrics, 31:93-101.
.topic 156
  Rohlf (1977)
Rohlf, F. J. 1977. Computational efficiency of agglomerative cluster-ing algorithms. IBM Watson Research Center.  RC no. 6831, 36 pp.
.topic 94
  Rohlf (1982)
Rohlf, F. J. 1982. Consensus indices for comparing classifications. Math. Biosci., 59:131-144.
.topic 135
  Rohlf (1986)
Rohlf, F. J. 1986. Relationships among eigenshape analysis, Fourier analysis, and analysis of coordinates. Math. Geology, 18:845-854.
.topic 96
  Rohlf (1990)
Rohlf, F. J. 1990. Fitting curves to outlines.  pp. 167-177 in Rohlf, F. J. and F. L. Bookstein (eds.) Proceedings of the Michigan Morphometrics Workshop.  Museum of Zoology special publication no. 2, University of Michigan.
.topic 95
  Rohlf (1993)
Rohlf, F.J. 1993. Relative warp analysis and an example of its appli­cation to mosquito wings.  In Contributions to Morphometrics, (Marcus, L.F., Bello, E. García-Valdecasas, A. eds.). Museo Nacional de Ciencias Naturales (CSIC), Vol. 8. Madrid, Spain.
.topic 162
   Rohlf (1995)
Rohlf, F. J. 1995. Statistical analysis of shape using partial-warp scores.  In Mardia, K. V. and Gill, C. A. (eds.)  Proceedings in Current Issues in Statistical Shape Analysis, Leeds Univ. Press. pp. 154-158.
.topic 160
   Rohlf (1996)
Rohlf, F. J. 1996. Morphometric spaces, shape components, and the effects of linear transformations. Pp.  117-129 in Marcus, L. F., M. Corti, A. Loy, G. Naylor, and D. E. Slice (eds.)  Advances in Morphometrics. Proceedings of the 1993 NATO Advanced Studies Institute on Morphometrics in Il Ciocco, Italy. Plenum Publishing Corp., New York.
.topic 131
   Rohlf (1998)
Rohlf, F. J. 1998.  On applications of geometric morphometrics to studies of ontogeny and phylogeny.  Systematic Biology, 47:147-158.
.topic 2
   Rohlf (1999)
Rohlf, F. J. 1999. Shape statistics: Procrustes superimpositions and tangent spaces. Journal of Classification, 16:197-223.
.topic 4
   Rohlf (2000a)
Rohlf, F. J. 2000. On the use of shape spaces to compare morphometric methods. Hystrix, Italian J. Mammology (n.s.), 11(1):8-24.
.topic 127
   Rohlf (2000b)
Rohlf, F. J. 2000. Statistical power comparisons among alternative morphometric methods. Amer. J. Phys. Anthropol. 111:463-478.
.topic 185
   Rohlf (2001)
Rohlf, F. J. 2001. Comparative methods for the analysis of continuous variables: geometric interpretations. Evolution 55: 2143-2160.
.topic 208
   Rohlf (2002)
Rohlf, F. J. 2002. Geometric morphometrics in phylogeny. Pp. 175-193 in Forey, P. and N. Macleod (eds.) Morphology, shape and phylogenetics. Francis & Taylor: London.
.topic 207
   Rohlf (2006)
Rohlf, F. J. 2006. A comment on "phylogenetic correction". Evolution. 60:1509-1515.

.topic 97
  Rohlf and Archie (1984)
Rohlf, F. J. and J. Archie. 1984. A comparison of Fourier   methods for the description of wing shape in mosquitoes   (Diptera: Culicidae). Systematic Zool., 33:302-317.
.topic 98
  Rohlf and Bookstein (1988)
Rohlf, F. J. and F. L. Bookstein. 1988. A comment on shearing as a method for "size correction". Systematic Zool., 36:356-367.
.topic 164
   Rohlf and Bookstein (2003)
Rohlf, F.J. and F. L. Bookstein. 2003. Computing the uniform component of shape variation. Systematic Biology, 52:66-69.

.topic 128
   Rohlf and Corti (2000)
Rohlf, F. J. and M. Corti. 2000. The use of two-block partial least-squares to study covariation in shape. Systematic Biology. 49:740-753.
.topic 99
  Rohlf and Fisher (1968)
Rohlf, F. J. and D. L. Fisher. 1968. Test for hierarchical structure in random data sets. Systematic Zool., 17:407-412.
.topic 136
  Rohlf and Marcus (1993)
Rohlf, F. J. and L. F. Marcus.  1993.  A revolution in morphometrics.  Trends in Ecology and Evolution, 8:129-132.
.topic 100
  Rohlf and Slice (1990)
Rohlf, F. J. and D. Slice. 1990.  Extensions of the Procrustes method for the optimal superimposition of landmarks.  Systematic Zoology, 39:40-59.
.topic 101
  Rohlf and Sokal (1981)
Rohlf, F. J. and R. R. Sokal. 1981. Comparing numerical taxonomic studies. Systematic Zool., 30:459-490.
.topic 132
   Rohlf, Loy, and Corti (1996)
Rohlf, F. J., Loy, A. and M. Corti.  1996.  Morphometric analysis of Old World Talpidae (Mammalia, Insectivora) using partial warp scores.  Systematic Biology, 45:344-362.
.topic 103
  Saitou and Nei (1987)
Saitou, N. and M. Nei. 1987. The neighbor-joining method: a new method for reconstructing phylogenetic trees.  Mol. Biol. Evol., 4:406-425.
.topic 104
  Sampson et al. (1989)
Sampson, P. D., Streissguth, A. P., Barr, H. M., and Bookstein, F. L. 1989. Neurobehavioral effects of prenatal alcohol.  Part II: partial least squares analysis.  Neurotoxicology and teratology, 11:477-491.
.topic 105
  Schuh and Farris (1981)
Schuh, R. T. and J. S. Farris. 1981. Methods for investigating taxonomic congruence and their application to the Leptopodomorpha. Syst. Zool., 30:331-351.
.topic 106
  Slice (1993)
Slice, D. E. 1993. Extensions, comparisons, and applications of superimposition methods for morphometric analysis.  Ph.D. dissertation. State Univ. of New York and Stony Brook.
.topic 161
   Slice, Rohlf, and Bookstein (1996)
Slice, D. E., F. J. Rohlf, and F. L. Bookstein 1996. Glossary. Pp. 531-551 in Marcus, L. F., M. Corti, A. Loy, G. Naylor, and D. E. Slice (eds.)  Advances in Morphometrics. Proceedings of the 1993 NATO Advanced Studies Institute on Morphometrics in Il Ciocco, Italy. Plenum Publishing Corp., New York.
.topic 107
  Smouse et al. (1986)
Smouse, P. E., J. C. Long, and R. R. Sokal. 1986. Multiple regression and correlation extensions of the Mantel test of matrix correspondence. Systematic Zool., 35:627-632.
.topic 108
  Sneath and Sokal (1973)
Sneath, P. H. A. and R. R. Sokal. 1973. Numerical Taxonomy. Freeman. San Francisco. 573 pp.
.topic 109
  Sokal (1979)
Sokal, R. R. 1979. Testing statistical significance of geographic variation patterns. Systematic Zool., 28:227-231.
.topic 110
  Sokal and Rohlf (1981)
Sokal, R. R. and F.J. Rohlf. 1981. Taxonomic congruence in the Leptopodomorpha re-examined.  Systematic Zool., 30:309-325.
.topic 111
  Sokal and Sneath (1963)
Sokal, R. R. and P. H. A. Sneath. 1963. Principles of Numerical Taxonomy. Freeman. San Francisco. 359 pp.
.topic 112
  Somers (1986)
Somers, K. M. 1986. Multivariate allometry and removal of size with principal components analysis. Systematic Zool., 35:359-368.
.topic 113
  Spence (1972)
Spence, I. 1972. A Monte Carlo evaluation of three nonmetric multidimensional scaling algorithms.  Psychometrika, 37:461-486.
.topic 114
  Spence and Ogilvie (1973)
Spence, I. and S. C. Ogilvie. 1973. A table of expected stress values for random rankings in nonmetric multidimensional scaling.  Mult. Behav. Res., 8:511-517.
.topic 3016
Enter topic text here.
.topic 3015
Sørensen, T. A. 1948. A method of establishing groups of equal amplitude in plant sociology based on similarity of species content, and its application to analyses of the vegetation on Danish commons. Kongelige Danske Videnskabernes Selskabs Biologiske Skrifter, 5:1-34.
.topic 3014
Steinley, D. 2006. K-means clustering: a half-century synthesis. British Journal of Mathematical and Statistical Phychology, 59:1-34.
.topic 140
  Stewart, G. W. (1993)
Stewart, G. W. 1993. On the early history of the singular value decomposition. SIAM Review, 35(4):551-566.
.topic 115
  Stinebrickner (1984)
Stinebrickner, R. 1984. s-Consensus trees and indices. Bull. Math. Biol. 46. 923-935.
.topic 116
  Studier and Keppler (1988)
Studier, J. A. and K. J. Keppler. 1988. A note on the neighbor-joining algorithm of Saitou and Nei.  Mol. Biol. Evol., 5:729-731.
.topic 117
  Swofford and Olsen (1990)
Swofford, D. L. and G. J. Olsen. 1990. Phylogeny reconstruction.  Pp. 411-501 in Hillis, D. M. and C. Moritz (eds.) Molecular systematics. Sinauer Assoc.: Sunderland, Mass.
.topic 3002
Tanimoto (1958)
Tanimoto, T. T. 1958. An elementary mathematical theory of classification and prediction, IBM Report (November, 1958), cited in: G. Salton, Automatic Information Organization and Retrieval (McGraw-Hill, 1968) p. 238.
.topic 191
   Tataryn, Wood, and Gorsuch (1999)
Tataryn, D. J. J. M. Wood, and R. L. Gorsuch. 1999. Setting the value of k in promax: a Monte Carlo study. Educationald and Psychological Measurement, 59:384-391.
.topic 197
   ten Berge, Krijnen, Wansbeek, and Shapiro (1999)
ten Berge, J., W. Krijnen, T. Wansbeek, and A. Shapiro. 1999. Some new results on correlation-preserving factor scores prediction methods. Linear Algebra and its applications, 289: 322-318.
.topic 199
   Thurstone (1935)
Thurstone, L. L.1935. The vectors of the mind. University of Chicago Press.
.topic 192
   Thurstone (1947)
Thurstone, L. L. 1947. Multiple factor analysis. Univ. of Chicago Press: Chicago.
.topic 204
   Timm (2002)
Timm, N. H. 2002. Applied Multivariate Analysis. Springer.
.topic 118
  Ultrametric
A generalization of the idea of a metric.  In addition to the usual requirements for a distance, the largest distance between 3 points must not be unique (i.e., there must be a tie for the largest distance).  Such distances correspond to the type of relationships implied in a hierarchical nested tree such as produced by the SAHN module.
.topic 180
   Wallace and Wintz (1980)
Wallace, T. P. and P. A. Wintz 1980. An efficient three-dimensional aircraft recognition algorithm using normalized Fourier descriptors. Computer Graphics Imaging Proceedings, 13:99-126.
.topic 134
  Weir (1989)
Weir, B. S. 1989. Building trees with DNA sequences. Biometric Bulletin, 6(4):21-23.
.topic 119
  White and Prentice (1987)
White, R. J. and H. C. Prentice. 1987.  Comparison of shape description methods for biological   outlines. H. H. Bock (ed.). Classification and Related Methods of Data Analysis. North-Holand. New York. 395-402.
.topic 120
  Wright (1978)
Wright, S. 1978. Evolution and the genetics of populations, vol. 4. Variability  within and among natural populations. U. Chicago Press. Chicago.
.topic 121
  Yule (1911)
Yule, G. U. 1911.
.topic 122
  Zahn and Roskies (1972)
Zahn, C. T. and Roskies, R. Z. 1972. Fourier descriptors for plane closed curves. IEEE Trans. Comput., C-21:269-281.
.topic 159
  Landry and Lapointe (1996)
Landry, P.A. and F.-J. Lapointe. 1996. RAPD problems in phylogenetics. Zoologica Scripta, 25:283-290.
.topic 210
   Whitehead, A. and D. L. Crawford. (2006)
Neutral and adaptive variation in gene expression. Pproceedings of the National Academy of Sciences (USA), 103:5425-5430.
Babaei et al. (2007)

.topic 1054
   Zegura, S. L., T. M. Karafet, L. A. Zhivotovsky, and M. F. Hammer (2004)
High-Resolution SNPs and Microsatellite Haplotypes Point to a Single, Recent Entry of Native American Y Chromosomes into the Americas. Mol. Biol. Evol., 21:164-175.

.topic 130
   Zeng, L.,  T.-R. Kwon, X. Liu, C. Wilson, C. M. Grieve , and G. B.  Gregorio . (2004)
Genetic diversity analyzed by microsatellite markers among rice (Oryza sativa L.) genotypes with different adaptations to saline soils. Plant Science, 166:1275-1285.


3D plot cursors

Navigation: »No topics above this level«

3D plot cursors

Special cursors used in 3D plots

xlftrot | Rotate around the horizontal direction
xrgtrot | Rotate around the horizontal direction
xyrot | Rotate in all directions
xyview | View plot as Y vs. X
xyzhome | View plot from standard orientation
yrot | Rotate around the vertical direction
yzview | View plot as Z vs. Y
zrot | Rotate plot clockwise or counter clockwise
xzview | View plot as Z vs. X


Centroid size

Navigation: »No topics above this level«

Centroid size

The square root of the sum of squared distances of configuration of points to their centroid. Used as a statistical measure of size in geometric morphometrics.


Detailed list of recent changes

Navigation: »No topics above this level«

Detailed list of recent changes

Service releases (changes in increments of 0.01 and/or a letter suffix) are available at no charge to registered users of the major version (changes in increments of 0.1 or more):

Version 2.2: Added several new modules and major and minor changes to others. Released ??? 200?.


IDH_Nei_1972

Nei (1972)

Nei, M. 1972. Genetic distance between populations. Amer. Naturalist, 106:283-292.


IDH_Nei_1978

Nei (1978)

Nei, M. 1978. Estimation of average heterozygosity and genetic distance from a small number of individuals. Genetics., 89:583‑590.


IDH_Nei_and_Li_1979

Nei and Li (1979)

Nei, M. and W. H. Li. 1979. Mathematical model for studying genetic variation in terms of restriction endonucleases. Proc. Natl. Acad. Sci. USA, 76:5269-5273.


IDH_Ochiai_1957

Ochiai (1957)

Ochiai, A. 1957. Zoogeographic studies on the soleoid fishes found in Japan and its neighbouring regions. Bull. Jap. Soc. Sci. Fish., 22:526-530.


IDH_Renkonen_1938

Renkonen (1938)

Renkonen, O. 1938. Statisch-okologische Untersuchungen uber die terrestiche kaferwelt der finnischen bruchmoore.. Ann. Zool. Soc. Bot. Fenn. Vanamo, 6:1‑231.


IDH_Rogers_and_Tanimoto_1960

Rogers and Tanimoto (1960)

Rogers, D. G. and T. T. Tanimoto. 1960. A computer program for classifying plants. Science, 132:1115-1118.


IDH_Russel_and_Rao_1940

Russel and Rao (1940)

Russel, P. F. and T. R. Rao. 1940. On habitat and association of species of anopheline larvae in south-eastern Mdras. J. Malar. Inst. India, 3:153-178.